Bug 120927 - gnome-settings-daemon looks for XKB rules in a inexistent file
Summary: gnome-settings-daemon looks for XKB rules in a inexistent file
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
: 120928 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-15 12:00 UTC by Felipe Alfaro Solana
Modified: 2013-04-02 04:19 UTC (History)
3 users (show)

Fixed In Version: 2.8.0-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 23:23:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felipe Alfaro Solana 2004-04-15 12:00:17 UTC
Description of problem: 
gnome-settings-daemon from GNOME's control-center-2.6.0.3-2 
incorrectly looks for XKB keyboard rules 
in /usr/X11R6/lib/X11/xkb/rules/xfree86.lst. However, 
xorg-x11-6.7.0-0.4 does not provide such file. Instead, it provides 
xorg and xorg.lst. 
 
Since this file does not exists, gnome-settings-daemon complains 
with an error message during startup. A temporary fix is simple: 
create a symbolic link from /usr/X11R6/lib/X11/xkb/rules/xfree86.lst 
to /usr/X11R6/lib/X11/xkb/rules/xorg.lst. 
 
A partial strace from running gnome-settings-daemon looks like: 
 
open("/usr/X11R6/lib/X11/xkb/rules/xfree86-en_US.UTF-8.lst", 
O_RDONLY) = -1 ENOENT (No such file or directory) 
open("/usr/X11R6/lib/X11/xkb/rules/xfree86.lst", O_RDONLY) = -1 
ENOENT (No such file or directory) 
write(2, "\n** (gnome-settings-daemon:1437)"..., 87 
** (gnome-settings-daemon:1437): WARNING **: Could not activate the 
XKB configuration 
) = 87 
 
Thus, gnome-settings-daemon should be fixed to look for XKB rules in  
 /usr/X11R6/lib/X11/xkb/rules/xorg.lst instead. 
 
Version-Release number of selected component (if applicable): 
control-center-2.6.0.3-2 
xorg-x11-6.7.0-0.4 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Launch gnome-settings-daemon 
   
Actual results: 
gnome-settings-daemon complains with an error since it can't get XKB 
rules from a file that does not exist. 
 
Expected results: 
gnome-settings-daemon should look for XKB rules by looking in 
xorg.lst instead of xfree86.lst. 
 
Additional info:

Comment 1 Mike A. Harris 2004-04-19 19:12:26 UTC
*** Bug 120928 has been marked as a duplicate of this bug. ***

Comment 2 Mike A. Harris 2004-04-19 20:36:04 UTC
This is suspiciously a potential duplicate of bug #120858.  In
particular the following comment suggests this issue is fixed in
control-center 2.6.1:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=120858#c18

Please confirm wether upgrading your system to the newest
control-center 2.6.1 version, along with all other current rawhide
packages resolves this issue or not.



Comment 4 Felipe Alfaro Solana 2004-04-21 22:34:03 UTC
Upgrading to control-center-2.6.1, libxklavier-1.02, and then removing the 
following line 
 
Option      "XkbRules" "xfree86" 
 
from /etc/X11/XF86Config Works For Me. 

Comment 5 Felipe Alfaro Solana 2004-09-28 23:23:28 UTC
Seems fixed in control-center-2.8.0-8.


Note You need to log in before you can comment on or make changes to this bug.