Bug 120932 - Error activing XKB configuration
Error activing XKB configuration
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 08:56 EDT by José Salgado
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description José Salgado 2004-04-15 08:56:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Every time I've log in to the X I have the same error:

Error al activar la configuraci�n XKB.
(Error activating XKB configuration)
Probablemente un problema interno del servidor X.
(due an internal X server error)

Datos del servidor X:
The X.Org Foundation
60700000

The screen error told me to do this:
[root@iglu root]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "es", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "es", "", ""


and

[root@iglu root]# gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [es]
 model = pc105
 overrideSettings = false
 options = []




Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-0.4

How reproducible:
Always

Steps to Reproduce:
1. Log into the X


Actual Results:  I have the error screen, but whe I click on Ok, I can
work without problemas.

Expected Results:  Don't have this error screen :)

Additional info:
Comment 1 Jeffrey C. Ollie 2004-04-15 09:35:04 EDT
I get the same thing on my laptop:

[root@pc05987 root]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
[root@pc05987 root]# gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
Comment 2 Mark Howell 2004-04-15 22:13:36 EDT
On my Dell Inspiron 7500 notebook, PIII-700/550, 512MB SDRAM, ATI Rage
Mobility P video:

[root@marx root]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
[root@marx root]# gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []

Xorg versions:

[root@marx root]# rpm -qa | grep xorg
xorg-x11-base-fonts-6.7.0-0.4
xorg-x11-ISO8859-9-75dpi-fonts-6.7.0-0.4
xorg-x11-tools-6.7.0-0.4
xorg-x11-truetype-fonts-6.7.0-0.4
xorg-x11-75dpi-fonts-6.7.0-0.4
xorg-x11-Xvfb-6.7.0-0.4
xorg-x11-100dpi-fonts-6.7.0-0.4
xorg-x11-Mesa-libGL-6.7.0-0.4
xorg-x11-ISO8859-15-75dpi-fonts-6.7.0-0.4
xorg-x11-ISO8859-14-100dpi-fonts-6.7.0-0.4
xorg-x11-sdk-6.7.0-0.4
xorg-x11-xfs-6.7.0-0.4
xorg-x11-cyrillic-fonts-6.7.0-0.4
xorg-x11-twm-6.7.0-0.4
xorg-x11-libs-6.7.0-0.4
xorg-x11-ISO8859-15-100dpi-fonts-6.7.0-0.4
xorg-x11-syriac-fonts-6.7.0-0.4
xorg-x11-ISO8859-2-100dpi-fonts-6.7.0-0.4
xorg-x11-libs-data-6.7.0-0.4
xorg-x11-Mesa-libGLU-6.7.0-0.4
xorg-x11-devel-6.7.0-0.4
xorg-x11-xdm-6.7.0-0.4
xorg-x11-doc-6.7.0-0.4
xorg-x11-ISO8859-2-75dpi-fonts-6.7.0-0.4
xorg-x11-font-utils-6.7.0-0.4
xorg-x11-ISO8859-14-75dpi-fonts-6.7.0-0.4
xorg-x11-xauth-6.7.0-0.4
xorg-x11-Xnest-6.7.0-0.4
xorg-x11-6.7.0-0.4
xorg-x11-ISO8859-9-100dpi-fonts-6.7.0-0.4
[root@marx root]#
Comment 3 Sean Bruno 2004-04-16 00:18:41 EDT
I am getting the same error on my system after updating xorg.  Same
packages.

Here is my xprop output:
[sean@localhost sean]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""

Here is my gconftool output:
[sean@localhost sean]$ gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
Comment 4 Per Bjornsson 2004-04-16 00:56:51 EDT
Me too... xorg-x11-6.7.0-0.4

The effect of this seems to be that the keyboard switcher doesn't
work, the only layout used is the default "us-ascii" one.

The only difference from the listings above is that I hav set up
hotkey switching between two different keyboard layouts (US and
Swedish), as seen in the gconftool output:

 layouts = [us,se]
 model = pc105
 overrideSettings = false
 options = [grp grp:alt_shift_toggle]
Comment 5 VnPenguin 2004-04-16 01:04:39 EDT
Me too with xorg-x11-6.7.0-0.4

# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "be", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "be", "", ""

# gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = true
 options = []

There is no problem with older version of xorg.
Comment 6 Mike A. Harris 2004-04-16 04:07:08 EDT
Xorg until this week, still used the XFree86 X server name, log
file and config file, and other files.  It no longer uses the
trademarked XFree86 name anymore.  The xkbrules file for XFree86
is named "xfree86" and the one for Xorg is now named "xorg".

This problem is caused because your config file explicitly has

    Options "XkbRules" "xfree86"

in it, which no longer exists, as it is part of XFree86 and not
part of X.org.  The config file line can be completely removed
as it is unnecessary for either X server and is just
overconfiguration.

pyxf86config has been fixed to not put this line in the config file
anymore, and it will be in rawhide sometime today hopefully.

Once upgrading pyxf86config, running system-config-display --reconfig
should generate a new config without this bogus option which
breaks xkb.
Comment 7 Victor Pechorin 2004-04-16 15:24:52 EDT
After upgrading to pyxf86config-0.3.17-1 and xorg-x11-*-6.7.0-0.5 i
have the same error when starting X. I tried manually remove the line
/Options "XkbRules" "xfree86"/, but without any success.

# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

# gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us,ru]
 model = thinkpad
 overrideSettings = false
 options = [grp grp:ctrl_shift_toggle,grp_led   grp_led:caps]

on my notebook IBM T40.

Xorg versions:
# rpm -qa | grep xorg
xorg-x11-base-fonts-6.7.0-0.5
xorg-x11-twm-6.7.0-0.5
xorg-x11-libs-data-6.7.0-0.5
xorg-x11-font-utils-6.7.0-0.5
xorg-x11-xfs-6.7.0-0.5
xorg-x11-xauth-6.7.0-0.5
xorg-x11-100dpi-fonts-6.7.0-0.5
xorg-x11-libs-6.7.0-0.5
xorg-x11-Mesa-libGL-6.7.0-0.5
xorg-x11-6.7.0-0.5
xorg-x11-75dpi-fonts-6.7.0-0.5
xorg-x11-xdm-6.7.0-0.5
xorg-x11-tools-6.7.0-0.5
xorg-x11-Mesa-libGLU-6.7.0-0.5
xorg-x11-devel-6.7.0-0.5
Comment 8 Thomas Molina 2004-04-17 07:48:22 EDT
Mike,

I tried your suggestion above and got the following results:

[root@dad root]# rpm -qa|grep pyxf
pyxf86config-0.3.17-1
[root@dad root]# system-config-display --reconfig
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 412, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined
[root@dad root]#

This is after fully updating my system.  As others have pointed out,
simply commenting out the offending line does not work for me.
Comment 9 Doug McClean 2004-04-17 23:56:34 EDT
I get the same trouble as Thomas when I try to run
system-config-display --reconfig; I tried playing with the xconf.py
file a bit, but I don't know enough about python to know what I was
doing. I decided to backup and delete /etc/X11/XF86Config and just run
system-config-display without the --reconfig option, and it ended up
creating /etc/X11/xorg.conf, which has Option "XkbRules" "xorg"
instead of "xfree86". I still get the Error activating XKB
configuration. Here is my xprop and gconftool-2 output:


_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""
                                                                     
          
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
Comment 10 Mike A. Harris 2004-04-18 13:55:30 EDT
The hardware_state error is a different bug, which is filed in
another bugzilla report for system-config-display.

The newest version of pyxf86config, with the fix, is 0.3.18-1.

Also, it is important to use Red Hat binaries, as this involves
a static library getting linked in, and so if someone recompiles
the above stuff on a system with the broken library, they will
not get the bugfixes from the last week.  I'm assuming that
everyone is using our binaries, but just mentioning this for
completeness just in case.

Will reinvestigate this later this week once all fixes are pushed
publically and people have a chance to update to the latest
internal versions.

Thanks again for testing.
Comment 11 Warren Togami 2004-04-19 05:09:21 EDT
The system-config-display problem is Bug #119620.  Consolidating this
with another large bug.

*** This bug has been marked as a duplicate of 120858 ***
Comment 12 Red Hat Bugzilla 2006-02-21 14:02:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.