Bug 119620 - Can't configure the graphic system
Can't configure the graphic system
Status: CLOSED DUPLICATE of bug 123429
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
2
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
:
: 121107 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-31 16:49 EST by Alessandro Polverini
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my xorg.conf (2.65 KB, text/plain)
2004-06-04 09:27 EDT, Jonathan Smith
no flags Details
my Xorg log (33.35 KB, text/plain)
2004-06-04 09:28 EDT, Jonathan Smith
no flags Details

  None (edit)
Description Alessandro Polverini 2004-03-31 16:49:10 EST
Description of problem:
Anaconda starts in textmode, so I did all the installation and after
the boot I run


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install fedora core2 test2
2. reboot
3. start system-config-display --reconfig
  
Actual results:
file "/usr/share/system-config-fisplay/xconf.py" line 412, in ? 
hardware_state.merge_into(xconfig)
name error: name "hardware_state" is not defined

Sorry if the output is not perfect, I copied by hand on hand writing
because I could not be able to do cut&paste.

Expected results:
I expected the configurator telling me something, at least while it
was not working, and hopefully able to configure my dual flat panel
display.

Additional info:
My graphic card is a GeForce FX 5600, m/b is Asus K8V.
Comment 1 Jeff Iddings 2004-04-07 12:20:07 EDT
Experiencing the same problem on x86...

SIS315 video card -- though I suspect it's not hardware specific.
Happens also when I try to setup the card manually...

# system-config-display --set-driver=sis --set-resolution=800x600
--set-depth=16 --set-videoram=0 

Traceback (most recent call last):
   File "/usr/share/system-config-display/xconf.py", line 412, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined
Comment 2 Brent Fox 2004-04-07 15:27:12 EDT
Type this in as root:
1) python
2) import rhpl.videocard
3) vc = rhpl.videocard.VideoCardInfo()
4) card_list = vc.videocards
5) print card_list
6) for card in card_list: print card  (press Enter twice)

Please paste the output of those print statements to this bug report.
 It looks like the video card isn't getting probed for some reason.
Comment 3 Mike A. Harris 2004-04-16 00:09:30 EDT
>>> import rhpl.videocard
>>> vc = rhpl.videocard.VideoCardInfo()
>>> card_list = vc.videocards
>>> print card_list
[<rhpl.videocard.VideoCard instance at 0x2a97e8bef0>]
>>> for card in card_list: print card
...
device: None
descr : ATI|Rage XL
server: Xorg
cardManf: None
vidRam: 8192
carddata: {'CHIPSET': 'ati', 'DRIVER': 'ati', 'NAME': 'ATI Mach64',
'NOCLOCKPROBE': ''}
devID: ATI Mach64
fbmodes: None
fbbpp: None
Comment 4 Warren Togami 2004-04-18 23:46:37 EDT
*** Bug 121107 has been marked as a duplicate of this bug. ***
Comment 5 Ralf Ertzinger 2004-04-19 06:30:27 EDT
[... start output ...]

>>> import rhpl.videocard
>>> vc = rhpl.videocard.VideoCardInfo()
>>> card_list = vc.videocards
>>> print card_list
[<rhpl.videocard.VideoCard instance at 0xf6fefaec>]
>>> for card in card_list: print card
... 
device: None
descr : nVidia Corporation|NV11 [GeForce2 MX/MX 400]
server: Xorg
cardManf: None
vidRam: 32768
carddata: {'CHIPSET': 'GeForce 2', 'SEE': 'NVIDIA GeForce 2
(generic)', 'DRIVER': 'nv', 'NAME': 'NVIDIA GeForce 2 MX (generic)',
'NOCLOCKPROBE': ''}
devID: NVIDIA GeForce 2 MX (generic)
fbmodes: None
fbbpp: None

[... end output ...]
The card is identified correctly.
Comment 6 Victor Pechorin 2004-04-20 04:19:51 EDT
Python 2.3.3 (#1, Mar 16 2004, 16:37:35)
[GCC 3.3.3 20040311 (Red Hat Linux 3.3.3-3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import rhpl.videocard
>>> vc = rhpl.videocard.VideoCardInfo()
>>> card_list = vc.videocards
>>> print card_list
[<rhpl.videocard.VideoCard instance at 0xf6f84b0c>]
>>> for card in card_list: print card
...
device: None
descr : ATI|Radeon Mobility M7 LW [Radeon Mobility 7500]
server: Xorg
cardManf: None
vidRam: 32704
carddata: {'CHIPSET': 'RV200', 'DRIVER': 'radeon', 'NAME': 'ATI Radeon
Mobility 7500'}
devID: ATI Radeon Mobility 7500
fbmodes: None
fbbpp: None
 
>>>

Also the latest system-config-display gives me only two resolutions
640x480 and 800x600, but before, when i installed FC2 test 2 it worked
normally (gave 1024x768 mode).
Comment 7 Alessandro Polverini 2004-04-28 07:46:24 EDT
Here is the output requested:
-----------------------------
Python 2.3.3 (#1, Mar 16 2004, 17:10:55)
[GCC 3.3.3 20040311 (Red Hat Linux 3.3.3-3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import rhpl.videocard
>>> vc = rhpl.videocard.VideoCardInfo()
* no cardMem, assuming 8192
>>> card_list = vc.videocards
>>> print card_list
[<rhpl.videocard.VideoCard instance at 0x2a97d8ef38>]
>>> for card in card_list: print card
...
device: None
descr : VESA driver (generic)
server: Xorg
cardManf: None
vidRam: 8192
carddata: {'CHIPSET': 'VESA VBE 2.0', 'DRIVER': 'vesa', 'NAME': 'VESA
driver (generic)'}
devID: VESA driver (generic)
fbmodes: None
fbbpp: None
-----------------------------

Hoping to be useful, here is the output of lspci and lspci -n:
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host
Bridge (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800
South]
00:09.0 Multimedia video controller: Brooktree Corporation Bt878 Video
Capture (rev 11)
00:09.1 Multimedia controller: Brooktree Corporation Bt878 Audio
Capture (rev 11)
00:0a.0 Ethernet controller: Marvell Yukon Gigabit Ethernet
10/100/1000Base-T Adapter (rev 13)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA
RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800
South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AQ
[Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AQ [Radeon
9600] (Secondary)

00:00.0 Class 0600: 1106:3188 (rev 01)
00:01.0 Class 0604: 1106:b188
00:09.0 Class 0400: 109e:036e (rev 11)
00:09.1 Class 0480: 109e:0878 (rev 11)
00:0a.0 Class 0200: 11ab:4320 (rev 13)
00:0d.0 Class 0200: 10ec:8139 (rev 10)
00:0f.0 Class 0104: 1106:3149 (rev 80)
00:0f.1 Class 0101: 1106:0571 (rev 06)
00:10.0 Class 0c03: 1106:3038 (rev 81)
00:10.1 Class 0c03: 1106:3038 (rev 81)
00:10.2 Class 0c03: 1106:3038 (rev 81)
00:10.3 Class 0c03: 1106:3038 (rev 81)
00:10.4 Class 0c03: 1106:3104 (rev 86)
00:11.0 Class 0601: 1106:3227
00:11.5 Class 0401: 1106:3059 (rev 60)
00:18.0 Class 0600: 1022:1100
00:18.1 Class 0600: 1022:1101
00:18.2 Class 0600: 1022:1102
00:18.3 Class 0600: 1022:1103
01:00.0 Class 0300: 1002:4151
01:00.1 Class 0380: 1002:4171
Comment 8 Gene Czarcinski 2004-04-28 13:22:35 EDT
Confirmed ... this problem still exists with FC2-T3
Comment 9 Gene Czarcinski 2004-04-28 13:33:41 EDT
Note:

1. running s-c-d without "--reconfig" seems to work if there is no
/etc/X11/xorg.conf.

2. Have a more or less "good" version of /etc/X11/xorg.conf works even
better.
Comment 10 Kyrre Ness Sjøbæk 2004-04-30 17:53:41 EDT
Seems to me if its just making completely destroyed config-files.

I specified a "generic 1024x768 CRT", and this is what it came up with
(it was not autodetected) (i tried more than once - the thing was
behaving rater "funny" - giving and removing access to resolutions
varying between 800x600 and 1024x768, but when put to the test, all X
gave me was 600x???.)

Section "Monitor"

 ### Uncomment if you don't want to default to DDC:
 ### Uncomment if you don't want to default to DDC:
#	HorizSync    31.5 - 57.0
#	VertRefresh  50.0 - 70.0
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor 1024x768"
 ### Uncomment if you don't want to default to DDC:
#	HorizSync    31.5 - 57.0
#	VertRefresh  50.0 - 70.0
	Option	    "dpms"
EndSection

After manualy creatining the monitor setup and setting up the
modeline, as well as deleting /etc/X11/XF86Config and xorg.conf.backup
all worked smooth for me.

I have a Philips Brilliance 17A attached to a ATI 
Comment 11 J. Scott Farrow 2004-05-01 16:40:05 EDT
I'm having the same issues with an Nvidia GeForce4 MX420 w/Eizo TX-
C7S monitor.  This setup worked fine under test2.  I'm unable to get 
more than 620x480 resolution even with manual edits 
to /etc/X11/xorg.conf.  

Deleting the xorg.conf file and rerunning system-config-display, as 
suggested above, did not help.

- J. Scott Farrow
jsfarrow@comcast.net

Script started on Sat 01 May 2004 02:22:11 PM MDT
[root@pontifex root]# python

Python 2.3.3 (#1, Mar 16 2004, 16:37:35) 

[GCC 3.3.3 20040311 (Red Hat Linux 3.3.3-3)] on linux2

Type "help", "copyright", "credits" or "license" for more information.

>>> rhpl.     import rhpl.videocard

>>> vc = rhpl.videocard.VideoCardInfo()

>>> card_list = fc.videocards[1P[1P[1@ 
[1@vc.videocards

>>> print card_list

[<rhpl.videocard.VideoCard instance at 0xf707296c>]

>>> for card in card_list: print card 

... 

device: None

descr : nVidia Corporation|NV17 [GeForce4 MX 420]

server: Xorg

cardManf: None

vidRam: 65536

carddata: {'CHIPSET': 'GeForce 4', 'DRIVER': 'nv', 'NAME': 'NVIDIA 
GeForce 4 (generic)', 'NOCLOCKPROBE': ''}

devID: NVIDIA GeForce 4 (generic)

fbmodes: None

fbbpp: None



>>> exit


 
Comment 12 Douglas Furlong 2004-05-07 08:25:45 EDT
This bug may be related to   Bug #:   120950  
Comment 13 Matt Brown 2004-05-08 19:04:24 EDT
I am also seeing this bug on a fresh FC2T3 install. Gigabyte nForce2
motherboard, AMD XP 2600+ and a Radeon 9600 connected to a Philips
170B (LCD). 

Running system-config-display returns
[root@argon root]# system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 412, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined

Running the python snippet given above prints an empty list
and no output is generated from the for loop.
Comment 14 Jonathan Smith 2004-06-04 09:27:06 EDT
Created attachment 100866 [details]
my xorg.conf
Comment 15 Jonathan Smith 2004-06-04 09:28:04 EDT
Created attachment 100867 [details]
my Xorg log
Comment 16 Jonathan Smith 2004-06-04 09:32:45 EDT
For me, it goes into endless searching, similar to what happens when 
I run system-config-display except without the black void.

>>> print card_list
[<rhpl.videocard.VideoCard instance at 0xf6f79aac>]
>>> for card in card_list: print card
... endless searching prevails

I have attached my xorg.conf and log files
Comment 17 Jonathan Smith 2004-06-04 11:48:40 EDT
I failed to press enter TWICE. Repeating the steps produces the 
following info:

device: None
descr : Silicon Integrated Systems [SiS]|630/730 PCI/AGP VGA Display 
Adapter
server: Xorg
cardManf: None
vidRam: None
carddata: {'CHIPSET': 'SiS630', 'DRIVER': 'sis', 'NAME': 'SiS 630', 
'NOCLOCKPROBE': ''}
devID: SiS 630
fbmodes: None
fbbpp: None

Comment 18 Jonathan Smith 2004-06-04 16:54:15 EDT
Additional info from pciutils-devel (lspci):
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 730 Host (rev 
02)
00:00.1 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] 
(rev d0)
00:01.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 
(LPC Bridge)
00:01.1 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 
PCI Fast Ethernet (rev 82)
00:01.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 
Controller (rev 07)
00:01.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 
Controller (rev 07)
00:01.4 Multimedia audio controller: Silicon Integrated Systems [SiS] 
SiS PCI Audio Accelerator (rev 02)
00:01.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem 
Controller (rev a0)
00:02.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual 
PCI-to-PCI bridge (AGP)
00:0b.0 Unknown mass storage controller: Promise Technology, Inc. 
20268 (rev 02)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 
630/730 PCI/AGP VGA Display Adapter (rev 31)

00:00.0 Class 0600: 1039:0730 (rev 02)
00:00.1 Class 0101: 1039:5513 (rev d0)
00:01.0 Class 0601: 1039:0018
00:01.1 Class 0200: 1039:0900 (rev 82)
00:01.2 Class 0c03: 1039:7001 (rev 07)
00:01.3 Class 0c03: 1039:7001 (rev 07)
00:01.4 Class 0401: 1039:7018 (rev 02)
00:01.6 Class 0703: 1039:7013 (rev a0)
00:02.0 Class 0604: 1039:0001
00:0b.0 Class 0180: 105a:4d68 (rev 02)
01:00.0 Class 0300: 1039:6300 (rev 31)

Is there anything to the discussion on LinuxQuestions.org http://www.
linuxquestions.org/questions/showthread.php?threadid=188138 about 
solving the problem by building a custom kernel that has an 8 
Kilobytes stack size? Apparently the latest kernel (version 2.6) is 
built with a stack size of only 4 Kilobytes. Many drivers (including 
the nVidia drivers) expect a stack size of 8 Kilobytes.
Comment 19 Jonathan Smith 2004-06-06 11:06:19 EDT
I now have tried three 2.6.6 test kernels; the most recent one was 
Arjan's kernel-2.6.6-1.422. As mentioned in the previous comment,  
kernel-2.6.6-1.422 supposedly resolved a stack size issue that 
prevented some videocards from working properly. 

The test kernel failed to resolve the problem for my SiS630 chipset.
It was a quick test. If logged in as a Gnome user, the startup 
process is interrupted and the splash screen remains up. It is the 
first sign that something is amiss. i.e., non-QT GUIs fail to run. 
Perhaps, I should have tried system-config-display --reconfig except 
that I believe that my xorg.conf is valid.
Comment 20 Jonathan Smith 2004-06-11 11:30:56 EDT
I tried the most recent test kernel, kernel-2.6.6-1.424. It failed to 
resolve the problem for my SiS630 chipset.With the overt hostility 
and disrespect toward people who ask questions on #fedora, it is 
increasingly difficult to monitor the channel hoping to learn of a 
way to uncripple my Linux system after the upgrade from FC1 to FC2.
Comment 21 Jonathan Smith 2004-06-11 13:34:44 EDT
Make that testing the most recent kernels (plural), kernel-2.6.6-1.
424 or kernel-2.6.6-1.427, failed to resolved the problem.
Comment 22 Jonathan Smith 2004-06-12 13:00:59 EDT
I tried kernel-2.6.5-1.358.8kstacks ( http://www.linuxant.
com/driverloader/wlan/full/downloads-fc2-kernel-i686.php ), to which 
I believe someone on #fedora referred as a "binary kernel", i.e., 
consistent with, yet coming from other than Fedora. It, too, failed 
to resolve the problem for my SiS 630/730S chipset, i.e., inability 
to view non-QT GUIs. Thus, I suspect the problem is something in 
addition to the 4k-8k stack issue, as I now have tried two different 
kernels that reportedly fixed FC2 problems related to nVidia cards.
Comment 23 Jonathan Smith 2004-06-16 10:33:23 EDT
I upgraded to kernel-2.6.6-1.435 and still have the same problem. 
Hopefully, the kernel improvement is helping others (e.g., ATI and 
nVidia users) who had problems after upgrading.
Comment 24 Ralf Ertzinger 2004-06-16 12:59:04 EDT
To be honest, I'd be very surprised if this turned out to be a kernel
problem.
Comment 25 Jonathan Smith 2004-06-21 08:51:33 EDT
So who might be able to ascertain whether it is a <a href="http:
//aspn.activestate.
com/ASPN/Mail/Message/komodo-discuss/2079798">glibc bug</a> instead?
Comment 26 Jonathan Smith 2004-06-24 10:33:45 EDT
I am glad to report resolution of the problem that had crippled my
Linux computer after the FC1 -> FC2 upgrade. I have the FC2 set up to
run nightly yum updates, so I am unclear as to everything that
happened to resolve it. I do know that s-c-d (and others apps such as
Mozilla) work after I installed pango-1.4, which I downloaded from the
development i386 Fedora RPMs.
Comment 27 Brent Fox 2004-06-25 10:57:03 EDT
I'm not able to reproduce this on an FC2 final system.  Are any of you
still seeing this problem?
Comment 28 Brent Fox 2004-06-25 11:02:02 EDT

*** This bug has been marked as a duplicate of 123429 ***
Comment 29 Alessandro Polverini 2004-06-25 11:51:00 EDT
I'm still able to reproduce it on a full up2date FC2 AMD64 system:

[root@tatty root]# system-config-display --reconfig
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 412, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined

xorg-x11-6.7.0-2
system-config-display-1.0.14-1
Comment 30 Brent Fox 2004-06-25 11:59:53 EDT
Alessandro:  As stated in bug #123429, system-config-display-1.0.15-2
in Rawhide should fix this problem.  It was released after FC2 went Gold.

Please reopen this bug if you still see this problem after updating to
that version.

*** This bug has been marked as a duplicate of 123429 ***
Comment 31 Alessandro Polverini 2004-06-25 12:18:01 EDT
Sorry, my bad.

Problem went away with version 1.0.16-1.

I keep getting the following messages tough:
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Thanks,
Alex
Comment 32 Red Hat Bugzilla 2006-02-21 14:02:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.
Comment 33 naha 2006-06-18 02:32:35 EDT
(In reply to comment #2)
> Type this in as root:
> 1) python
> 2) import rhpl.videocard
> 3) vc = rhpl.videocard.VideoCardInfo()
mmap /dev/mem bad address

Can you please help?
Comment 34 naha 2006-06-18 02:43:51 EDT
File "/usr/share/system-config-display/xconf.py", line 388, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined

The line error is 388. 

> Type this in as root:
> 1) python
> 2) import rhpl.videocard
> 3) vc = rhpl.videocard.VideoCardInfo()
mmap /dev/mem bad address

Can you please help?

Comment 35 naha 2006-06-18 02:44:47 EDT
File "/usr/share/system-config-display/xconf.py", line 388, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined

The line error is 388. RHEL 4.0. Latest system-config-display.

> Type this in as root:
> 1) python
> 2) import rhpl.videocard
> 3) vc = rhpl.videocard.VideoCardInfo()
mmap /dev/mem bad address

Can you please help?

Note You need to log in before you can comment on or make changes to this bug.