Bug 120944 - Module.symvers missing while building kernel module
Module.symvers missing while building kernel module
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
: 121094 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-15 11:33 EDT by Philip Balister
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 07:17:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Balister 2004-04-15 11:33:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
While trying to build the ndiswrapper module I get an error saying
Module.symvers is missing. I believe this should be in the
/lib/modules/-kver-/build directory.

http://lwn.net/Articles/79984/

Here is an article mentioning this file. The file is refered to in the
Makefile in the build directory, not the Makefile for ndiswrapper.

if possible can you email me the Module.symvers file for that kernel
package? I'd like to see if that fixed my problem.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.322

How reproducible:
Always

Steps to Reproduce:
1. Download ndiswrapper from sf
2. Try to compile it
3.
    

Actual Results:  Failure

Expected Results:  Success

Additional info:
Comment 1 Andrew Farris 2004-04-17 17:10:06 EDT
Confirmed while building nVIDIA module.  I cannot determine how this
file gets created, but it is referenced by scripts/modpost and is
removed from the source tree by 'make mrproper'.  Rebuilding the entire
kernel and modules from the kernel-source did create this file (I
rebuilt a custom build of -1.326 so I cannot post it for you).  I will
rebuild the default config i686 kernel -1.322 later and attach the
Module.symvers if it is created.

Using the kernel-<vers>.src.rpm and rebuilding via rpmbuild -ba
--target=i686 did NOT create the Modules.symvers file anywhere in the
rpms (that I can find).  I presume the kernel sources are being cleaned
(mrproper) before being packaged.  Modules.symvers needs to show up in
the /lib/modules/<vers>/build directory before it is destroyed.
Once this file was copied into the build directory my module compile
works.
Comment 2 Andrew Farris 2004-04-17 21:19:07 EDT
bug is duplicate of #121132
Comment 3 Warren Togami 2004-04-18 23:12:05 EDT

*** This bug has been marked as a duplicate of 121132 ***
Comment 4 Arjan van de Ven 2004-04-19 02:50:45 EDT
Warren is incorrect in duping this bug
Comment 5 Arjan van de Ven 2004-04-19 02:55:22 EDT
*** Bug 121094 has been marked as a duplicate of this bug. ***
Comment 6 Arjan van de Ven 2004-04-20 07:17:58 EDT
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.