Bug 1209670 - Improve review statistics - approved vs translated
Summary: Improve review statistics - approved vs translated
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Usability (Show other bugs)
(Show other bugs)
Version: 3.7
Hardware: Unspecified Unspecified
high
high
Target Milestone: ---
: 3.7
Assignee: Alex Eng
QA Contact: Damian Jansen
URL:
Whiteboard:
Keywords: Triaged
: 1159107 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-08 00:35 UTC by Michelle Kim
Modified: 2015-07-22 02:20 UTC (History)
5 users (show)

Fixed In Version: 3.7.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3565)
Doc Type: Bug Fix
Doc Text:
Story Points: 3
Clone Of:
Environment:
Last Closed: 2015-07-22 02:20:11 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Status for approved / translated needs fix (111.92 KB, image/png)
2015-04-08 01:56 UTC, Michelle Kim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1211134 None None None Never
Red Hat Bugzilla 1211137 None None None Never

Description Michelle Kim 2015-04-08 00:35:58 UTC
Please provide two modes: Translating and Reviewing mode - displaying the review/reject button only in reviewing mode.

Toggle button to switch between the two modes.

Comment 2 Damian Jansen 2015-04-08 01:29:48 UTC
See also https://bugzilla.redhat.com/show_bug.cgi?id=1153474

Comment 3 Michelle Kim 2015-04-08 01:56:07 UTC
Created attachment 1011995 [details]
Status for approved / translated needs fix

Comment 4 Michelle Kim 2015-04-13 06:26:30 UTC
My initial comments in this bug is no longer relevant. 

New scope:

For stats percentage being different between project tiles vs. translated % at the top of the editor. Project tiles are doing it wrong: percentage goes down when translated items are approved.

   - make stats percentage in all places (project/version page, project tile, editors, etc) always shows translated+approved% as the total translated.
   - no changes to the REST API are expected in this change.

Comment 5 Alex Eng 2015-05-14 22:41:10 UTC
Pull request:
https://github.com/zanata/zanata-server/pull/812

Comment 6 Damian Jansen 2015-05-19 01:03:22 UTC
Verified (master) at 53417cf3fa5374f96ddf1d9b0abe14c56ff59ec0

Comment 7 Michelle Kim 2015-06-10 04:42:11 UTC
*** Bug 1159107 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.