Bug 120975 - kernel freeze when loginout off a kde or gnome seesion
kernel freeze when loginout off a kde or gnome seesion
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 16:00 EDT by Knut J BJuland
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2004-04-15 16:00:34 EDT
Description of problem:

When I log out of gnome-session or kde session the system freeze, but
if  I lanuch X with startx this does not happen. In bug #120575
Mathieu Chouquet-Stringer (mchouque@free.fr) descriped s similar fault
to this bug. However I use nvidia driver with a kernel compiled from
kernel-source without 4stack and reg. 

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.326

How reproducible:
every time

Steps to Reproduce:
1. log out off a x session
2.
3.
  
Actual results:
Apr 14 10:33:27 knut kernel: agpgart: Found an AGP 2.0 compliant
device at 0000:00:00.0.
Apr 14 10:33:27 knut kernel: agpgart: Putting AGP V2 device at
0000:00:00.0 into 4x mode
Apr 14 10:33:27 knut kernel: agpgart: Putting AGP V2 device at
0000:01:00.0 into 4x mode
Apr 14 10:33:28 knut kernel: Unable to handle kernel paging request at
virtual address c93c82c4
Apr 14 10:33:28 knut kernel:  printing eip:
Apr 14 10:33:28 knut kernel: c0244f72
Apr 14 10:33:28 knut kernel: *pde = 090001e3
Apr 14 10:33:28 knut kernel: *pte = 00320000
Apr 14 10:33:28 knut kernel: Oops: 0000 [#1]
Apr 14 10:33:28 knut kernel: PREEMPT 
Apr 14 10:33:28 knut kernel: CPU:    0
Apr 14 10:33:28 knut kernel: EIP:    0060:[radix_tree_lookup+63/68]  
 Tainted: P  
Apr 14 10:33:28 knut kernel: EIP:    0060:[<c0244f72>]    Tainted: P  
Apr 14 10:33:28 knut kernel: EFLAGS: 00010047   (2.6.5-1.319custom) 
Apr 14 10:33:28 knut kernel: EIP is at radix_tree_lookup+0x3f/0x44
Apr 14 10:33:28 knut kernel: eax: c93c82c4   ebx: c93c8200   ecx:
fffffffa   edx: 00000000
Apr 14 10:33:28 knut kernel: esi: 00000030   edi: cce26000   ebp:
00000030   esp: cce27b40
Apr 14 10:33:28 knut kernel: ds: 007b   es: 007b   ss: 0068
Apr 14 10:33:28 knut kernel: Process modprobe (pid: 11341,
threadinfo=cce26000 task=cf41e030)
Apr 14 10:33:28 knut kernel: Stack: cd031c94 00000000 c0140edf
cd031c98 00000030 00000032 00000000 c01424a6 
Apr 14 10:33:28 knut kernel:        cd031c94 00000030 00000001
00000000 cd031bb4 c56057c8 cd031c94 c5605780 
Apr 14 10:33:28 knut kernel:        c6e26680 c6c80440 08078ab4
c6e26680 c0152d60 c6c80440 08078000 cce27bb0 
Apr 14 10:33:28 knut kernel: Call Trace:
Apr 14 10:33:28 knut kernel:  [find_get_page+144/291]
find_get_page+0x90/0x123
Apr 14 10:33:28 knut kernel:  [<c0140edf>] find_get_page+0x90/0x123
Apr 14 10:33:28 knut kernel:  [filemap_nopage+188/935]
filemap_nopage+0xbc/0x3a7
Apr 14 10:33:28 knut kernel:  [<c01424a6>] filemap_nopage+0xbc/0x3a7
Apr 14 10:33:28 knut kernel:  [do_no_page+261/1591] do_no_page+0x105/0x637
Apr 14 10:33:28 knut kernel:  [<c0152d60>] do_no_page+0x105/0x637
Apr 14 10:33:28 knut kernel:  [handle_mm_fault+235/587]
handle_mm_fault+0xeb/0x24b
Apr 14 10:33:28 knut kernel:  [<c01534a3>] handle_mm_fault+0xeb/0x24b
Apr 14 10:33:28 knut kernel:  [do_page_fault+307/1147]
do_page_fault+0x133/0x47b
Apr 14 10:33:28 knut kernel:  [<c011967b>] do_page_fault+0x133/0x47b
Apr 14 10:33:28 knut kernel:  [__vma_link+86/156] __vma_link+0x56/0x9c
Apr 14 10:33:28 knut kernel:  [<c0154308>] __vma_link+0x56/0x9c
Apr 14 10:33:28 knut kernel:  [vma_link+202/361] vma_link+0xca/0x169
Apr 14 10:33:28 knut kernel:  [<c0154418>] vma_link+0xca/0x169
Apr 14 10:33:28 knut kernel:  [__vma_link+86/156] __vma_link+0x56/0x9c
Apr 14 10:33:28 knut kernel:  [<c0154308>] __vma_link+0x56/0x9c
Apr 14 10:33:28 knut kernel:  [vma_link+202/361] vma_link+0xca/0x169
Apr 14 10:33:28 knut kernel:  [<c0154418>] vma_link+0xca/0x169
Apr 14 10:33:28 knut kernel:  [do_page_fault+0/1147]
do_page_fault+0x0/0x47b
Apr 14 10:33:28 knut kernel:  [<c0119548>] do_page_fault+0x0/0x47b
Apr 14 10:33:28 knut kernel:  [error_code+47/56] error_code+0x2f/0x38
Apr 14 10:33:28 knut kernel:  [<c037914b>] error_code+0x2f/0x38
Apr 14 10:33:28 knut kernel:  [direct_clear_user+63/77]
direct_clear_user+0x3f/0x4d
Apr 14 10:33:28 knut kernel:  [<c02471e6>] direct_clear_user+0x3f/0x4d
Apr 14 10:33:28 knut kernel:  [padzero+28/31] padzero+0x1c/0x1f
Apr 14 10:33:28 knut kernel:  [<c0197a2e>] padzero+0x1c/0x1f
Apr 14 10:33:28 knut kernel:  [load_elf_binary+2068/2957]
load_elf_binary+0x814/0xb8d
Apr 14 10:33:28 knut kernel:  [<c0198b0f>] load_elf_binary+0x814/0xb8d
Apr 14 10:33:28 knut kernel:  [__alloc_pages+163/655]
__alloc_pages+0xa3/0x28f
Apr 14 10:33:28 knut kernel:  [<c0145c5a>] __alloc_pages+0xa3/0x28f
Apr 14 10:33:28 knut kernel:  [copy_strings+457/546]
copy_strings+0x1c9/0x222
Apr 14 10:33:28 knut kernel:  [<c0171dd0>] copy_strings+0x1c9/0x222
Apr 14 10:33:28 knut kernel:  [search_binary_handler+188/593]
search_binary_handler+0xbc/0x251
Apr 14 10:33:28 knut kernel:  [<c0173ada>]
search_binary_handler+0xbc/0x251
Apr 14 10:33:28 knut kernel:  [load_elf_binary+0/2957]
load_elf_binary+0x0/0xb8d
Apr 14 10:33:28 knut kernel:  [<c01982fb>] load_elf_binary+0x0/0xb8d
Apr 14 10:33:28 knut kernel:  [do_execve+415/561] do_execve+0x19f/0x231
Apr 14 10:33:28 knut kernel:  [<c0173e0e>] do_execve+0x19f/0x231
Apr 14 10:33:28 knut kernel:  [sys_execve+42/115] sys_execve+0x2a/0x73
Apr 14 10:33:28 knut kernel:  [<c01049c2>] sys_execve+0x2a/0x73
Apr 14 10:33:28 knut kernel:  [syscall_call+7/11] syscall_call+0x7/0xb
Apr 14 10:33:28 knut kernel:  [<c0378fc7>] syscall_call+0x7/0xb
Apr 14 10:33:28 knut kernel:  [____call_usermodehelper+478/505]
____call_usermodehelper+0x1de/0x1f9
Apr 14 10:33:28 knut kernel:  [<c01326f6>]
____call_usermodehelper+0x1de/0x1f9
Apr 14 10:33:28 knut kernel:  [____call_usermodehelper+0/505]
____call_usermodehelper+0x0/0x1f9
Apr 14 10:33:28 knut kernel:  [<c0132518>]
____call_usermodehelper+0x0/0x1f9
Apr 14 10:33:28 knut kernel:  [kernel_thread_helper+5/11]
kernel_thread_helper+0x5/0xb
Apr 14 10:33:28 knut kernel:  [<c01041e5>] kernel_thread_helper+0x5/0xb
Apr 14 10:33:28 knut kernel: 
Apr 14 10:33:28 knut kernel: Code: 8b 00 5b 5e c3 55 57 56 53 8b 54 24
14 8b 6c 24 18 8b 1a 3b 
Apr 14 10:33:28 knut kernel:  <6>note: modprobe[11341] exited with
preempt_count 1
Apr 14 10:33:28 knut kernel: Debug: sleeping function called from
invalid context at include/linux/rwsem.h:43
Apr 14 10:33:28 knut kernel: in_atomic():1, irqs_disabled():0
Apr 14 10:33:28 knut kernel: Call Trace:
Apr 14 10:33:28 knut kernel:  [__might_sleep+164/172]
__might_sleep+0xa4/0xac
Apr 14 10:33:28 knut kernel:  [<c011cf48>] __might_sleep+0xa4/0xac
Apr 14 10:33:28 knut kernel:  [do_exit+230/2043] do_exit+0xe6/0x7fb
Apr 14 10:33:28 knut kernel:  [<c012325f>] do_exit+0xe6/0x7fb
Apr 14 10:33:28 knut kernel:  [do_divide_error+0/167]
do_divide_error+0x0/0xa7
Apr 14 10:33:28 knut kernel:  [<c0106d5f>] do_divide_error+0x0/0xa7
Apr 14 10:33:28 knut kernel:  [do_page_fault+812/1147]
do_page_fault+0x32c/0x47b
Apr 14 10:33:28 knut kernel:  [<c0119874>] do_page_fault+0x32c/0x47b
Apr 14 10:33:28 knut kernel:  [do_page_cache_readahead+293/795]
do_page_cache_readahead+0x125/0x31b
Apr 14 10:33:28 knut kernel:  [<c0148a96>]
do_page_cache_readahead+0x125/0x31b
Apr 14 10:33:28 knut kernel:  [__copy_to_user_ll+76/86]
__copy_to_user_ll+0x4c/0x56
Apr 14 10:33:28 knut kernel:  [<c02473da>] __copy_to_user_ll+0x4c/0x56
Apr 14 10:33:28 knut kernel:  [file_read_actor+108/212]
file_read_actor+0x6c/0xd4
Apr 14 10:33:28 knut kernel:  [<c0141e15>] file_read_actor+0x6c/0xd4
Apr 14 10:33:28 knut kernel:  [do_generic_mapping_read+464/1376]
do_generic_mapping_read+0x1d0/0x560
Apr 14 10:33:28 knut kernel:  [<c0141a19>]
do_generic_mapping_read+0x1d0/0x560
Apr 14 10:33:28 knut kernel:  [update_atime+123/165]
update_atime+0x7b/0xa5
Apr 14 10:33:28 knut kernel:  [<c0187527>] update_atime+0x7b/0xa5
Apr 14 10:33:28 knut kernel:  [do_page_fault+0/1147]
do_page_fault+0x0/0x47b
Apr 14 10:33:28 knut kernel:  [<c0119548>] do_page_fault+0x0/0x47b
Apr 14 10:33:28 knut kernel:  [error_code+47/56] error_code+0x2f/0x38
Apr 14 10:33:28 knut kernel:  [<c037914b>] error_code+0x2f/0x38
Apr 14 10:33:28 knut kernel:  [radix_tree_lookup+63/68]
radix_tree_lookup+0x3f/0x44
Apr 14 10:33:28 knut kernel:  [<c0244f72>] radix_tree_lookup+0x3f/0x44
Apr 14 10:33:28 knut kernel:  [find_get_page+144/291]
find_get_page+0x90/0x123
Apr 14 10:33:28 knut kernel:  [<c0140edf>] find_get_page+0x90/0x123
Apr 14 10:33:28 knut kernel:  [filemap_nopage+188/935]
filemap_nopage+0xbc/0x3a7
Apr 14 10:33:28 knut kernel:  [<c01424a6>] filemap_nopage+0xbc/0x3a7
Apr 14 10:33:28 knut kernel:  [do_no_page+261/1591] do_no_page+0x105/0x637
Apr 14 10:33:28 knut kernel:  [<c0152d60>] do_no_page+0x105/0x637
Apr 14 10:33:28 knut kernel:  [handle_mm_fault+235/587]
handle_mm_fault+0xeb/0x24b
Apr 14 10:33:28 knut kernel:  [<c01534a3>] handle_mm_fault+0xeb/0x24b
Apr 14 10:33:28 knut kernel:  [do_page_fault+307/1147]
do_page_fault+0x133/0x47b
Apr 14 10:33:28 knut kernel:  [<c011967b>] do_page_fault+0x133/0x47b
Apr 14 10:33:28 knut kernel:  [__vma_link+86/156] __vma_link+0x56/0x9c
Apr 14 10:33:28 knut kernel:  [<c0154308>] __vma_link+0x56/0x9c
Apr 14 10:33:28 knut kernel:  [vma_link+202/361] vma_link+0xca/0x169
Apr 14 10:33:28 knut kernel:  [<c0154418>] vma_link+0xca/0x169
Apr 14 10:33:28 knut kernel:  [__vma_link+86/156] __vma_link+0x56/0x9c
Apr 14 10:33:28 knut kernel:  [<c0154308>] __vma_link+0x56/0x9c
Apr 14 10:33:28 knut kernel:  [vma_link+202/361] vma_link+0xca/0x169
Apr 14 10:33:28 knut kernel:  [<c0154418>] vma_link+0xca/0x169
Apr 14 10:33:28 knut kernel:  [do_page_fault+0/1147]
do_page_fault+0x0/0x47b
Apr 14 10:33:28 knut kernel:  [<c0119548>] do_page_fault+0x0/0x47b
Apr 14 10:33:28 knut kernel:  [error_code+47/56] error_code+0x2f/0x38
Apr 14 10:33:28 knut kernel:  [<c037914b>] error_code+0x2f/0x38
Apr 14 10:33:28 knut kernel:  [direct_clear_user+63/77]
direct_clear_user+0x3f/0x4d
Apr 14 10:33:28 knut kernel:  [<c02471e6>] direct_clear_user+0x3f/0x4d
Apr 14 10:33:28 knut kernel:  [padzero+28/31] padzero+0x1c/0x1f
Apr 14 10:33:28 knut kernel:  [<c0197a2e>] padzero+0x1c/0x1f
Apr 14 10:33:28 knut kernel:  [load_elf_binary+2068/2957]
load_elf_binary+0x814/0xb8d
Apr 14 10:33:28 knut kernel:  [<c0198b0f>] load_elf_binary+0x814/0xb8d
Apr 14 10:33:28 knut kernel:  [__alloc_pages+163/655]
__alloc_pages+0xa3/0x28f
Apr 14 10:33:28 knut kernel:  [<c0145c5a>] __alloc_pages+0xa3/0x28f
Apr 14 10:33:28 knut kernel:  [copy_strings+457/546]
copy_strings+0x1c9/0x222
Apr 14 10:33:28 knut kernel:  [<c0171dd0>] copy_strings+0x1c9/0x222
Apr 14 10:33:28 knut kernel:  [search_binary_handler+188/593]
search_binary_handler+0xbc/0x251
Apr 14 10:33:28 knut kernel:  [<c0173ada>]
search_binary_handler+0xbc/0x251
Apr 14 10:33:28 knut kernel:  [load_elf_binary+0/2957]
load_elf_binary+0x0/0xb8d
Apr 14 10:33:28 knut kernel:  [<c01982fb>] load_elf_binary+0x0/0xb8d
Apr 14 10:33:28 knut kernel:  [do_execve+415/561] do_execve+0x19f/0x231
Apr 14 10:33:28 knut kernel:  [<c0173e0e>] do_execve+0x19f/0x231
Apr 14 10:33:28 knut kernel:  [sys_execve+42/115] sys_execve+0x2a/0x73
Apr 14 10:33:28 knut kernel:  [<c01049c2>] sys_execve+0x2a/0x73
Apr 14 10:33:28 knut kernel:  [syscall_call+7/11] syscall_call+0x7/0xb
Apr 14 10:33:28 knut kernel:  [<c0378fc7>] syscall_call+0x7/0xb
Apr 14 10:33:28 knut kernel:  [____call_usermodehelper+478/505]
____call_usermodehelper+0x1de/0x1f9
Apr 14 10:33:28 knut kernel:  [<c01326f6>]
____call_usermodehelper+0x1de/0x1f9
Apr 14 10:33:28 knut kernel:  [____call_usermodehelper+0/505]
____call_usermodehelper+0x0/0x1f9
Apr 14 10:33:28 knut kernel:  [<c0132518>]
____call_usermodehelper+0x0/0x1f9
Apr 14 10:33:28 knut kernel:  [kernel_thread_helper+5/11]
kernel_thread_helper+0x5/0xb
Apr 14 10:33:28 knut kernel:  [<c01041e5>] kernel_thread_helper+0x5/0xb
Apr 14 10:33:28 knut kernel: 
Apr 14 10:33:41 knut kernel: SysRq : SAK


Expected results:
gdm should appear 

Additional info:
Comment 1 Arjan van de Ven 2004-04-15 16:05:18 EDT
which modules are in use ?
Comment 2 Knut J BJuland 2004-04-15 16:31:38 EDT
tuner 18964 0 - Live 0xd8c6a000
bttv 163852 0 - Live 0xd8c40000
video_buf 23940 1 bttv, Live 0xd8c75000
i2c_algo_bit 9736 1 bttv, Live 0xd8c0f000
v4l2_common 6656 1 bttv, Live 0xd8bc1000
btcx_risc 5256 1 bttv, Live 0xd8bbe000
i2c_core 24836 3 tuner,bttv,i2c_algo_bit, Live 0xd8c07000
videodev 10880 1 bttv, Live 0xd8bba000
nvidia 2079656 12 - Live 0xd8f5f000
parport_pc 27328 1 - Live 0xd8b1f000
lp 13676 0 - Live 0xd8b4b000
parport 50248 2 parport_pc,lp, Live 0xd8bc5000
snd_seq_midi 9248 0 - Live 0xd8a8a000
snd_seq_oss 43136 0 - Live 0xd8b09000
snd_emu10k1_synth 10112 0 - Live 0xd8a86000
snd_emux_synth 48256 1 snd_emu10k1_synth, Live 0xd8c19000
snd_seq_virmidi 8192 1 snd_emux_synth, Live 0xd8a23000
snd_seq_midi_event 10112 3 snd_seq_midi,snd_seq_oss,snd_seq_virmidi,
Live 0xd8a82000
snd_seq_midi_emul 8576 1 snd_emux_synth, Live 0xd8a1f000
snd_seq 75024 8
snd_seq_midi,snd_seq_oss,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul,
Live 0xd8c81000
snd_emu10k1 121220 1 snd_emu10k1_synth, Live 0xd8a31000
snd_rawmidi 31904 3 snd_seq_midi,snd_seq_virmidi,snd_emu10k1, Live
0xd8a05000
snd_pcm 117896 1 snd_emu10k1, Live 0xd89e7000
snd_timer 37508 2 snd_seq,snd_pcm, Live 0xd8a26000
snd_seq_device 9224 7
snd_seq_midi,snd_seq_oss,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi,
Live 0xd8977000
snd_ac97_codec 70148 1 snd_emu10k1, Live 0xd8a8f000
snd_page_alloc 12164 2 snd_emu10k1,snd_pcm, Live 0xd8973000
snd_util_mem 5376 2 snd_emux_synth,snd_emu10k1, Live 0xd8970000
snd_hwdep 10756 2 snd_emux_synth,snd_emu10k1, Live 0xd896c000
snd 64100 14
snd_seq_midi,snd_seq_oss,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep,
Live 0xd89d6000
soundcore 12128 1 snd, Live 0xd895f000
ipv6 288032 10 - Live 0xd898e000
autofs4 24320 0 - Live 0xd8965000
ds 19588 0 - Live 0xd8959000
yenta_socket 21632 0 - Live 0xd8952000
pcmcia_core 68168 2 ds,yenta_socket, Live 0xd8940000
3c59x 41000 0 - Live 0xd8934000
ipt_REJECT 7552 2 - Live 0xd8931000
iptable_filter 3328 1 - Live 0xd8963000
ip_tables 20096 2 ipt_REJECT,iptable_filter, Live 0xd8922000
floppy 68656 0 - Live 0xd897c000
sg 39328 0 - Live 0xd8917000
scsi_mod 135248 1 sg, Live 0xd8ad5000
uhci_hcd 36252 0 - Live 0xd890d000
nls_utf8 2560 1 - Live 0xd8856000
nls_cp437 6144 1 - Live 0xd8928000
vfat 19712 1 - Live 0xd8850000
fat 53536 1 vfat, Live 0xd8841000
dm_mod 47008 0 - Live 0xd8834000
button 6680 0 - Live 0xd8831000
battery 9356 0 - Live 0xd882d000
asus_acpi 10520 0 - Live 0xd8829000
ac 5260 0 - Live 0xd885800

I have thesse modules loaded. I think this bug is not caused by nvidia
driver but I might be wrong. 
Comment 3 Arjan van de Ven 2004-04-16 03:35:08 EDT
to the contrary, looks very much like an nvidia artifact..

*** This bug has been marked as a duplicate of 73733 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.