This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 120988 - Network install lists both nics as eth0
Network install lists both nics as eth0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 122398 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 17:52 EDT by Dax Kelson
Modified: 2014-03-16 22:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 09:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2004-04-15 17:52:19 EDT
Description of problem:

Doing an install of FCT2 or Apr 14 2004 rawhide from a boot.iso, still
in the curses stage I tell it to do an NFS install.

On the next screen it shows both of my nics and asks which one I would
like to configure. It displays them both as eth0.

The display looks roughly like this:

eth0 -- 3COM blah blah blah
eth0 -- Prism yenta blah blah blah

This is my Dell Inspiron 4150 laptop with a internal 3COM PCI 10/100
nic and internal pcmcia 802.11b nic.
Comment 1 Jeremy Katz 2004-04-15 18:27:08 EDT
Bill, I'm doing...
   devs = probeDevices(CLASS_NETWORK, BUS_UNSPEC, PROBE_LOADED);

So I'm not sure why kudzu would show me both of them...

Dax -- do you see modules for both the prism and the 3com being loaded
if you look on tty4?  Also, what sort of stuff is there on tty3?
Comment 2 Dax Kelson 2004-04-16 13:41:12 EDT
Alright, gotta catch a plain a couple hours, but I got the info you
needed.

Boot off of boot.iso, select language, get to the "choose source
(NFS,CDROM,FTP,etc) screen.

tty3 shows:

modules to insert 3c59x hermes orinoco orinoco_cs
loaded blah blah modules.cgz
loaded blah blah modules.cgz
loaded blah blah modules.cgz
loaded blah blah modules.cgz
inserted 3c59x
inserted hermes
inserted orinoco
inserted orinoco_cs
loaded module set done

over on tty4 I see the standard kernel messages. 3c59x is eth0 and
orinoco_cs is eth1.

I then select NFS, and I get a screen that says:

Networking Devices -- you have mutliple blah blah

eth0 - 3com Corporation|3c905C-TX/TX-M [Tornado]
eth0 - Intersil PRISM2 11 Mbps Wireless Adapter

Flipping over to tty3 I see these new messages:

53 keymaps are available
device[0] is 3COM Corporation|3c905C-TX/TX-M [Tornado] - eth0 using
3c59x (loaded)
device[0] is 3COM Corporation|3c905C-TX/TX-M [Tornado] - eth0 using
3c59x (loaded)
(yes that line is repeated twice)
need to setup networking
going to pick interface

-----------------------------------------

Thats it. Something is foobared. BTW, futher in the install during the
set your networking details page, eth0 and eth1 are displayed.

I remember around RH8/9 time frame, Anaconda was modified to not show
wireless devices. In fact, I was the bug reporter on that one. Could
this be related?
Comment 3 Dax Kelson 2004-04-16 13:45:19 EDT
The old bug I talking about is:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=71602
Comment 4 Jeremy Katz 2004-04-16 14:17:49 EDT
This might be fixed with test3...  I can probably get my mostly broken
thinkpad to work for long enough to at least try this tonight.
Comment 5 Barry K. Nathan 2004-05-06 08:07:41 EDT
I'm seeing this with FC-devel as of 2004-05-05, so I don't think it's
fixed yet.
Comment 6 Jeremy Katz 2004-05-06 14:36:34 EDT
Can you grab http://people.redhat.com/~katzj/net-test.c and build it
with 'gcc -o net-test net-test.c -lkudzu -lpci' and run it and provide
the output?
Comment 7 Dax Kelson 2004-05-06 15:14:11 EDT
[root@mentor tmp]# ./net-test
dev[0] uses the 3c59x driver, device is eth0
dev[1] uses the orinoco_cs driver, device is eth2

BTW, I don't have an eth2, just eth0 (3c59x) and eth1 (orinoco_cs).
Comment 8 Barry K. Nathan 2004-05-06 15:47:45 EDT
[root@localhost root]# ~barryn/net-test
dev[0] uses the e100 driver, device is eth0

The fact that my wireless isn't showing up at all is probably bug
121742. Once I run "modprobe yenta_socket", this is the output:
[root@localhost root]# ~barryn/net-test
dev[0] uses the e100 driver, device is eth0
dev[1] uses the orinoco_cs driver, device is eth1
Comment 9 Jeremy Katz 2004-05-06 18:35:50 EDT
*** Bug 122398 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2004-05-06 21:59:00 EDT
Can you try with tomorrow's tree?  I've made some kudzu changes that
may have a positive effect on this
Comment 11 Barry K. Nathan 2004-05-07 16:15:42 EDT
I just tried with the 20040507 tree. This problem still exists.
Comment 12 Jeremy Katz 2004-06-08 12:03:22 EDT
Reproduced finally and can definitely point fingers at kudzu screwing
things up... Bill knows what's going on and had an idea on how he
wanted to fix it.
Comment 13 Barry K. Nathan 2004-07-15 00:27:45 EDT
Still happens with the 20040713 tree (earlier today I checked
mirrors.kernel.org and it didn't have anything newer yet).
Comment 14 Barry K. Nathan 2004-08-23 05:19:45 EDT
Still happens with 20040822 rawhide tree
Comment 15 Bill Nottingham 2004-08-31 21:39:23 EDT
Please try rawhide - this should be better there.
Comment 16 Barry K. Nathan 2004-10-08 04:02:06 EDT
(Sorry I didn't respond earlier)

Yes, it's fixed in recent rawhide (I don't remember exactly how long
ago) and in RHEL 4 beta1. I'm not the person who filed this bug,
otherwise I'd be closing it now.

Note You need to log in before you can comment on or make changes to this bug.