Bug 120989 - Can't find xfree86 rules file error message
Can't find xfree86 rules file error message
Status: CLOSED DUPLICATE of bug 121016
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 17:54 EDT by Dax Kelson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2004-04-15 17:54:39 EDT
Description of problem:

When installing rawhide April 14 2004, the GUI starts up, but if I
shell back out to CTL-ALT-F1 I see the error message:

Can't find/load the xfree86 rules file (or something like that)

I'm sure it's related to the xorg change.

I didn't notice any ill effects during the install I could attribute
to this error message.
Comment 1 Jeremy Katz 2004-04-15 18:29:19 EDT
Bad setxkbmap, no cookie
[katzj@orodruin anaconda]$ setxkbmap -layout us -model pc104 -option ""
Couldn't find rules file (xfree86) 
Comment 2 Mike A. Harris 2004-04-15 22:46:20 EDT
Can you strace that?
Comment 3 Mike A. Harris 2004-04-15 23:41:30 EDT
This appears to be caused by the X server config file containing
an unnecessary XkbRules "xfree86" option.
Comment 4 Mike A. Harris 2004-04-19 15:17:11 EDT

*** This bug has been marked as a duplicate of 121016 ***
Comment 5 Nicolas Zujev 2004-06-11 02:18:44 EDT
it's like a KDE and xOrg bug.
cause xOrg has rewrote rules files from xfree86* (XFree86) to xorg*

so to do it working  just make 2 links:
~ cd /etc/X11/xkb/rules
~ ln -s xorg.lst xfree86.lst
~ ln -s xorg.xml xfree86.xml

and restart the X server

but better, I think, to recompile KDE to work with new xorg* rules files
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.