Bug 121016 - (xkbrules-setxkbmap) setxkbmap -> Couldn't find rules file (xfree86)
setxkbmap -> Couldn't find rules file (xfree86)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 120989 139480 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 04:13 EDT by Nicolas Mailhot
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 15:08:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xkbrulesfilequery.c (1.40 KB, text/plain)
2005-11-21 19:41 EST, Mike A. Harris
no flags Details

  None (edit)
Description Nicolas Mailhot 2004-04-16 04:13:46 EDT
[nim@ulysse nim]$ setxkbmap fr
Couldn't find rules file (xfree86)
[nim@ulysse nim]$ rpm -qa | grep xorg
xorg-x11-libs-6.7.0-0.4
xorg-x11-xauth-6.7.0-0.4
xorg-x11-base-fonts-6.7.0-0.4
xorg-x11-truetype-fonts-6.7.0-0.4
xorg-x11-font-utils-6.7.0-0.4
xorg-x11-6.7.0-0.4
xorg-x11-xdm-6.7.0-0.4
xorg-x11-Mesa-libGL-6.7.0-0.4
xorg-x11-Mesa-libGLU-6.7.0-0.4
xorg-x11-tools-6.7.0-0.4
xorg-x11-sdk-6.7.0-0.4
xorg-x11-xfs-6.7.0-0.4
xorg-x11-ISO8859-15-100dpi-fonts-6.7.0-0.4
xorg-x11-libs-data-6.7.0-0.4
xorg-x11-devel-6.7.0-0.4
Comment 1 Luc Lalonde 2004-04-16 22:26:35 EDT
I have the same problem here after updating this morning with Yum.
Comment 2 Scott Sloan 2004-04-19 04:16:57 EDT
*** Bug 121000 has been marked as a duplicate of this bug. ***
Comment 3 Scott Sloan 2004-04-19 04:18:33 EDT
work around would as follows

setxkbmap -rules xorg -layout fr
Comment 4 Mike A. Harris 2004-04-19 15:08:45 EDT
setxkbmap fails due to the X server config file hard coding:

     Option "XkbRules" "xfree86"

... in it.  When that line is removed from the config file and the
X server restarted, setxkbmap works correctly again.  In other words,
that is just a misconfiguration issue, one which is addressed in our
most recent pyxf86config and other updates.

As a quick workaround, edit the X server config file, and remove
the above line, then restart the server.
Comment 5 Mike A. Harris 2004-04-19 15:17:14 EDT
*** Bug 120989 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2004-04-19 15:18:17 EDT
This bug has been marked as a master duplicate, with bug alias:
"xkbrules-setxkbmap" for easier duplicate closing.
Comment 7 Mike A. Harris 2005-02-11 17:18:07 EST
*** Bug 139480 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2005-11-21 19:41:37 EST
Created attachment 121326 [details]
xkbrulesfilequery.c

xkbrulesfilequery.c  -	I meant to attach this to a bug report about 2 years
ago, and just spent 2 hours trying to find it.	I found it.  I'm adding it
to a few bug reports now so it turns up in bugzilla should anyone ever need
an example of how to do this again.  ;o)

Note You need to log in before you can comment on or make changes to this bug.