Bug 120991 - ACPI support severely lacking
ACPI support severely lacking
Status: CLOSED DUPLICATE of bug 81142
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: 123040 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-04-15 18:11 EDT by Nickolai Zeldovich
Modified: 2014-03-16 22:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nickolai Zeldovich 2004-04-15 18:11:45 EDT
The ACPI support in Fedora Core 2 is severely lacking, providing less
functionality than a typical APM BIOS.  The kernel ACPI support might
be there, but the OSPM is largely missing.  An obvious thing to add
is to support the ACPI sleep button in acpid scripts:

    # sleep button
    action=echo -n mem > /sys/power/state

But I've noticed that even with this added to the ACPI configuration,
my laptop randomly wakes up from suspend, and proceeds to run out of
battery power and crash.  My suspicion is that we aren't properly
setting the ACPI alarm (/proc/acpi/alarm) before suspending, but I've
not been able to debug it further yet.

What about suspend-to-disk after N hours of suspend-to-RAM?  The ACPI
timer would make it fairly simple to do this.  What about auto-suspend
when the laptop is about to run out of battery power?  My APM BIOS did
this for me very well before ACPI.  The list goes on...

This is really more of a feature-request than a bug report, although
I would like to point out that it seems that ACPI support will be a
step down for current APM users, unless OSPM is improved.

-- kolya
Comment 1 Len Brown 2004-05-19 18:34:16 EDT
This is because of issues in the upstream kernel that FC has inherited. 
If you want to be proactive to help fix those issues, then test the 
kernel.org or -mm kernels and file specific bugs against specific 
failures on bugzilla.osdl.org.  Suspend/resume has a number of 
known issues, as do alarms and events in general.  Some of the 
fixes are already being tested. 
I don't know what to do with this bug report -- maybe Red Hat 
can fix the button.conf file and maybe an updated kernel will 
have better underlying support for events, alarms, and suspend/resume. 
Comment 2 Bill Nottingham 2004-05-24 16:24:49 EDT
*** Bug 123040 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2004-07-08 15:15:46 EDT

*** This bug has been marked as a duplicate of 81142 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.