Bug 121000 - KB error with latest development packages
KB error with latest development packages
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-04-15 21:23 EDT by Scott Sloan
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xprop output (127 bytes, text/plain)
2004-04-15 21:24 EDT, Scott Sloan
no flags Details
gconftool output (71 bytes, text/plain)
2004-04-15 21:24 EDT, Scott Sloan
no flags Details

  None (edit)
Description Scott Sloan 2004-04-15 21:23:23 EDT
Updated to the April 15th development packages, got this error on
login. Attached are the results requested

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
Comment 1 Scott Sloan 2004-04-15 21:24:10 EDT
Created attachment 99458 [details]
Xprop output
Comment 2 Scott Sloan 2004-04-15 21:24:35 EDT
Created attachment 99459 [details]
gconftool output
Comment 3 raxet 2004-04-18 10:23:57 EDT
Here you go MIKE! :)
The results of 

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""

gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = true
 options = []
Comment 4 Bernd Bartmann 2004-04-18 11:24:56 EDT
Same thing here, but with a german keyboard layout:

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "de",
"nodeadkeys", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "de", "nodeadkeys", ""

gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [de  nodeadkeys]
 model = pc105
 overrideSettings = false
 options = []
Comment 5 Robert Parker 2004-04-18 23:58:27 EDT
[root@localhost root]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc104", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc104", "us", "", ""
[root@localhost root]# gconftool-2 -R
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
Comment 6 Scott Sloan 2004-04-19 01:47:09 EDT
Under further investigation I think the bug was caused by 

* Wed Apr 14 2004 Alex Larsson <alexl redhat com> 1:2.6.0-2

- Add gswitchit.schemas to SCHEMAS

The problem I think occurs when gnome tries to lunch individual user
keyboard settings. It runs gswitchit to switch over the keyboard
settings and it pukes on the Schema. Where I'm trying to find out. I
have a feeling it somewhere in capplets because if you run


no plugins are listed and none are available. (I don't know if that is
normal behavior, I've yet to hit the code) I'll investiage further
later, for now I have an english paper to write. 

Note this bug can also be viewed by running the gnome control panel
and adding additional layouts under keyboard 
Comment 7 Nicolas Mailhot 2004-04-19 04:02:07 EDT
This is a dupe of #121016
Comment 8 Scott Sloan 2004-04-19 04:16:54 EDT

*** This bug has been marked as a duplicate of 121016 ***
Comment 9 Mike A. Harris 2004-04-19 15:06:25 EDT
Bug #121016 is related to Xkb rules file rename, but it is a different
bug, in which setxkbmap fails due to the X server config file hard

     Option "XkbRules" "xfree86"

in it.  When that line is removed from the config file and the X
server restarted, setxkbmap works correctly again.  In other words,
that is just a misconfiguration issue, one which is addressed
in our most recent pyxf86config and other updates.

Reopening this bug as it is not a duplicate of 121016, but rather
a dupe of 120858.

Comment 10 Mike A. Harris 2004-04-19 15:06:45 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 11 Red Hat Bugzilla 2006-02-21 14:02:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.