Bug 121006 - [PATCH] anacron package-build-error
[PATCH] anacron package-build-error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 116249 (view as bug list)
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-04-15 22:42 EDT by kanagawa jigorou
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: anacron-2.3-31
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-03 06:41:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kanagawa jigorou 2004-04-15 22:42:53 EDT
Description of problem:
package-build-error

Version-Release number of selected component (if applicable):
anacron-2.3-30

How reproducible:
Always

Steps to Reproduce:
Try to build anacron-2.3-30.src.rpm on latest fedora-development
environment.

Additional info:
Here is extracted error messages...

gregor.c: In function `day_num':
gregor.c:79: error: assignment of read-only variable `isleap'
make: *** [gregor.o] Error 1


According to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=240043
Debian solved this problem with following patch.

--- anacron-2.3/gregor.c.orig	2000-06-23 02:00:14.000000000 +0200
+++ anacron-2.3/gregor.c	2004-03-26 20:45:13.000000000 +0100
@@ -65,7 +65,7 @@
 {
     int dn;
     int i;
-    const int isleap; /* save three calls to leap() */
+    int isleap; /* save three calls to leap() */
 
     /* Some validity checks */
Comment 1 Miloslav Trmac 2004-04-21 13:57:42 EDT
*** Bug 116249 has been marked as a duplicate of this bug. ***
Comment 2 kanagawa jigorou 2004-04-21 20:34:20 EDT
Oops!
That is very true.
Sorry for my carelessness.
And, thank you!
Comment 3 kanagawa jigorou 2004-07-03 06:41:15 EDT
It looks like fixed in anacron-2.3-31.

Note You need to log in before you can comment on or make changes to this bug.