Bug 121018 - The status window has the decorated window and appears on the tasklist
The status window has the decorated window and appears on the tasklist
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: im-sdk (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
Depends On:
Blocks: FC2Target FC2Update IIIMF
  Show dependency treegraph
 
Reported: 2004-04-16 05:09 EDT by Lawrence Lim
Modified: 2014-03-25 20:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-05 01:28:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KDE screenshot in ja_JP locale (210.16 KB, image/png)
2004-04-16 05:10 EDT, Lawrence Lim
no flags Details
KDE screenshot in ko_KR locale (217.08 KB, image/png)
2004-04-16 05:10 EDT, Lawrence Lim
no flags Details
KDE screenshot in zh_CN locale (247.51 KB, image/png)
2004-04-16 05:11 EDT, Lawrence Lim
no flags Details
KDE screenshot in zh_TW locale (253.21 KB, image/png)
2004-04-16 05:12 EDT, Lawrence Lim
no flags Details
This is what it looks like when user logs into KDE with ja locale (148.60 KB, image/png)
2004-06-10 21:03 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2004-04-16 05:09:25 EDT
Description of problem:
Htt IM status should not be appearing on the panel in KDE. It takes up
space on panel and serve no purpose.

Version-Release number of selected component (if applicable):
+ FC2-re0415.0
+ qt-3.3.1-0.8
+ kdelibs-3.2.1-1.4
+ xinitrc-3.39-1
+ im-sdk -35

How reproducible:
Always

Steps to Reproduce:
1. Log in (gdm) with KDE session and any CJK Language
2. 
3.
  
Actual results:
Every application started with initiated a new Htt IM status on the
panel. (see attached screenshots)

Expected results:
No Htt IM status on the panel

Additional info:
Comment 1 Lawrence Lim 2004-04-16 05:10:11 EDT
Created attachment 99470 [details]
KDE screenshot in ja_JP locale
Comment 2 Lawrence Lim 2004-04-16 05:10:49 EDT
Created attachment 99471 [details]
KDE screenshot in ko_KR locale
Comment 3 Lawrence Lim 2004-04-16 05:11:26 EDT
Created attachment 99472 [details]
KDE screenshot in zh_CN locale
Comment 4 Lawrence Lim 2004-04-16 05:12:03 EDT
Created attachment 99473 [details]
KDE screenshot in zh_TW locale
Comment 5 Akira TAGOH 2004-04-22 05:31:30 EDT
I think this problem has three problems at least.

1) as the summary says, the status window appears under the bottom of
the panel menu on KDE.

2) the status window has been decorated.

3) the status window appears on the tasklist.

We have already had a bug like 1) as Bug#118114. so the it should be
marked as DUPLICATED. but we doesn't have the bugs yet for 2) and 3)
so I'm retitling this bug for 2) and 3). and I think 2) and 3) should
be fixed for FC2.
Comment 6 Akira TAGOH 2004-04-23 01:14:15 EDT
Should be fixed in 1:11.4-41
Comment 7 Jens Petersen 2004-05-03 23:35:43 EDT
The decorations are gone in -41, but status windows still appear
in the kde taskbar.
Comment 8 Akira TAGOH 2004-05-06 09:55:52 EDT
I couldn't reproduce that. have you restarted htt and httx?
Comment 10 Lawrence Lim 2004-06-10 21:03:30 EDT
Created attachment 101052 [details]
This is what it looks like when user logs into KDE with ja locale
Comment 12 Lawrence Lim 2004-06-11 03:10:12 EDT
Test Outcome for new patch.

Version Number:
-44.FC2.20040608.0

Actual Result:
The Status Window on the Taskbar does not appear during the initial
log in. However, running an application say kedit and minimise it
causes the Status Window on the Taskbar to reappear. Also, the
workplace switcher is still not working.

Expected Result:
1) No Status Window on the Taskbar.
2) Workplace switcher work as normal

Additional Information:
If you kill httx and start httx again, this problem will be resolved.
However, this alternative leaves the status window of an application
open in the middle of the screen when the application is minimised.
Very ugly. Also, this alternative also allow the workplace switcher to
work again.
Comment 13 Akira TAGOH 2004-06-11 04:46:10 EDT
did the status window appears with just minimizing the application
window? and actually you didn't see the status window on the desktop
anywhere, right?
I did:
1. create a new user
2. log into the KDE with ja_JP.UTF-8
3. run kedit from the menu
4. minimized the window

But I couldn't reproduce that problem. do you have any steps to 100%
reproduce that problem?
Comment 16 Lawrence Lim 2004-06-15 02:34:36 EDT
Tagoh,
I have tested your latest im-sdk -08 (orochi.tokyo) on FC2 and
everything looks very good. :)

The problem could be due to the different qt version on FC2 and
RHEL4-alpha3.

FC2 is using qt-3.3.2-2
RHEL4-alpha3 is using qt-3.3.2-5


Thanks,
Lawrence
Comment 17 Lawrence Lim 2004-06-21 05:55:19 EDT
In the ja locale, this situation does not appear anymore but in the
zh_*, problem still exist. According to tagoh-san, it is because
iiimf-le-xcin and iiimf-le-inpinyin does not have hiding the status
window code. 

Will file a bug against each of them.
Comment 18 Akira TAGOH 2004-06-28 02:19:41 EDT
as Bug#126405 and Bug#126406 was closed, this problem should
disappears anymore. Lawrence, could you confirm if this problem was
fixed? we can close this then.
Comment 19 Akira TAGOH 2004-07-04 23:20:34 EDT
need the confirmation
Comment 20 Lawrence Lim 2004-07-05 01:28:59 EDT
Tested against version -46.svn1587 against zh_*, ja_JP and ko_KR
locale. Problem of status window no longer exist.

Great work tagoh-san.

Note You need to log in before you can comment on or make changes to this bug.