Bug 1210325 - RFE: missing option to download metadata in parallel
Summary: RFE: missing option to download metadata in parallel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: librepo
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1172752 1275599 (view as bug list)
Depends On:
Blocks: 1172752
TreeView+ depends on / blocked
 
Reported: 2015-04-09 13:13 UTC by Honza Silhan
Modified: 2017-10-04 13:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-04 13:44:52 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1464149 0 unspecified CLOSED Don't apply 'retries=' option to tcp timeouts 2021-02-22 00:41:40 UTC

Internal Links: 1464149

Description Honza Silhan 2015-04-09 13:13:50 UTC
Description of problem:
In librepo there's no option to download metadata in parallel other than running it in different threads which would result in inconsistent log.

Actual results:
no option to download metadata in parallel. It downloads them one by one.


Expected results:
Simultaneously downloads metadata when the option is set

Comment 1 Honza Silhan 2015-08-06 12:55:24 UTC
*** Bug 1172752 has been marked as a duplicate of this bug. ***

Comment 2 EMR_Fedora 2015-08-26 18:50:21 UTC
Trying to download updates, and install packages, many times it just sits there and is either very slow, or just stalls for hours.

(4-5/5): libpurple-devel-2.10.11-12 40% [==============                     ] ---  B/s | 1.2 MB     --:-- ETA

Comment 3 EMR_Fedora 2015-09-01 15:16:02 UTC
So I just tried to dnf download some data, and even with the timeout set to 5 seconds, it took forever cycling through the servers, and just quit (without alternating) downloading meta-data. They were all FTP sites. Yet, when I used wget to each ftp URL that curl timed out on, it worked fine. I am not sure what's happening but it might be an upstream libcurl problem with FTP.

Comment 4 Honza Silhan 2015-11-02 15:22:25 UTC
*** Bug 1275599 has been marked as a duplicate of this bug. ***

Comment 5 Fedora End Of Life 2016-07-19 13:40:57 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 6 Martin Hatina 2017-06-27 07:32:13 UTC
Actually there is a PR for parallel download. https://github.com/rpm-software-management/librepo/pull/95

Comment 7 Martin Hatina 2017-10-04 13:44:52 UTC
Fixed in librepo-1.8.0


Note You need to log in before you can comment on or make changes to this bug.