Bug 1275599 - rfe: make dnf cache download in parallel
rfe: make dnf cache download in parallel
Status: CLOSED DUPLICATE of bug 1210325
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-10-27 06:07 EDT by Michael S. Tsirkin
Modified: 2015-11-02 10:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-02 10:22:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael S. Tsirkin 2015-10-27 06:07:25 EDT
Description of problem:
dnf update is now downloading packages in parallel.
but dnf makecache is also pretty slow
(depending on a network), making it fetch
cache from unrelated repos in parallel would
speed this up.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run as root:
# time dnf makecache
2. compare time reported for each repo and total real time

Actual results:
each repo is updated separately, one after another,
total time is the sum of times for each repo

Expected results:
Total time is worst time for a repo.

Additional info:
Can some downloads be parallelized within repo?
Might be worth considering, but might increase load on repo servers.
Comment 1 Honza Silhan 2015-11-02 10:22:25 EST

*** This bug has been marked as a duplicate of bug 1210325 ***

Note You need to log in before you can comment on or make changes to this bug.