Bug 1210679 - sync cluster.rng schema with latest updates from all cluster packages
Summary: sync cluster.rng schema with latest updates from all cluster packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci
Version: 6.5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: beta
: 6.6
Assignee: Jan Pokorný [poki]
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On: 1118008
Blocks: 1210683 1212968
TreeView+ depends on / blocked
 
Reported: 2015-04-10 11:07 UTC by Jan Pokorný [poki]
Modified: 2015-10-16 19:51 UTC (History)
11 users (show)

Fixed In Version: ricci-0.16.2-79.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1055424
: 1210683 1212968 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:34:13 UTC


Attachments (Terms of Use)
HTML highlighting the differences between RHEL 6.6 and 6.7 schemas (3.48 MB, text/html)
2015-04-17 19:25 UTC, Jan Pokorný [poki]
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1405 normal SHIPPED_LIVE ricci bug fix and enhancement update 2015-07-20 18:07:08 UTC
Red Hat Bugzilla 1118008 None None None Never
Red Hat Bugzilla 1171734 None None None Never
Red Hat Bugzilla 1272588 None None None Never

Internal Links: 1118008 1171734 1272588

Description Jan Pokorný [poki] 2015-04-10 11:07:59 UTC
New release, same old story once again...

As a starter:

- fence agents: new fence_mpath agent


+++ This bug was initially created as a clone of Bug #1055424 +++

Comment 1 Jan Pokorný [poki] 2015-04-10 11:11:14 UTC
> fence agents: new fence_mpath agent

[bug 1118008]

Comment 3 Jan Pokorný [poki] 2015-04-10 13:21:55 UTC
- fence agents: new fence_emerson agent [bug 1171734]

Comment 4 Stephen Gilson 2015-04-13 19:02:32 UTC
This issue needs to be described in the Release Notes for RHEL 6.7

Content Services needs your input to make that happen. 

Please complete the Doc Text text field for this bug by April 20 using the Cause, Consequence, Workaround, and Result model, as follows:

Cause — Actions or circumstances that cause this bug to occur on a customer's system

Consequence — What happens to the customer's system or application when the bug occurs?

Workaround (if any) — If a workaround for the issue exists, describe in detail. If more than one workaround is available, describe each one.

Result — Describe what happens when a workaround is applied. If the issue is completely circumvented by the workaround, state so. Any side effects caused by the workaround should also be noted here. If no reliable workaround exists, try to describe some preventive measures that help to avoid the bug scenario.

Comment 11 Jan Pokorný [poki] 2015-04-17 19:25:39 UTC
Created attachment 1015721 [details]
HTML highlighting the differences between RHEL 6.6 and 6.7 schemas

List of changes (lines relates to the second file in diff):


=== COSMETIC CHANGES ===

2061: fence_apc/@port
      - add UUID into description of possible interpretations
2076: fence_apc/@ipport
      - "TCP" -> "TCP/UDP" in the description
2079: fence_apc/@cmd_prompt
      - explicit about Python regex in the description

2124: fence_apc_snmp
      - "APC over SNMP" -> "APC, Tripplite PDU over SNMP" in the label
2144: see 2061 (here for fence_apc_snmp)

2230: see 2079 (here for fence_bladecenter)
2236: see 2061 (here for fence_bladecenter)
2248: see 2076 (here for fence_bladecenter)

2316: see 2061 (here for fence_bladecenter_snmp)

2405: see 2079 (here for fence_brocade)
2414: see 2076 (here for fence_brocade)
2236: see 2061 (here for fence_brocade)

2485: see 2061 (here for fence_cisco_mds)

2580: see 2076 (here for fence_cisco_ucs)
2583: see 2061 (here for fence_cisco_ucs)

2692: see 2079 (here for fence_drac5)
2701: fence_drac5/@drac_version
      - explicit about choices ((DRAC 5, DRAC CMC, DRAC MC)
        in the description
2713: see 2076 (here for fence_drac5)

2781: see 2061 (here for fence_eaton)

2973: see 2079 (here for fence_hpblade)
2979: see 2061 (here for fence_hpblade)
2991: see 2076 (here for fence_hpblade)

3059: see 2061 (here for fence_ibmblade)

3216: see 2061 (here for fence_ifmib)

3314: see 2076 (here for fence_ilo)

3394: see 2076 (here for fence_ilo2)

3592: see 2079 (here for fence_ilo_mp)
3595: see 2076 (here for fence_ilo_mp)

3710: see 2061 (here for fence_intelmodular)

3796: see 2061 (here for fence_ipdu)

3981: see 2076 (here for fence_rhevm)
3984: see 2061 (here for fence_rhevm)

4055: see 2079 (here for fence_rsa)
4064: see 2076 (here for fence_rsa)

4138: see 2079 (here for fence_rsb)
4147: see 2076 (here for fence_rsb)

4344: see 2076 (here for fence_virsh)
4353: see 2061 (here for fence_virsh)

4542: see 2061 (here for fence_vmware_soap)
4548: see 2076 (here for fence_vmware_soap)

4622: see 2079 (here for fence_wti)
4631: see 2061 (here for fence_wti)
4640: see 2076 (here for fence_wti)



=== SUBSTANTIAL CHANGES ===

2117: fence_apc/@ssh_path
      - new attribute
2120: fence_apc/@telnet_path
      - new attribute
2117: fence_apc/@ssh_path
      - new attribute
2120: fence_apc/@telnet_path
      - new attribute

2287: fence_bladecenter/@ssh_options
      - new attribute
2290: see 2117 (here for fence_bladecenter)
2293: see 2120 (here for fence_bladecenter)

2456: see 2287 (here for fence_brocade)
2459: see 2117 (here for fence_brocade)
2462: see 2120 (here for fence_brocade)

2621: fence_cisco_ucs/@notls
      - new optional attribute
2624: fence_cisco_ucs/@ssl_insecure
      - new optional attribute
2627: fence_cisco_ucs/@ssl_secure
      - new optional attribute
2630: fence_cisco_ucs/@gnutlscli_path
      - new optional attribute

2748: fence_drac5/@port
      - new optional attribute
2751: see 2287 (here for fence_drac5)
2754: see 2117 (here for fence_drac5)
2757: see 2120 (here for fence_drac5)

2873: fence_ilo_moonshot
      - new fence agent

3029: see 2287 (here for fence_hpblade)
3032: see 2117 (here for fence_hpblade)
3035: see 2120 (here for fence_hpblade)

3346: see 2621 (here for fence_ilo)
3349: see 2624 (here for fence_ilo)
3352: see 2627 (here for fence_ilo)
3355: fence_ilo/@tls1.0
      - new optional attribute
3358: see 2630 (here for fence_ilo)


3426: see 2621 (here for fence_ilo2)
3429: see 2624 (here for fence_ilo2)
3432: see 2627 (here for fence_ilo2)
3435: see 3344 (here for fence_ilo2)
3438: see 2630 (here for fence_ilo2)

3510: fence_mpath
      - new fence agent

3616: fence_ilo_mp/@separator
      - parameter got removed (!)
3616: see 2287 (here for fence_ilo_mp)
3636: see 2117 (here for fence_ilo_mp)
3640: see 2120 (here for fence_ilo_mp)

4016: see 2621 (here for fence_rhevm)
4019: see 2624 (here for fence_rhevm)
4022: see 2627 (here for fence_rhevm)
4025: fence_rhevm/@use_cookies
      - new optional parameter
4028: fence_rhevm/@login_timeout
      - new optional parameter
4031: see 2630 (here for fence_rhevm)

4099: fence_rsa/@inet4_only
      - new optional parameter
4102: fence_rsa/@inet6_only
      - new optional parameter
4105: see 2117 (here for fence_rsa)
4108: see 2120 (here for fence_rsa)

3616: fence_rsb/@separator
      - parameter got removed (!)
4165: see 2287 (here for fence_rsb)
4185: see 2117 (here for fence_rsb)
4188: see 2120 (here for fence_rsb)

4192: fence_tripplite_snmp
      - new fence agent

4391: fence_virsh/@cmd_prompt
      - new optional parameter
4394: fence_virsh/@sudo
      - new optional parameter
4397: see 2117 (here for fence_virsh)
4400: fence_virsh/@sudo_path
      - new optional parameter

4459: fence_vmware/@port
      - parameter got removed (!)
4459: see 4099 (here for fence_vmware)
4489: fence_vmware/@separator
      - parameter got removed (!)
4489: see 4102 (here for fence_vmware)
4509: fence_vmware/@ipport
      - new optional parameter
4512: see 2287 (here for fence_vmware)
4515: see 2117 (here for fence_vmware)

4583: see 4099 (here for fence_vmware_soap)
4586: see 4102 (here for fence_vmware_soap)
3589: see 2621 (here for fence_vmware_soap)
3592: see 2624 (here for fence_vmware_soap)
3595: see 2627 (here for fence_vmware_soap)
3598: see 2630 (here for fence_vmware_soap)

4675: see 2287 (here for fence_wti)
4678: see 2117 (here for fence_wti)
4681: see 2120 (here for fence_wti)

4737: fence_emerson
      - new fence agent

4989: fence_ilo3_ssh
      - new fence agent

5152: fence_ilo4_ssh
      - new fence agent

5232: fence_ilo_ssh
      - new fence agent



=== NOT COVERED YET ===

These are not covered yet because the diff is not optimal for
them (they are placed on different location preventing from
direct in-document comparison):

imm
ipmilan
eps
idrac
ilo3
ilo4



=== RECAP ===

New fence agents (if I am not missing anything):

fence_emerson
fence_ilo3_ssh
fence_ilo4_ssh
fence_ilo_moonshot
fence_ilo_ssh
fence_mpath
fence_tripplite_snmp

Comment 12 Jan Pokorný [poki] 2015-05-19 16:21:35 UTC
re [comment 11]:

One important detail (even though rather implementation-specific)
with fence-agents is that there are plenty of duplicate files
(IIRC, used to be symlinks right away in the past, but this was
changed to accommodate situations where symlinking is not possible).

Let's have a look at the groups of such duplicates:

$ rpm -ql fence-agents | xargs -I{} sh -c 'test -d {} || ls -l {}' \
  | cut "-d " -f5,9 | grep '/usr/sbin/fence_' | sort | \
  { m=0; prev_s=0; prev_f=/dev/null; \
    while read s f; do \
      [ "$prev_s" -ne "$s" -o -n "$(diff -u "$prev_f" "$f")" ] \
      && { [ "$m" -eq 1 ] && echo -e "$prev_s;$prev_f\n"; m=0; } \
      || { echo "$prev_s;$prev_f"; m=1; }; \
      prev_s=$s; prev_f=$f; \
    done; }
> 2038;/usr/sbin/fence_ilo3_ssh
> 2038;/usr/sbin/fence_ilo4_ssh
> 2038;/usr/sbin/fence_ilo_ssh
> 
> 4313;/usr/sbin/fence_ilo
> 4313;/usr/sbin/fence_ilo2
> 
> 4800;/usr/sbin/fence_idrac
> 4800;/usr/sbin/fence_ilo3
> 4800;/usr/sbin/fence_ilo4
> 4800;/usr/sbin/fence_imm
> 4800;/usr/sbin/fence_ipmilan
> 
> 6568;/usr/sbin/fence_apc_snmp
> 6568;/usr/sbin/fence_tripplite_snmp

of which a first group, of fence_ilo*_ssh, and fence_tripplite_snmp
are the new agents.

Comment 13 errata-xmlrpc 2015-07-22 07:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1405.html


Note You need to log in before you can comment on or make changes to this bug.