Bug 121078 - up2date error
up2date error
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
:
: 160583 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 17:17 EDT by Chandra
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandra 2004-04-16 17:17:06 EDT
Description of problem:
When i try to run up to date i get the following error:

Error Message:
    Please run rhn_register (or up2date --register on Red Hat Linux 8.0)
as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Version-Release number of selected component (if applicable):
I have update version up2date-4.0.1-1, which wants to be updated to
version up2date-4.2.5-1. I can only find older versions on the redhat
web site. 

How reproducible:
very

Steps to Reproduce:
1.redhat aler notification tool
2.click on "launch up2date" button
3.
  
Actual results:


Expected results:


Additional info:
The system is registered on the RHN website. I am root when i try to
run up2date. I am new to linux. system is registered as  Red Hat
Enterprise Linux WS (v. 3 for x86)
Comment 1 Suzanne Hillman 2004-04-19 13:56:04 EDT
How did you become root? Log in as such, or 'su' to it?
Comment 2 Chandra 2004-04-19 15:45:21 EDT
I logged straight into root. Although, i have entered the root 
password while logged in as another persona. In either case i get the 
same update error. 
Comment 3 Adrian Likins 2004-04-22 15:53:48 EDT
The error indicates the systemid sent up identifying the client
doesn't match anything in the database.
 
If you have changed to serverUrl (to point at a RHN Sattellite
for example) could be a cause. So verify serverURL in
/etc/sysconfig/rhn/up2date is pointing at 
https://xmlrpc.rhn.redhat.com/XMLRPC

also, if you could give me your RHN username, I can try
to verify the server is registered properly. 
Comment 4 Chandra 2004-04-22 18:58:15 EDT
The URL above is the serverURL is see in the file. my RHN user name is
Oliveira3Lin1. Thanks
Comment 5 Mark J. Cox (Product Security) 2005-06-16 07:58:40 EDT
*** Bug 160583 has been marked as a duplicate of this bug. ***
Comment 6 RHEL Product and Program Management 2007-10-19 15:27:29 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.