Bug 121088 - Package info incorrect: states "Note: This is a relocatable package" but package is not relocateable
Package info incorrect: states "Note: This is a relocatable package" but pack...
Status: CLOSED DUPLICATE of bug 107393
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-16 19:01 EDT by Matt Van Gundy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Van Gundy 2004-04-16 19:01:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
rpm -qip subversion-1.0.1-1.i386.rpm on the package obtained from
rpmfind.net's Fedora Core Devel section states that it is relocateable
in the description section.  However, when I tried to rpm -Uvh
--prefix ~ subversion-1.0.1-1.i386.rpm I get "error: package
subversion is not relocateable".  A quick check of the Relocations
entry in the package info confirms this.

Version-Release number of selected component (if applicable):
1.0.1-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -qip subversion-1.0.1-1.i386.rpm
2. rpm -Uvh --prefix ~ subversion-1.0.1-1.i386.rpm
    

Actual Results:  warning: subversion-1.0.1-1.i386.rpm: V3 DSA
signature: NOKEY, key ID 30c9ecf8
error: package subversion is not relocateable

Expected Results:  Package should have installed in my home directory. :-)

Additional info:
Comment 1 Joe Orton 2004-04-17 05:27:42 EDT
It doesn't actually say that any more.  But there is an obscure rpm
i18n thing which means that sometimes you'll get the wrong
%description displayed, this happened to me too.  Try

unset LANG
rpm -qip subversion-1.0.1-1.i386.rpm

or maybe

LANG=C rpm -qip subversion-1.0.1-1.i386.rpm

I can't remember which works around it.
Comment 2 Miloslav Trmac 2004-04-17 09:11:11 EDT

*** This bug has been marked as a duplicate of 107393 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.