Bug 121098 - battstat_applet is missing
Summary: battstat_applet is missing
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
(Show other bugs)
Version: 2
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 121181 (view as bug list)
Depends On:
Blocks: fedora-ppc
TreeView+ depends on / blocked
 
Reported: 2004-04-17 03:47 UTC by David Woodhouse
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.6.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 19:14:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2004-04-17 03:47:14 UTC
PowerBook kernels provide /proc/apm. The battery applet, however, is
not present on ppc. Bonobo errors are reported on login.

Comment 1 Mark McLoughlin 2004-04-19 16:21:25 UTC
You need the apmd package for the applet and this is only built on ix86

Need to fix gnome-panel's %post add-battstat-to-the-default-panel
heuristic 

Comment 2 Mark McLoughlin 2004-04-19 17:15:46 UTC
David: could you test gnome-panel-2.6.0-8 in dist-fc2-HEAD?

* Mon Apr 19 2004 Mark McLoughlin <markmc@redhat.com> 2.6.0-8
- Only put the battstat applet on the default panel on ix86 (i.e. the
  platforms where apmd is built) - bug #121098


Comment 3 Mark McLoughlin 2004-04-19 17:19:05 UTC
*** Bug 121181 has been marked as a duplicate of this bug. ***

Comment 4 David Woodhouse 2004-04-19 17:25:39 UTC
But that way I still don't get the battstat_applet, which is still wrong.

I 'fixed' it locally by building apmd and rebuilding gnome-applets
without ppc listed in 'no_apm_archs'. 

Comment 5 Mark McLoughlin 2004-04-19 19:14:19 UTC
Fixed with gnome-panel-2.6.0-9, gnome-applets-2.6.0-3 and apmd-3.0.2-22

* Mon Apr 19 2004 Mark McLoughlin <markmc@redhat.com> 2.6.0-9
- Install battstat on the default panel on ppc too

* Mon Apr 19 2004 Mark McLoughlin <markmc@redhat.com> 1:2.6.0-3
- Build battstat on ppc too

* Mon Apr 19 2004 David Woodhouse <dwmw2@redhat.com>
- build on ppc too because that emulates APM



Note You need to log in before you can comment on or make changes to this bug.