Bug 121108 - guile %post failure causes rpm duplicate
guile %post failure causes rpm duplicate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: guile (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 121124 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-17 06:09 EDT by Warren Togami
Modified: 2015-03-04 20:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 14:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guile.spec.patch (2.18 KB, patch)
2004-04-17 06:11 EDT, Warren Togami
no flags Details | Diff

  None (edit)
Description Warren Togami 2004-04-17 06:09:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040404 Firefox/0.8

Description of problem:
You can reproduce this problem easily with the following procedure.

[root@ibmlaptop tmp]# rpm -e guile --allmatches --nodeps
[root@ibmlaptop tmp]# rpm -Uvh guile-1.6.4-9.2.1.i386.rpm
Preparing...               
########################################### [100%]
   1:guile                 
########################################### [100%]
[root@ibmlaptop tmp]# rpm -Uvh guile-1.6.4-10.i386.rpm
Preparing...               
########################################### [100%]
   1:guile                 
########################################### [100%]
/sbin/ldconfig: relative path `2' used to build cache
error: %post(guile-1.6.4-10) scriptlet failed, exit status 1
[root@ibmlaptop tmp]# rpm -q guile
guile-1.6.4-9.2.1
guile-1.6.4-10
Comment 1 Warren Togami 2004-04-17 06:11:51 EDT
Created attachment 99506 [details]
guile.spec.patch

* Fixes info install
* Prevents %post failure which caused rpm database duplicate

Please allow me to checkin and build this.
Comment 2 Warren Togami 2004-04-17 06:14:01 EDT
Oops, it also shrinks the installed package size by more than 150KB.
Comment 3 Warren Togami 2004-04-18 00:06:43 EDT
Jeremy said I can checked this in, hopefully should hit rawhide soon.
Comment 4 Warren Togami 2004-04-18 14:55:14 EDT
*** Bug 121124 has been marked as a duplicate of this bug. ***
Comment 5 Warren Togami 2004-04-19 14:35:43 EDT
rawhide tomorrow, but I am copying this to fedora.us RPMS.updates now.

Note You need to log in before you can comment on or make changes to this bug.