Bug 1211123 - ls command failed with features.read-only on while mounting ec volume.
Summary: ls command failed with features.read-only on while mounting ec volume.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
: 1211915 (view as bug list)
Depends On:
Blocks: 1225320 1227172
TreeView+ depends on / blocked
 
Reported: 2015-04-13 05:31 UTC by zhoushicheng
Modified: 2016-06-16 12:49 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1225320 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:49:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description zhoushicheng 2015-04-13 05:31:36 UTC
Description of problem:
ls command failed if ec volume was set features.read-only on

Version-Release number of selected component (if applicable):
starting from gluster3.6.3 beta1 to gluster3.7 dev

How reproducible:

Create ec volume and set this volume with features.read-only on.
Mount ec volume and enter ls cmd under mount point.
Steps to Reproduce:
1.Create ec volume.
2.Set features.read-only on
3.Mount volume and enter ls cmd.

Actual results:

ls: cannot open directory .: Input/output error

Expected results:

list all the files

Additional info:

Comment 1 Pranith Kumar K 2015-05-09 17:43:19 UTC
*** Bug 1211915 has been marked as a duplicate of this bug. ***

Comment 2 Anand Avati 2015-05-09 17:53:35 UTC
REVIEW: http://review.gluster.org/10727 (worm: Let lock calls succeed) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Pranith Kumar K 2015-05-09 17:55:21 UTC
With the fix:

root@pranithk-laptop - ~ 
23:19:42 :) ⚡ glusterd && gluster volume create ec2 disperse-data 2 redundancy 1 `hostname`:/home/gfs/ec_{0..2} force && gluster volume start ec2 && mount -t glusterfs `hostname`:/ec2 /mnt/ec2
volume create: ec2: success: please start the volume to access data
cd volume start: ec2: success

root@pranithk-laptop - ~ 
23:19:49 :) ⚡ cd /mnt/ec2

root@pranithk-laptop - /mnt/ec2 
23:19:50 :) ⚡ dd if=/dev/zero of=test.bak bs=1M count=10
10+0 records in
10+0 records out
10485760 bytes (10 MB) copied, 0.046685 s, 225 MB/s

root@pranithk-laptop - /mnt/ec2 
23:19:53 :) ⚡ md5sum test.bak
f1c9645dbc14efddc7d8a322685f26eb  test.bak

root@pranithk-laptop - /mnt/ec2 
23:20:03 :) ⚡ cd

root@pranithk-laptop - ~ 
23:20:05 :) ⚡ umount /mnt/ec2 

root@pranithk-laptop - ~ 
23:20:07 :) ⚡ gluster v set ec2 read-only on
volume set: success

root@pranithk-laptop - ~ 
23:20:11 :) ⚡ mount -t glusterfs `hostname`:/ec2 /mnt/ec2

root@pranithk-laptop - ~ 
23:20:14 :) ⚡ cd /mnt/ec2

root@pranithk-laptop - /mnt/ec2 
23:20:15 :) ⚡ md5sum test.bak 
f1c9645dbc14efddc7d8a322685f26eb  test.bak

root@pranithk-laptop - /mnt/ec2 
23:20:21 :) ⚡ ls
test.bak

root@pranithk-laptop - /mnt/ec2 
23:20:25 :) ⚡

Comment 4 Anand Avati 2015-05-15 08:24:14 UTC
REVIEW: http://review.gluster.org/10727 (worm: Let lock calls succeed) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Anand Avati 2015-05-21 16:48:26 UTC
REVIEW: http://review.gluster.org/10886 (posix: Do not update unmodified xattr in (f)xattrop) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 6 Anand Avati 2015-05-22 04:26:29 UTC
REVIEW: http://review.gluster.org/10727 (worm: Let lock, zero xattrop calls succeed) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 7 Anand Avati 2015-05-22 04:26:32 UTC
REVIEW: http://review.gluster.org/10886 (posix: Do not update unmodified xattr in (f)xattrop) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 8 Anand Avati 2015-05-22 07:29:51 UTC
REVIEW: http://review.gluster.org/10886 (posix: Do not update unmodified xattr in (f)xattrop) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 9 Anand Avati 2015-05-22 09:37:32 UTC
REVIEW: http://review.gluster.org/10886 (posix: Do not update unmodified xattr in (f)xattrop) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 10 Anand Avati 2015-05-27 10:24:41 UTC
COMMIT: http://review.gluster.org/10886 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 5513144feb5b062b733d7514adf194429e31666f
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Thu May 21 18:45:12 2015 +0200

    posix: Do not update unmodified xattr in (f)xattrop
    
    If a (f)xattrop is issued with a value that only contains 0's,
    then we don't modify or create the extended attribute. This
    is useful to avoid ctime modifications when the only purpose
    of the xattrop was to get the current value.
    
    Change-Id: Ia62494e9009962e683c8276783f671da17a8b03a
    BUG: 1211123
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/10886
    Tested-by: NetBSD Build System
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 11 Anand Avati 2015-05-28 11:15:00 UTC
REVIEW: http://review.gluster.org/10727 (worm: Let lock, zero xattrop calls succeed) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 12 Anand Avati 2015-05-29 11:47:52 UTC
COMMIT: http://review.gluster.org/10727 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 15a28c2b70003434d448a67d66ff722294e816f7
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Sat May 9 23:11:15 2015 +0530

    worm: Let lock, zero xattrop calls succeed
    
    Locks can be taken just to inspect the data as well, so allow them.
    Xattrops are internal fops so we can allow them as well as longs as
    it doesn't change the xattr value, i.e. All-zero xattrop.
    
    Change-Id: Idc06d2043eb472c064db40d811a80058f0bda378
    BUG: 1211123
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/10727
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: NetBSD Build System

Comment 13 Nagaprasad Sathyanarayana 2015-10-25 15:16:29 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 14 Niels de Vos 2016-06-16 12:49:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.