Bug 1225320 - ls command failed with features.read-only on while mounting ec volume.
Summary: ls command failed with features.read-only on while mounting ec volume.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1211123
Blocks: 1227172
TreeView+ depends on / blocked
 
Reported: 2015-05-27 06:32 UTC by Pranith Kumar K
Modified: 2015-06-20 09:48 UTC (History)
12 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1211123
: 1227172 (view as bug list)
Environment:
Last Closed: 2015-06-20 09:48:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2015-05-27 06:32:52 UTC
+++ This bug was initially created as a clone of Bug #1211123 +++

Description of problem:
ls command failed if ec volume was set features.read-only on

Version-Release number of selected component (if applicable):
starting from gluster3.6.3 beta1 to gluster3.7 dev

How reproducible:

Create ec volume and set this volume with features.read-only on.
Mount ec volume and enter ls cmd under mount point.
Steps to Reproduce:
1.Create ec volume.
2.Set features.read-only on
3.Mount volume and enter ls cmd.

Actual results:

ls: cannot open directory .: Input/output error

Expected results:

list all the files

Additional info:

--- Additional comment from Pranith Kumar K on 2015-05-09 13:43:19 EDT ---



--- Additional comment from Anand Avati on 2015-05-09 13:53:35 EDT ---

REVIEW: http://review.gluster.org/10727 (worm: Let lock calls succeed) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Pranith Kumar K on 2015-05-09 13:55:21 EDT ---

With the fix:

root@pranithk-laptop - ~ 
23:19:42 :) ⚡ glusterd && gluster volume create ec2 disperse-data 2 redundancy 1 `hostname`:/home/gfs/ec_{0..2} force && gluster volume start ec2 && mount -t glusterfs `hostname`:/ec2 /mnt/ec2
volume create: ec2: success: please start the volume to access data
cd volume start: ec2: success

root@pranithk-laptop - ~ 
23:19:49 :) ⚡ cd /mnt/ec2

root@pranithk-laptop - /mnt/ec2 
23:19:50 :) ⚡ dd if=/dev/zero of=test.bak bs=1M count=10
10+0 records in
10+0 records out
10485760 bytes (10 MB) copied, 0.046685 s, 225 MB/s

root@pranithk-laptop - /mnt/ec2 
23:19:53 :) ⚡ md5sum test.bak
f1c9645dbc14efddc7d8a322685f26eb  test.bak

root@pranithk-laptop - /mnt/ec2 
23:20:03 :) ⚡ cd

root@pranithk-laptop - ~ 
23:20:05 :) ⚡ umount /mnt/ec2 

root@pranithk-laptop - ~ 
23:20:07 :) ⚡ gluster v set ec2 read-only on
volume set: success

root@pranithk-laptop - ~ 
23:20:11 :) ⚡ mount -t glusterfs `hostname`:/ec2 /mnt/ec2

root@pranithk-laptop - ~ 
23:20:14 :) ⚡ cd /mnt/ec2

root@pranithk-laptop - /mnt/ec2 
23:20:15 :) ⚡ md5sum test.bak 
f1c9645dbc14efddc7d8a322685f26eb  test.bak

root@pranithk-laptop - /mnt/ec2 
23:20:21 :) ⚡ ls
test.bak

root@pranithk-laptop - /mnt/ec2 
23:20:25 :) ⚡

--- Additional comment from Anand Avati on 2015-05-15 04:24:14 EDT ---

REVIEW: http://review.gluster.org/10727 (worm: Let lock calls succeed) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2015-05-21 12:48:26 EDT ---

REVIEW: http://review.gluster.org/10886 (posix: Do not update unmodified xattr in (f)xattrop) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Anand Avati on 2015-05-22 00:26:29 EDT ---

REVIEW: http://review.gluster.org/10727 (worm: Let lock, zero xattrop calls succeed) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2015-05-22 00:26:32 EDT ---

REVIEW: http://review.gluster.org/10886 (posix: Do not update unmodified xattr in (f)xattrop) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2015-05-22 03:29:51 EDT ---

REVIEW: http://review.gluster.org/10886 (posix: Do not update unmodified xattr in (f)xattrop) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2015-05-22 05:37:32 EDT ---

REVIEW: http://review.gluster.org/10886 (posix: Do not update unmodified xattr in (f)xattrop) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 1 Anand Avati 2015-05-27 06:35:13 UTC
REVIEW: http://review.gluster.org/10928 (posix: Do not update unmodified xattr in (f)xattrop) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-05-28 11:14:28 UTC
REVIEW: http://review.gluster.org/10928 (posix: Do not update unmodified xattr in (f)xattrop) posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Anand Avati 2015-05-29 05:54:38 UTC
COMMIT: http://review.gluster.org/10928 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 02e53c084953399a5f73905085a109b61d9606c8
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Thu May 21 18:45:12 2015 +0200

    posix: Do not update unmodified xattr in (f)xattrop
    
            Backport of http://review.gluster.org/10886
    
    If a (f)xattrop is issued with a value that only contains 0's,
    then we don't modify or create the extended attribute. This
    is useful to avoid ctime modifications when the only purpose
    of the xattrop was to get the current value.
    
    Change-Id: Ia62494e9009962e683c8276783f671da17a8b03a
    BUG: 1225320
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/10928
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 4 Niels de Vos 2015-06-02 08:03:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Anand Avati 2015-06-02 13:50:20 UTC
REVIEW: http://review.gluster.org/11046 (worm: Let lock, zero xattrop calls succeed) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 6 Anand Avati 2015-06-05 16:24:06 UTC
COMMIT: http://review.gluster.org/11046 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit d38939e388c819f6c2ba6a6891edc27b6ecf3731
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Sat May 9 23:11:15 2015 +0530

    worm: Let lock, zero xattrop calls succeed
    
            Backport of http://review.gluster.org/10727
    
    Locks can be taken just to inspect the data as well, so allow them.
    Xattrops are internal fops so we can allow them as well as longs as
    it doesn't change the xattr value, i.e. All-zero xattrop.
    
    BUG: 1225320
    Change-Id: I9e72806e0605ab2938348a87935966909f1a721f
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11046
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 7 Niels de Vos 2015-06-20 09:48:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.