Bug 121129 - kdelibs conflicts with kde-i18n-Brazil 3.2.2-1
kdelibs conflicts with kde-i18n-Brazil 3.2.2-1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-17 14:37 EDT by Alexandre Oliva
Modified: 2014-01-21 17:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 04:49:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-04-17 14:37:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Somehow, up2date -u kdelibs kde-i18n-Brazil reports lots of conflicts
between these two packages.  This is the first of them:

file /usr/share/doc/HTML/pt_BR/common/1.png conflicts between
attempted installs of kde-i18n-Brazil-3.2.2-1 and kdelibs-3.2.2-1


It's the only language in kde-i18n-Brazil that conflicts with kdelibs.
 up2date -u --exclude=kde-i18n-Brazil succeeds, and up2date -u
kde-i18n-Brazil afterwards succeeds.

Oddly, rpm -ql kdelibs | grep pt_BR/common gives no hits, but rpm -qf
/usr/share/doc/HTML/pt_BR/common/1.png lists both rpms.

What's going on?!?  Could this possibly be a packaging bug in kdelibs,
or is it a bug in rpm (or up2date)?


Version-Release number of selected component (if applicable):
kdelibs-3.2.2-1 kde-i18n-Brazil-3.2.2-1

How reproducible:
Always

Steps to Reproduce:
1.up2date -u

Actual Results:  file /usr/share/doc/HTML/pt_BR/common/1.png conflicts
between attempted installs of kde-i18n-Brazil-3.2.2-1 and kdelibs-3.2.2-1
(and many other similar errors about other pt_BR files)

Expected Results:  No such errors.

Additional info:
Comment 1 Warren Togami 2004-04-18 20:49:35 EDT
skvidal said this affects British too.  I'm investigating.
Comment 2 Warren Togami 2004-04-18 23:24:31 EDT
Hmmm, bad news, I tried downgrading two of my systems (i386 and
x86_64) to KDE 3.2.1 then did a upgrade again.  I can't reproduce any
of these conflicts.
Comment 3 Warren Togami 2004-04-19 07:15:01 EDT
Both than and I were completely unable to reproduce this problem. 
Than said that Bug #121058 appears to be the same problem.

This may be incorrect, but it may be worth checking out.  I personally
suspect that this could be an error caused by the rpm-python bindings.
 Alexandre said that he always uses up2date, while Seth Vidal uses
yum.  I personally always use apt, while than said that he uses rpm. 
(Huh?)  apt and rpm avoid the rpm-python bindings entirely, so this
could be a common cause of this problem?  Just a guess...
Comment 4 Karsten Hopp 2004-04-19 08:40:19 EDT
I could reproduce it here and Than and I tracked it down to
/usr/share/doc/HTML/[pt_BR,en_GB]/common being a symlink in older 
versions and a directory in kde-3.2.2. 
Comment 5 Ngo Than 2004-04-19 17:38:37 EDT
it looks like that i have to make symlinks to ../en/common instead a
directory here as it's done in old version! but it's a bug and should
be a directory instead a symlink!

Jeff, it looks like a bug in rpm, or i'm wrong here ?
Comment 6 Ngo Than 2004-04-20 04:49:30 EDT
ok, i have removed the directories add added the symlinks back.
kde-i18n-3.2.2-2 should fix this problem.

Note You need to log in before you can comment on or make changes to this bug.