Bug 121143 - "Invalid argument" from initscripts
"Invalid argument" from initscripts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 121663 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-17 20:57 EDT by Michal Jaegermann
Modified: 2016-10-28 09:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: 7.51-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1338716 (view as bug list)
Environment:
Last Closed: 2004-05-03 17:18:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-04-17 20:57:05 EDT
Description of problem:

When booting with 'selinux=0' one sees this:

INIT: version 2.85 booting
cat: /proc/self/attr/current: Invalid argument

The culprit is that line:

if [ -n "$selinuxfs" -a  "`cat /proc/self/attr/current`" != "kernel"
]; then
.....

because 'test' is not short-circuiting '-a'.  Replacing the above
with

if [ -n "$selinuxfs" ] && \
   [ "`cat /proc/self/attr/current`" != "kernel" ]; then

will work as clearly intended.

Version-Release number of selected component (if applicable):
initscripts-7.50-1

How reproducible:
Always
Comment 1 Craig Cruden 2004-05-01 12:39:23 EDT
Looks similar to another FC Blocker bug:

121663 [NEW - normal - notting@redhat.com] strange boot message when
rc.sysinit starts to run.
Comment 2 Bill Nottingham 2004-05-02 20:57:20 EDT
*** Bug 121663 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2004-05-03 17:18:22 EDT
Fixed, will be in 7.51-1, thanks!

Note You need to log in before you can comment on or make changes to this bug.