Bug 121663 - strange boot message when rc.sysinit starts to run
strange boot message when rc.sysinit starts to run
Status: CLOSED DUPLICATE of bug 121143
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-24 20:46 EDT by Brian Millett
Modified: 2014-03-16 22:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Millett 2004-04-24 20:46:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a)
Gecko/20040422 Firefox/0.8.0+

Description of problem:
cat: /proc/self/attr/current: Invalid argument

is the message seen.

I am booting with selinux=0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot
2.read screen
3.
    

Actual Results:  cat: /proc/self/attr/current: Invalid argument

Expected Results:  no message about "invalid argument"

Additional info:

code in rc.sysinit is:
# Check SELinux status
selinuxfs=`awk '/ selinuxfs / { print $2 }' /proc/mounts`
SELINUX=
if [ -n "$selinuxfs" -a  "`cat /proc/self/attr/current`" != "kernel"
]; then
	if [ -r $selinuxfs/enforce ] ; then
		SELINUX=`cat $selinuxfs/enforce`
	else
		# assume enforcing if you can't read it
		SELINUX=1
	fi
fi
Comment 1 Craig Cruden 2004-04-29 08:24:34 EDT
I have seen the same "problem" on bootup....  

After bootup I decided to execute "cat /proc/self/attr/current" at 
the shell, and received the same:
   "cat: /proc/self/attr/current: Invalid argument".  

I checked the file and it exists with 0 bytes [rw-rw-rw-].  

I decided to create another file in my home directory [text.txt] with 
zero bytes [touch text.txt] and then execute "cat text.txt".... no 
error.  

Could this be related to something special about the "proc" 
filesystem?
Comment 2 Craig Cruden 2004-05-01 12:40:12 EDT
Looks similar to another FC Blocker bug:

121143 [NEW - normal - notting@redhat.com] "Invalid argument" from
initscripts.
Comment 3 Bill Nottingham 2004-05-02 20:57:17 EDT

*** This bug has been marked as a duplicate of 121143 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.