Bug 1211562 - Data Tiering:UI:changes required to CLI responses for attach and detach tier
Summary: Data Tiering:UI:changes required to CLI responses for attach and detach tier
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Linux
urgent
medium
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard: TIERING
: 1214273 (view as bug list)
Depends On:
Blocks: qe_tracker_everglades 1220052 1229248 1260923
TreeView+ depends on / blocked
 
Reported: 2015-04-14 10:43 UTC by Nag Pavan Chilakam
Modified: 2016-06-16 12:50 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1220052 1229248 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:50:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nag Pavan Chilakam 2015-04-14 10:43:22 UTC
Description of problem:
======================
The response user gets after executing a attach-tier or detach-tier right now are quite ambigous. They talk about brick rather than the tier.
Eg: on a attach tier it says "add-brick is success"
[root@yarrow ~]# gluster v attach-tier ec_vol1 yarrow:/yarrow_ssd_75G_2/ec_vol1 rhs-client6:/brick15/ec_vol1 force
volume add-brick: success
[root@yarrow ~]# gluster v info ec_vol1


It should instead say, attaching of tier to <volname> is successful


same with detach tier, it say remove-brick is success

Need to take care even when the command fails, like it should be detach-tier fails rather than remove-brick fails


Version-Release number of selected component (if applicable):
============================================================
[root@yarrow ~]# gluster --version
glusterfs 3.7dev built on Apr  8 2015 17:57:45
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@yarrow ~]# rpm -qa|grep gluster
glusterfs-cli-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-server-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-libs-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-fuse-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-api-3.7dev-0.994.gitf522001.el6.x86_64



How reproducible:
=================
always and easily


Steps to Reproduce:
==================
1.create a regular volume
2.attach a tier, the reponse user gets talks abt brick rather than tier
3.same with detaching the tier

Comment 1 Anand Avati 2015-04-17 09:01:13 UTC
REVIEW: http://review.gluster.org/10284 (cli/tiering: Enhance cli output for tiering) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-05-02 12:15:10 UTC
REVIEW: http://review.gluster.org/10284 (cli/tiering: Enhance cli output for tiering) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Anand Avati 2015-05-08 22:12:26 UTC
REVIEW: http://review.gluster.org/10284 (cli/tiering: Enhance cli output for tiering) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Anand Avati 2015-05-09 04:27:57 UTC
COMMIT: http://review.gluster.org/10284 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 2676c402bc47ee89b763393e496a013e82d76e54
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Sat May 2 17:31:07 2015 +0530

    cli/tiering: Enhance cli output for tiering
    
    Fix for handling cli output for attach-tier and
    detach-tier
    
    Change-Id: I4d17f4b09612754fe1b8cec6c2e14927029b9678
    BUG: 1211562
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/10284
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Niels de Vos 2015-05-15 13:07:34 UTC
This change should not be in "ON_QA", the patch posted for this bug is only available in the master branch and not in a release yet. Moving back to MODIFIED until there is an beta release for the next GlusterFS version.

Comment 6 Niels de Vos 2015-05-18 06:41:39 UTC
*** Bug 1214273 has been marked as a duplicate of this bug. ***

Comment 7 Nagaprasad Sathyanarayana 2015-10-25 15:14:57 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 8 Niels de Vos 2016-06-16 12:50:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.