Bug 1211602 - Hide ipa-server-install KDC master password option (-P)
Summary: Hide ipa-server-install KDC master password option (-P)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-14 12:19 UTC by Petr Vobornik
Modified: 2016-11-04 05:45 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:45:23 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2015-04-14 12:19:46 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/4516

Option "-P" is just a remnant of FreeIPA v1 we no longer need. Admins should not be encouraged in setting KDC master password manually, it is already autogenerated by `ipa-server-install` with the sufficient complexity and password quality.

Comment 1 Petr Vobornik 2015-05-07 14:01:53 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/059a4c188760ec7360ccb68a5c8a292afb21d35e

Comment 3 Pavel Picka 2015-10-01 14:17:26 UTC
Not verified, ipa-server-install -h and --help still showing '-P' as option

Manual page under deprecated options -  OK
within ipa-server-install -P ...  warning showed OK

Output : 

[root@rhel04 ~]# rpm -q ipa-server
ipa-server-4.2.0-12.el7.x86_64
[root@rhel04 ~]# ipa-server-install --help | grep -e "-P"
    -P MASTER_PASSWORD, --master-password=MASTER_PASSWORD
[root@rhel04 ~]# ipa-server-install -h | grep -e "-P"
    -P MASTER_PASSWORD, --master-password=MASTER_PASSWORD
[root@rhel04 ~]# man ipa-server-install | grep -C 1 -e "-P"
DEPRECATED OPTIONS
       -P MASTER_PASSWORD, --master-password=MASTER_PASSWORD
              The kerberos master password (normally autogenerated).

Comment 4 Jan Cholasta 2015-10-01 14:21:39 UTC
The fix for this bug was accidentally undone by the fix for bug 1250928.

Comment 7 Petr Vobornik 2016-02-15 17:45:02 UTC
I can no longer reproduce with 4.3.x:

#  ipa-server-install --help | grep -e "-P"
# ipa-server-install -h | grep -e "-P"
# man ipa-server-install | grep -C 1 -e "-P"
DEPRECATED OPTIONS
       -P MASTER_PASSWORD, --master-password=MASTER_PASSWORD
              The kerberos master password (normally autogenerated).

Not sure in which commit(s) it was fixed.

Comment 8 Mike McCune 2016-03-28 22:43:24 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 10 Pavel Picka 2016-09-06 13:11:06 UTC
Verified

[root@ipa ~]# ipa-server-install --help | grep -e "-P"
[root@ipa ~]# ipa-server-install -h | grep -e "-P"
[root@ipa ~]# man ipa-server-install | grep -C 1 -e "-P"
DEPRECATED OPTIONS
       -P MASTER_PASSWORD, --master-password=MASTER_PASSWORD
              The kerberos master password (normally autogenerated).
[root@ipa ~]# rpm -q ipa-server
ipa-server-4.4.0-8.el7.x86_64

Comment 12 errata-xmlrpc 2016-11-04 05:45:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.