Bug 121168 - SAX parser not registered
SAX parser not registered
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-XML-LibXML (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
: EasyFix, Patch
Depends On: 121167
Blocks: FC3Target FC2Update FC3BugWeekQA
  Show dependency treegraph
 
Reported: 2004-04-18 07:44 EDT by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-17 22:06:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Register parsers, other improvements (3.40 KB, patch)
2004-04-18 07:45 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2004-04-18 07:44:50 EDT
perl-XML-LibXML-1.56-10 does not register the SAX parser.  Will attach
a fix which also updates to 1.58 and has some other improvements.
Comment 1 Ville Skyttä 2004-04-18 07:45:57 EDT
Created attachment 99515 [details]
Register parsers, other improvements

* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
- Update to 1.58.
- Require perl(:MODULE_COMPAT_*).
- Handle ParserDetails.ini parser registration.
- BuildRequires libxml2-devel.
- Own installed directories.
Comment 2 Ville Skyttä 2004-04-18 07:47:58 EDT
Note: using %triggerin with perl-XML-SAX instead of %post for cases
where perl-XML-SAX is upgraded such that the versioned dir location of
ParserDetails.ini changes, eg.

/usr/lib/perl5/vendor_perl/5.8.1/XML/SAX/ParserDetails.ini ->
/usr/lib/perl5/vendor_perl/5.8.3/XML/SAX/ParserDetails.ini
Comment 3 Ville Skyttä 2004-07-06 17:59:42 EDT
Except for the Release tag bump in rawhide, the patch still applies. 
Please fix for FC3.
Comment 4 Warren Togami 2004-09-24 18:55:15 EDT
Applied to CVS, but build may be delayed due to build system problems.

Note You need to log in before you can comment on or make changes to this bug.