Bug 1211836 - glusterfs-api.pc versioning breaks QEMU
Summary: glusterfs-api.pc versioning breaks QEMU
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact: Sudhir D
URL: http://thread.gmane.org/gmane.comp.em...
Whiteboard:
Depends On:
Blocks: 1211837 1211840 1211841
TreeView+ depends on / blocked
 
Reported: 2015-04-15 05:20 UTC by Niels de Vos
Modified: 2016-06-16 12:51 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1211837 1211840 1211841 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:51:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-04-15 05:20:53 UTC
Description of problem:
The version in glusterfs-api.pc has moved backwards, breaking existing versioned dependencies in QEMU.

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
100%

Steps to Reproduce:
1. rebuild QEMU
2. notice missing dependencies, support for gluster:// storage will be missing

Additional info:
http://thread.gmane.org/gmane.comp.emulators.qemu/330176

Comment 1 Anand Avati 2015-04-21 11:20:01 UTC
REVIEW: http://review.gluster.org/10308 (build: correct the version in glusterfs-api.pc) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2015-04-21 11:21:18 UTC
REVIEW: http://review.gluster.org/10309 (build: correct the version in glusterfs-api.pc) posted (#1) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 3 Anand Avati 2015-04-24 12:22:12 UTC
COMMIT: http://review.gluster.org/10308 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 4973d0ea608147ff186f13ab51090f59986f1c9f
Author: Niels de Vos <ndevos@redhat.com>
Date:   Thu Apr 16 17:46:49 2015 +0530

    build: correct the version in glusterfs-api.pc
    
    The version in glusterfs-api.pc has moved backwards, breaking existing
    versioned dependencies in QEMU. The following table contains the
    GlusterFS version and the version for glusterfs-api.pc:
    
        .------------------------.
        | GlusterFS | pkg-config |
        |-----------+------------|
        |   3.4.x   |   4.3.4.x  |
        |   3.5.x   |   6.3.5.x  |
        |   3.6.x   |   7.3.6.x  |
        |   3.7.x   |   7.3.7.x  |
        |   master  |   7.x.y.z  |
        '------------------------'
    
    BUG: 1211836
    Change-Id: I62168a0ab4f0c78e61987371ae75a0d2dd56ced8
    URL: http://thread.gmane.org/gmane.comp.emulators.qemu/330176
    Reported-by: Andreas Färber <afaerber@suse.de>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/10308
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 14:44:59 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 5 Nagaprasad Sathyanarayana 2015-10-25 14:54:09 UTC
Fix for this bug is already made in a GlusterFS release. The cloned BZ has details of the fix and the release. Hence closing this mainline BZ.

Comment 6 Niels de Vos 2016-06-16 12:51:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.