Bug 1211840 - glusterfs-api.pc versioning breaks QEMU
Summary: glusterfs-api.pc versioning breaks QEMU
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.6.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact: Sudhir D
URL: http://thread.gmane.org/gmane.comp.em...
Whiteboard:
Depends On: 1211836
Blocks: glusterfs-3.6.4
TreeView+ depends on / blocked
 
Reported: 2015-04-15 05:24 UTC by Niels de Vos
Modified: 2016-02-04 15:27 UTC (History)
2 users (show)

Fixed In Version: glusterfs-v3.6.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1211836
Environment:
Last Closed: 2016-02-04 15:27:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-04-15 05:24:29 UTC
Description of problem:
The version in glusterfs-api.pc has moved backwards, breaking existing versioned dependencies in QEMU.

Version-Release number of selected component (if applicable):
3.6.2

How reproducible:
100%

Steps to Reproduce:
1. rebuild QEMU
2. notice missing dependencies, support for gluster:// storage will be missing

Additional info:
http://thread.gmane.org/gmane.comp.emulators.qemu/330176

Comment 1 Anand Avati 2015-04-21 11:22:17 UTC
REVIEW: http://review.gluster.org/10310 (build: correct the version in glusterfs-api.pc) posted (#1) for review on release-3.6 by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2015-04-30 01:38:37 UTC
REVIEW: http://review.gluster.org/10310 (build: correct the version in glusterfs-api.pc) posted (#2) for review on release-3.6 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Anand Avati 2015-05-05 19:41:57 UTC
COMMIT: http://review.gluster.org/10310 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit c5a76aa8e63eb614a4e77e98f4e1ce6efe467d6d
Author: Niels de Vos <ndevos@redhat.com>
Date:   Thu Apr 16 17:46:49 2015 +0530

    build: correct the version in glusterfs-api.pc
    
    The version in glusterfs-api.pc has moved backwards, breaking existing
    versioned dependencies in QEMU. The following table contains the
    GlusterFS version and the version for glusterfs-api.pc:
    
        .------------------------.
        | GlusterFS | pkg-config |
        |-----------+------------|
        |   3.4.x   |   4.3.4.x  |
        |   3.5.x   |   6.3.5.x  |
        |   3.6.x   |   7.3.6.x  |
        |   3.7.x   |   7.3.7.x  |
        |   master  |   7.x.y.z  |
        '------------------------'
    
    BUG: 1211840
    Change-Id: I62168a0ab4f0c78e61987371ae75a0d2dd56ced8
    URL: http://thread.gmane.org/gmane.comp.emulators.qemu/330176
    Reported-by: Andreas Färber <afaerber@suse.de>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/10310
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 4 Kaushal 2016-02-04 15:27:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.4, please open a new bug report.

glusterfs-v3.6.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2015-July/022826.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.