Bug 1211856
| Summary: | Ansible installer doesn't work with overlong hostname | ||
|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Gaoyun Pei <gpei> |
| Component: | Installer | Assignee: | Jason DeTiberus <jdetiber> |
| Status: | CLOSED ERRATA | QA Contact: | Gaoyun Pei <gpei> |
| Severity: | low | Docs Contact: | |
| Priority: | medium | ||
| Version: | 3.0.0 | CC: | bleanhar, cryan, dmcphers, jdetiber, jokerman, libra-bugs, libra-onpremise-devel, mmccomas |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2016-01-27 19:42:35 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Comment 3
Gaoyun Pei
2015-04-16 04:43:38 UTC
Once https://github.com/openshift/openshift-ansible/pull/924 is merged, we will no longer set the hostname on systems and will not be limited by the hostname length of hostnamed anymore. Got the same error as https://bugzilla.redhat.com/show_bug.cgi?id=1275395#c4 mentioned when testing with this PR. Now that https://github.com/openshift/openshift-ansible/pull/1165 is merged would you mind testing this to see if the error message for excessively long names is improved? Verify with the latest openshift-ansible master branch.
When installing with hostname more than 64 characters, ansible would abort the installation and prompt that the hostname length is invalid as below:
TASK: [openshift_common | fail ] **********************************************
failed: [10.66.x.x] => {"failed": true}
msg: openshift_hostname must be 64 characters or less
failed: [10.66.x.x] => {"failed": true}
msg: openshift_hostname must be 64 characters or less
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2016:0075 |