Bug 1211887 - Newly created menuentry title is nonsense
Summary: Newly created menuentry title is nonsense
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grubby
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker https://fedoraproject...
: 1212573 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-15 07:38 UTC by Petr Schindler
Modified: 2015-04-21 19:19 UTC (History)
9 users (show)

Fixed In Version: grubby-8.40-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 19:05:59 UTC
Type: Bug


Attachments (Terms of Use)
/var/log/grubby (22.80 KB, text/plain)
2015-04-15 07:38 UTC, Petr Schindler
no flags Details
grub screen (3.33 KB, image/png)
2015-04-15 14:24 UTC, Kamil Páral
no flags Details
grub.cfg (3.59 KB, text/plain)
2015-04-15 14:25 UTC, Kamil Páral
no flags Details

Description Petr Schindler 2015-04-15 07:38:30 UTC
Created attachment 1014610 [details]
/var/log/grubby

Description of problem:
The title of first entry is some random string. I updated to new grubby and new kernel. After reboot the newly created entry title is nonsense. Boot works normally if you chose that entry.

In grub.cfg there is 'H<EC>lq;^?'

grub2-mkconfig works fine.

Version-Release number of selected component (if applicable):
grubby-8.39-1.fc22.x86_64

How reproducible:
it happened after update to new version of grubby and new kernel and during installation of F22 Beta RC2 with updates testing.

Steps to Reproduce:
1. Install F22 Beta RC2 with updates testing

Actual results:
First menuentry is some random string

Expected results:
Correct menuentry

Additional info:
I propose this as a final blocker as it somehow violates this alpha criterion: "Any component which prominently identifies a Fedora release version number, code name or milestone (Alpha, Beta, Final) must do so correctly."

The grub doesn't show correct information about installed system. If there are another systems on the computer the grub doesn't provide efficient information about what the user is booting. Workaround would be to press 'e' and look what that entry boots which is not solution for everyone.

Comment 1 Kamil Páral 2015-04-15 14:24:00 UTC
Created attachment 1014804 [details]
grub screen

Reproduced easily, happens every time with the new grubby. Always some random characters, different every time (cool feature!).

Comment 2 Kamil Páral 2015-04-15 14:25:14 UTC
Created attachment 1014805 [details]
grub.cfg

Comment 3 Fedora Update System 2015-04-15 19:46:45 UTC
grubby-8.40-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/grubby-8.40-1.fc22

Comment 4 Fedora Blocker Bugs Application 2015-04-16 16:29:57 UTC
Proposed as a Blocker and Freeze Exception for 22-beta by Fedora user pwalter using the blocker tracking app because:

 Proposing as a blocker for Fedora 22 Beta, as it violates the following Alpha criterion:

"Any component which prominently identifies a Fedora release version number, code name or milestone (Alpha, Beta, Final) must do so correctly."

Comment 5 Adam Williamson 2015-04-16 17:03:25 UTC
-1 blocker, the affected grubby is not in the RC3 images and was never pushed stable.

Comment 6 Brian Lane 2015-04-16 17:12:32 UTC
*** Bug 1212573 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2015-04-17 18:36:59 UTC
Package grubby-8.40-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grubby-8.40-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6243/grubby-8.40-1.fc22
then log in and leave karma (feedback).

Comment 8 Petr Schindler 2015-04-20 17:47:48 UTC
Discussed at today's blocker review meeting [1].

This bug was rejected as Final Blocker - as the affected grubby build never went stable, there is no need to treat this bug as a release blocker.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-20/

Comment 9 Fedora Update System 2015-04-21 19:05:59 UTC
grubby-8.40-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.