Bug 1211907 - Updates are installed even though they were disabled in installation source
Summary: Updates are installed even though they were disabled in installation source
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1296905 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-15 08:21 UTC by Petr Schindler
Modified: 2016-04-25 07:58 UTC (History)
8 users (show)

Fixed In Version: anaconda-24.13.4-1 anaconda-24.13.4-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-23 23:46:01 UTC


Attachments (Terms of Use)
packaging.log (2.63 KB, text/plain)
2015-04-15 08:21 UTC, Petr Schindler
no flags Details
anaconda.log (20.83 KB, text/plain)
2015-04-15 14:11 UTC, Kamil Páral
no flags Details
dnf.log (307.34 KB, text/plain)
2015-04-15 14:11 UTC, Kamil Páral
no flags Details
dnf.rpm.log (89.35 KB, text/plain)
2015-04-15 14:11 UTC, Kamil Páral
no flags Details
journal.log (815.04 KB, text/plain)
2015-04-15 14:11 UTC, Kamil Páral
no flags Details
packaging.log (2.62 KB, text/plain)
2015-04-15 14:11 UTC, Kamil Páral
no flags Details
program.log (52.36 KB, text/plain)
2015-04-15 14:11 UTC, Kamil Páral
no flags Details
syslog (75.44 KB, text/plain)
2015-04-15 14:11 UTC, Kamil Páral
no flags Details
yum distro-sync --disablerepo=updates-testing (33.13 KB, text/plain)
2015-04-15 14:19 UTC, Kamil Páral
no flags Details
non-functional configuration option (64.97 KB, image/png)
2016-04-15 13:56 UTC, Kamil Páral
no flags Details
anaconda-ks.cfg (1.15 KB, text/plain)
2016-04-15 13:57 UTC, Kamil Páral
no flags Details
anaconda.log (206.51 KB, text/plain)
2016-04-15 13:57 UTC, Kamil Páral
no flags Details
dnf.log (40.46 KB, text/plain)
2016-04-15 13:57 UTC, Kamil Páral
no flags Details
journal.log (678.48 KB, text/plain)
2016-04-15 13:58 UTC, Kamil Páral
no flags Details
packaging.log (45.06 KB, text/plain)
2016-04-15 13:58 UTC, Kamil Páral
no flags Details
program.log (112.97 KB, text/plain)
2016-04-15 13:58 UTC, Kamil Páral
no flags Details
syslog (791.32 KB, text/plain)
2016-04-15 13:58 UTC, Kamil Páral
no flags Details

Description Petr Schindler 2015-04-15 08:21:48 UTC
Created attachment 1014622 [details]
packaging.log

Description of problem:
I tried to install fedora workstation from netinst without updates(-testing). I checked 'don't install updates' in 'Installation source'.

The installed system contains updated packages from updates-testing. This is in packaging.log:
11:32:36,232 INFO packaging: Disabled 'updates'
11:32:36,232 INFO packaging: Disabled 'updates-testing'

Version-Release number of selected component (if applicable):
anaconda 22.20.9-1
F22-Workstation-netinst-x86_64-Beta_RC2

How reproducible:
always

Steps to Reproduce:
1. boot netinst
2. go to Installation Source
3. check 'Don't install updates'

Actual results:
Anaconda installs updates

Expected results:
No updates are installed.

Additional info:

Comment 1 David Shea 2015-04-15 13:43:39 UTC
Please attach the other logs from /tmp (or at least dnf.log). What packages were installed that you think shouldn't have been?

Comment 2 Kamil Páral 2015-04-15 14:11:06 UTC
Created attachment 1014791 [details]
anaconda.log

Comment 3 Kamil Páral 2015-04-15 14:11:10 UTC
Created attachment 1014792 [details]
dnf.log

Comment 4 Kamil Páral 2015-04-15 14:11:14 UTC
Created attachment 1014793 [details]
dnf.rpm.log

Comment 5 Kamil Páral 2015-04-15 14:11:20 UTC
Created attachment 1014794 [details]
journal.log

Comment 6 Kamil Páral 2015-04-15 14:11:23 UTC
Created attachment 1014795 [details]
packaging.log

Comment 7 Kamil Páral 2015-04-15 14:11:26 UTC
Created attachment 1014796 [details]
program.log

Comment 8 Kamil Páral 2015-04-15 14:11:30 UTC
Created attachment 1014797 [details]
syslog

Comment 9 Kamil Páral 2015-04-15 14:19:05 UTC
Created attachment 1014800 [details]
yum distro-sync --disablerepo=updates-testing

Reproduced. The logs are attached above. I also attach output of yum distro-sync --disablerepo=updates-testing to show that updates-testing was indeed enabled -> it wants to downgrade plenty of packages. (Using yum, because dnf is not talkative in this case).

Comment 10 David Shea 2016-01-08 19:56:56 UTC
*** Bug 1296905 has been marked as a duplicate of this bug. ***

Comment 11 Kamil Páral 2016-04-15 13:55:11 UTC
Still trivially reproducible with Fedora-24-20160411.n.1 Workstation netinst and anaconda 24.13.3-1. The system is always installed fully updated, even though I'd like to install it without updates (updates-testing, in this case).

Also note that the "don't install latest updates" checkbox gets unchecked after any operation in the Installation Source spoke.

Can we please increase priority here? This functionality is really useful when testing a number of issues in Fedora and this bug complicates QA's life. Thank you.

Comment 12 Kamil Páral 2016-04-15 13:56:42 UTC
Created attachment 1147656 [details]
non-functional configuration option

Comment 13 Kamil Páral 2016-04-15 13:57:45 UTC
Created attachment 1147657 [details]
anaconda-ks.cfg

Comment 14 Kamil Páral 2016-04-15 13:57:51 UTC
Created attachment 1147658 [details]
anaconda.log

Comment 15 Kamil Páral 2016-04-15 13:57:57 UTC
Created attachment 1147659 [details]
dnf.log

Comment 16 Kamil Páral 2016-04-15 13:58:08 UTC
Created attachment 1147660 [details]
journal.log

Comment 17 Kamil Páral 2016-04-15 13:58:14 UTC
Created attachment 1147661 [details]
packaging.log

Comment 18 Kamil Páral 2016-04-15 13:58:20 UTC
Created attachment 1147662 [details]
program.log

Comment 19 Kamil Páral 2016-04-15 13:58:36 UTC
Created attachment 1147663 [details]
syslog

Comment 21 Fedora Update System 2016-04-18 20:56:51 UTC
python-blivet-1.20.0-1.fc24 anaconda-24.13.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-45ca29d07c

Comment 22 Fedora Update System 2016-04-19 20:25:29 UTC
anaconda-24.13.4-1.fc24, python-blivet-1.20.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-45ca29d07c

Comment 23 Fedora Update System 2016-04-23 23:45:30 UTC
anaconda-24.13.4-1.fc24, python-blivet-1.20.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Kamil Páral 2016-04-25 07:58:35 UTC
Seems to work now, thanks!


Note You need to log in before you can comment on or make changes to this bug.