Bug 121227 - Keyboard still locked up with new kernels
Keyboard still locked up with new kernels
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 127829 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-19 09:27 EDT by Sammy
Modified: 2015-01-04 17:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 00:14:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vxx (9.31 KB, text/plain)
2004-07-29 12:34 EDT, Sammy
no flags Details

  None (edit)
Description Sammy 2004-04-19 09:27:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en_US.UTF-8, en) (KHTML, like Gecko)

Description of problem:
I have had this problem for a long time now. All packages updated
daily to the development tree, machine DELL precision 350 with
hyperthreading and running smp kernel. I have "pnpbios=off acpi=off"
in grub.conf. The keyboard is the standard DELL keyboard (PS/2).
My mouse is USB mouse. Mouse works fine.

The problem seems to be for the serio. For the non-working kernel
I get the message:

i8042.c: Can't read CTR while initializing i8042

For the working kernel (which is taking the source rpm and turning
off everything that I do not use, including acpi etc.) I get:

 kernel: serio: i8042 AUX port at 0x60,0x64 irq 12
 kernel: serio: i8042 KBD port at 0x60,0x6rq 1
 kernel: input: AT Translated Set 2 keyboard on isa0060/serio0





Version-Release number of selected component (if applicable):
kernel-2.6-1.32x

How reproducible:
Always

Steps to Reproduce:
1. Install the latest devel kernel
2. reboot machine
3. try keyboard
    

Additional info:
Comment 1 Sammy 2004-04-22 10:06:22 EDT
SOLUTION 
-------------- 
 
If you compile the USB support (ehci-hcd, ohci-hcd, and uhci-hcd only) then 
everything works perfectly and the keyboard is recognized and functional. 
I have heard this from other people as well. 
 
Any chance of making  this standard for  Fedora? 
 
Thanks 
Comment 2 Sammy 2004-07-14 10:22:29 EDT
Arjanv kernel 2.6.7-1.486 has the usb support compiled in and solves this 
problem. 
Comment 3 Alan Cox 2004-07-14 10:32:16 EDT
Unfortunatelty this breaks a collection of other x86-32 machines that
die on boot
Comment 4 Alan Cox 2004-07-14 10:32:58 EDT
(I've sent Arjan a test patch to fix the problem without compiling in
USB incidentally)
Comment 5 Alan Cox 2004-07-14 10:33:59 EDT
*** Bug 127829 has been marked as a duplicate of this bug. ***
Comment 6 Sammy 2004-07-16 11:10:04 EDT
I just tried kernel-smp-2.6.7-1.492 and unfortunately the same problem 
happened. 
 
 
Comment 7 Sammy 2004-07-29 11:42:14 EDT
I have tried the 1.499 arjanv smp kernel. The keyboard is still
locking up at boot with the same message about the CTR.
Comment 8 Alan Cox 2004-07-29 11:59:37 EDT
What exact messages do you see in this case, and can you also attach
an lspci -vxx (done with a working kernel or with usb legacy disabled
in the bios)
Comment 9 Sammy 2004-07-29 12:34:18 EDT
Created attachment 102286 [details]
output of lspci -vxx
Comment 10 Sammy 2004-07-29 12:36:20 EDT
I am getting the same message: 
 
kernel: i8042.c: Can't read CTR while initializing i8042. 
 
lspci -vxx is done on 1.492 with usb compiled in kernel. 
Comment 11 Alan Cox 2004-07-29 12:56:55 EDT
Does it also report "disabling USB legacy and retrying" before this ?
Comment 12 Sammy 2004-07-29 13:49:10 EDT
No...no such message...Few lines before the CTR errror are: 
 
 kernel: usbcore: registered new driver hiddev 
 kernel: usbcore: registered new driver usbhid 
 kernel: drivers/usb/input/hid-core.c: v2.0:USB HID core driver 
 kernel: mice: PS/2 mouse device common for all mice 
 kernel: i8042.c: Can't read CTR while initializing i8042. 
 
Comment 13 Dave Jones 2005-10-05 19:49:50 EDT
Is this still a problem in the current rawhide kernel ?
Comment 14 Mikael Hultgren 2005-10-06 04:16:01 EDT
No, for me its fixed in the current rawhide, and has been for some time.
Comment 15 Sammy 2005-10-06 10:33:37 EDT
Yes and No! The keyboard works fine after the reboot BUT is inactive during the
grub kernel selection stage.
Comment 16 Dave Jones 2005-10-06 15:56:46 EDT
at grub time, we're reliant upon the BIOS entirely for keyboard input, there's
nothing we can fix there.

You'll need 'usb legacy emulation' enabled in the bios for usb keyboard to work
at that stage.
Comment 17 oliver b. 2005-11-24 07:08:08 EST
I've compiled the 2.6.14.2 yesterday and have the same problem. Can't use the 
PS/2 keyboard. The error messages are the same.
How did you fix this?
Comment 18 oliver b. 2005-11-25 04:52:55 EST
Ok, I've disabled USB in BIOS and in the kernel. Now the keyboard works... 
Misterious...

Note You need to log in before you can comment on or make changes to this bug.