Bug 127829 - ps/2 keyboard won't work
ps/2 keyboard won't work
Status: CLOSED DUPLICATE of bug 121227
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-07-14 09:52 EDT by Mikael Hultgren
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-07-16 11:14:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mikael Hultgren 2004-07-14 09:52:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
System: Intel P4, 3.0GHz with Hyperthreading, 1024 MB RAM, standard
ps/2 swedish keyboard.

When i boot the smp kernel with acpi=on my keyboard wont work and
kudzu tries to remove it, also the following shows up in the boot logs.

ACPI: S3 and PAE do not like each other for now, S3 disabled.
i8042.c: Can't read CTR while initializing i8042.

If i the try to boot with either a non-smp kernel or with acpi=off on
the smp kernel, then the keyboard works, and the above messages don't
appear in the logs.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Use a PS/2 keyboard
2. Boot a smp kernel with acpi=on

Actual Results:  Keyboard isn't recognized. kudzu runs, presumably to
say that a
component has been removed (i.e. the keyboard) but as it only has a
keyboard interface that doesn't help much!)

Expected Results:  The keyboard should have worked.

Additional info:

This problem exists for me in fedora core 2 also with
kernel-smp-2.6.6-1.435.2.3, the kernels 2.6.5-1.358 and 2.6.5-1.358smp
didnt have this problem. see bug #126168
Comment 1 Alan Cox 2004-07-14 10:26:13 EDT
I've sent Arjan a possible patch for this. It seems to be a firmware
bug in E750x boards.
Comment 2 Alan Cox 2004-07-14 10:33:55 EDT

*** This bug has been marked as a duplicate of 121227 ***
Comment 3 Mikael Hultgren 2004-07-16 11:16:57 EDT
kernel-smp-2.6.7-1.492 solved this problem for me.

Note You need to log in before you can comment on or make changes to this bug.