Bug 1212385 - Disable rpc throttling for glusterfs protocol
Summary: Disable rpc throttling for glusterfs protocol
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Vijay Bellur
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1216310
TreeView+ depends on / blocked
 
Reported: 2015-04-16 10:06 UTC by Vijay Bellur
Modified: 2016-06-16 12:52 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1216310 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:52:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijay Bellur 2015-04-16 10:06:06 UTC
Description of problem:

RPC throttling is enabled for all rpcsvc programs. While the NFS rpcsvc program can benefit from throttling, the glusterfs rpcsvc program does not need throttling.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-04-16 10:11:54 UTC
REVIEW: http://review.gluster.org/10267 (rpc: Introduce attribute throttle for rpcsvc_t) posted (#1) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 2 Anand Avati 2015-04-16 10:11:59 UTC
REVIEW: http://review.gluster.org/10268 (rpc: Perform throttling conditionally) posted (#1) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 3 Anand Avati 2015-04-16 10:12:03 UTC
REVIEW: http://review.gluster.org/10269 (nfs: Enable throttling for rpcsvc) posted (#1) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 4 Anand Avati 2015-04-16 10:29:08 UTC
REVIEW: http://review.gluster.org/10267 (rpc: Introduce attribute throttle for rpcsvc_t) posted (#2) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 5 Anand Avati 2015-04-16 10:29:16 UTC
REVIEW: http://review.gluster.org/10269 (nfs: Enable throttling for rpcsvc) posted (#2) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 6 Anand Avati 2015-04-16 10:29:21 UTC
REVIEW: http://review.gluster.org/10268 (rpc: Perform throttling conditionally) posted (#2) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 7 Anand Avati 2015-04-29 04:30:45 UTC
COMMIT: http://review.gluster.org/10267 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit b04b957f2f27cf03958b456b3cec097d1e04923c
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Mon Apr 6 12:34:55 2015 +0530

    rpc: Introduce attribute throttle for rpcsvc_t
    
    This attribute will be used to set/unset throttling for
    a rpcsvc_t program subsequently.
    
    Following APIs have been added to get/set throttle.
    
    int
    rpcsvc_set_throttle (rpcsvc_t svc, gf_boolean_t value);
    
    gf_boolean_t
    rpcsvc_get_throttle (rpcsvc_t svc);
    
    Change-Id: Ica8a9166cef22eb92d81fe68e48d0a5e24a1ef95
    BUG: 1212385
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/10267
    Tested-by: NetBSD Build System
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 8 Anand Avati 2015-04-29 04:31:28 UTC
COMMIT: http://review.gluster.org/10268 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 32c35e175ac362a9682b10600044a5fe17441176
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Mon Apr 6 12:55:13 2015 +0530

    rpc: Perform throttling conditionally
    
    This change makes rpc's throttling to be performed only if
    attribute throttle is set in rpcsvc_t.
    
    Change-Id: I24620095570e206f5dc8fc6208fcf55cb22a1658
    BUG: 1212385
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/10268
    Tested-by: NetBSD Build System
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 9 Anand Avati 2015-04-29 04:31:46 UTC
COMMIT: http://review.gluster.org/10269 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 2bde49f98964724b9e12255539bd1a91b3c8b086
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Mon Apr 6 17:30:02 2015 +0530

    nfs: Enable throttling for rpcsvc
    
    Busy nfs servers need throttling to prevent duplicate requests
    from casuing an increase in memory consumption.
    
    Change-Id: I855bb1e841ba06b523e55f86f7788a0f7a49d444
    BUG: 1212385
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/10269
    Tested-by: NetBSD Build System
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 10 Nagaprasad Sathyanarayana 2015-10-25 14:46:50 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 11 Nagaprasad Sathyanarayana 2015-10-25 14:54:28 UTC
Fix for this bug is already made in a GlusterFS release. The cloned BZ has details of the fix and the release. Hence closing this mainline BZ.

Comment 12 Niels de Vos 2016-06-16 12:52:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.