Bug 1212392 - need to do extra Refresh work when initiate virtio-blk disk while boot guest with OVMF
Summary: need to do extra Refresh work when initiate virtio-blk disk while boot guest ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1224441 (view as bug list)
Depends On: 1195487
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-16 10:20 UTC by lijin
Modified: 2015-11-24 08:51 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:51:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
inititate screenshot (65.71 KB, image/png)
2015-04-16 11:53 UTC, lijin
no flags Details
create volume screenshot (66.05 KB, image/png)
2015-04-16 11:53 UTC, lijin
no flags Details
install win2k12R2 guest with viostor system disk (38.88 KB, image/png)
2015-04-22 07:59 UTC, lijin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description lijin 2015-04-16 10:20:18 UTC
Description of problem:
when initiate a virtio-blk-pci device,guest prompt a error message as attached.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.2.0-8.el7.x86_64
kernel-3.10.0-239.el7.x86_64
OVMF-20140822-7.git9ece15a.el7.x86_64
virtio-win-prewhql-103

How reproducible:
100%

Steps to Reproduce:
1.boot win2012R2 guest with OVMF:
/usr/libexec/qemu-kvm -name 103RNG2012R2ZAY -enable-kvm -m 4G -smp 4 -uuid d4c87374-40d9-4201-a6f3-374b5f2ba6f8 -nodefconfig -nodefaults -drive file=OVMF-test/OVMF_CODE.fd,if=pflash,format=raw,unit=0,readonly=on -drive file=OVMF-test/OVMF_VARS.fd,if=pflash,format=raw,unit=1 -drive id=cdrom1,if=none,cache=none,snapshot=off,aio=threads,file=OVMF-test/UefiShell.iso,media=cdrom -chardev socket,id=charmonitor,path=/tmp/103RNG2012R2ZAY,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=103BLK-testst.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_r2_x64_dvd_2707946.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=103RNG2012R2ZAY.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:11:1d:00:00,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:5 -vga cirrus -monitor stdio -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -drive file=test.raw,if=none,cache=none,id=drive11 -device virtio-blk-pci,drive=drive11,id=disk11

2.install virtio block driver 
3.in disk management,initiate the data disk as GPT
4.create new volume on the disk


Actual results:
after step3,disk management prompt "The operation failed to complete because the disk management console view is not up-to-date.Refresh the view by using the refresh task.If the problem persists close the disk management console,then restart disk management or restart the computer"(please check the first attachment);After right click "disk management",then select "Refresh",disk was initiated as GPT already.
after step4,a virtual disk manager window prompt "Incorrect function"(please check the second attachment);Still,after right click "disk management",then select "Refresh",disk volume was created without driver letter.

Expected results:
disk can be initiated smoothly without any error,and without any extra refresh work

Additional info:
virtio scsi does not hit this issue,disk can be initiated without any error

Comment 1 Laszlo Ersek 2015-04-16 10:27:36 UTC
Is this specific to OVMF? If you do the exact same installation & configuration procedure with SeaBIOS, is the warning absent?

I'm asking because I have no idea how this could be caused by OVMF. This should be assigned to virtio-win; the windows devs at least know how to narrow down such issues. I got no clue about windows.

Comment 3 Laszlo Ersek 2015-04-16 10:28:22 UTC
Also -- I think you may have forgotten to upload some screenshots.

Comment 4 Laszlo Ersek 2015-04-16 10:35:29 UTC
Moving to virtio-win due to comment 1.

Of course I could be wrong, and OVMF could be the culprit, but I'll need help from windows developers even to determine that. Thanks.

Comment 5 lijin 2015-04-16 11:53:18 UTC
Created attachment 1015163 [details]
inititate screenshot

Comment 6 lijin 2015-04-16 11:53:52 UTC
Created attachment 1015164 [details]
create volume screenshot

Comment 7 Mike Cao 2015-04-17 02:48:21 UTC
(In reply to Laszlo Ersek from comment #1)
> Is this specific to OVMF? If you do the exact same installation &
> configuration procedure with SeaBIOS, is the warning absent?
> 
> I'm asking because I have no idea how this could be caused by OVMF. This
> should be assigned to virtio-win; the windows devs at least know how to
> narrow down such issues. I got no clue about windows.

Hi, Laszlo

We did not hit this issue when using seabios.
Lijin confirmed that so such issue using virtio-scsi as well

Comment 8 Vadim Rozenfeld 2015-04-20 12:36:54 UTC
Is it reproducible with drivers from build 100?

Thanks,
Vadim.

Comment 9 lijin 2015-04-22 07:59:20 UTC
Created attachment 1017299 [details]
install win2k12R2 guest with viostor system disk

1.cannot reproduce this issue with build 100,disk can be formatted correctly.

2.BTW,install win2k12R2 guest with virtio-blk-pci SYSTEM disk,load viostor driver when required and then chose the system disk to install,guest installation can NOT continue(please check the screenshot).
Also cannot reproduce this issue with build100 and seabios,maybe the same issue with this bug

3.Our build 103 viostor whql job "Flush Test" is failed due to this bug.

Comment 12 Vadim Rozenfeld 2015-05-23 03:09:55 UTC
*** Bug 1224441 has been marked as a duplicate of this bug. ***

Comment 13 Vadim Rozenfeld 2015-05-24 06:15:00 UTC
please check it with the latest driver, available at 
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/104/win/virtio-win-prewhql-0.1.zip

Comment 15 lijin 2015-05-28 07:27:30 UTC
Reproduced this issue on build 103
Verified this issue on build 104

steps same as comment #0

Actual Results:
on build 103, errors prompt when initialize virtio-blk disk as GPT
on build 104, virtio-blk disk can be initialize as GPT and can create volume correctly

Based on above ,this issue has been fixed already.

Comment 17 errata-xmlrpc 2015-11-24 08:51:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.