Bug 1212413 - [RFE] Return proper error codes in case of snapshot failure
Summary: [RFE] Return proper error codes in case of snapshot failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard: Scheduler
Depends On: 1186216 1211643
Blocks: qe_tracker_everglades 1226117
TreeView+ depends on / blocked
 
Reported: 2015-04-16 11:10 UTC by Avra Sengupta
Modified: 2016-06-16 12:52 UTC (History)
13 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1186216
: 1226117 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:52:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-04-21 12:15:40 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct ret codes in events of failure - PATCH 1) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Avra Sengupta 2015-04-21 12:18:57 UTC
Submitted the first patch. Will be sending subsequent patches once this gets merged

Comment 3 Anand Avati 2015-04-22 06:09:25 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct ret codes in events of failure - PATCH 1) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 4 Anand Avati 2015-05-05 06:21:34 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 5 Anand Avati 2015-05-05 15:10:45 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 6 Anand Avati 2015-05-05 15:10:48 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 7 Anand Avati 2015-05-06 06:35:33 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 8 Anand Avati 2015-05-06 06:35:36 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#5) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 9 Anand Avati 2015-05-06 11:09:17 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 10 Anand Avati 2015-05-06 11:09:23 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#6) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 11 Anand Avati 2015-05-07 09:05:34 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 12 Anand Avati 2015-05-07 09:05:37 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#7) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 13 Anand Avati 2015-05-08 05:45:28 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#5) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 14 Anand Avati 2015-05-08 08:36:32 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#6) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 15 Anand Avati 2015-05-08 08:36:35 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#8) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 16 Anand Avati 2015-05-08 10:58:04 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#7) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 17 Anand Avati 2015-05-12 06:25:09 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#8) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 18 Anand Avati 2015-05-12 07:44:08 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#9) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 19 Anand Avati 2015-05-12 09:49:51 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#10) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 20 Anand Avati 2015-05-13 06:30:18 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#11) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 21 Anand Avati 2015-05-14 06:54:05 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#12) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 22 Anand Avati 2015-05-14 08:32:46 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#13) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 23 Anand Avati 2015-05-28 04:54:28 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#9) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 24 Anand Avati 2015-05-28 08:07:07 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#14) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 25 Anand Avati 2015-05-28 10:11:56 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#15) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 26 Anand Avati 2015-05-28 10:11:59 UTC
REVIEW: http://review.gluster.org/10313 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#10) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 27 Anand Avati 2015-05-29 02:38:08 UTC
COMMIT: http://review.gluster.org/10313 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 4397d7e72fdff6f01c59b72eebea421f23c1a392
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Tue May 5 10:58:10 2015 +0530

    glusterd/snapshot: Return correct errno in events of failure - PATCH 1
    
    RETCODE              ERROR
    -------------------------------------------
    30800                Internal Error
    30801                Another Transaction In Progress
    
    Change-Id: Ica7fd2e513b2c28717b6df73cfb2667725dbf057
    BUG: 1212413
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/10313
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 28 Anand Avati 2015-05-29 03:05:39 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#16) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 29 Anand Avati 2015-05-29 11:24:14 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#17) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 30 Anand Avati 2015-05-30 02:23:24 UTC
REVIEW: http://review.gluster.org/11010 (mgmt/glusterd: Add glusterd-errno.h to Makefile) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 31 Anand Avati 2015-06-01 07:11:07 UTC
REVIEW: http://review.gluster.org/10588 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#18) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 32 Nagaprasad Sathyanarayana 2015-10-25 14:42:29 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 33 Niels de Vos 2016-06-16 12:52:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.