Bug 1226117 - [RFE] Return proper error codes in case of snapshot failure
Summary: [RFE] Return proper error codes in case of snapshot failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard: Scheduler
Depends On: 1186216 1211643 1212413
Blocks: qe_tracker_everglades glusterfs-3.7.2
TreeView+ depends on / blocked
 
Reported: 2015-05-29 03:08 UTC by Avra Sengupta
Modified: 2015-06-20 09:49 UTC (History)
13 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1212413
Environment:
Last Closed: 2015-06-20 09:49:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-05-29 07:23:35 UTC
REVIEW: http://review.gluster.org/10991 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-05-30 03:59:23 UTC
REVIEW: http://review.gluster.org/11011 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-05-30 10:36:19 UTC
REVIEW: http://review.gluster.org/11011 (glusterd/snapshot: Return correct errno in events of failure - PATCH 1) posted (#2) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 4 Niels de Vos 2015-06-02 08:03:58 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Avra Sengupta 2015-06-02 10:13:04 UTC
Moving this back to post, as this has one more patch to be merged.

Comment 6 Anand Avati 2015-06-02 10:14:01 UTC
REVIEW: http://review.gluster.org/11042 (glusterd/snapshot: Return correct errno in events of failure - PATCH 2) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 7 Anand Avati 2015-06-09 14:18:44 UTC
COMMIT: http://review.gluster.org/11042 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 952ea9ae43d7668cf9661eb694757e17a2a6ae9e
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Tue May 5 18:08:25 2015 +0530

    glusterd/snapshot: Return correct errno in events of failure - PATCH 2
    
           Backport of http://review.gluster.org/#/c/10588/
    
    ENUM           RETCODE        ERROR
    -------------------------------------------------------------
    EG_INTRNL      30800          Internal Error
    EG_OPNOTSUP    30801          Gluster Op Not Supported
    EG_ANOTRANS    30802          Another Transaction in Progress
    EG_BRCKDWN     30803          One or more brick is down
    EG_NODEDWN     30804          One or more node is down
    EG_HRDLMT      30805          Hard Limit is reached
    EG_NOVOL       30806          Volume does not exist
    EG_NOSNAP      30807          Snap does not exist
    EG_RBALRUN     30808          Rebalance is running
    EG_VOLRUN      30809          Volume is running
    EG_VOLSTP      30810          Volume is not running
    EG_VOLEXST     30811          Volume exists
    EG_SNAPEXST    30812          Snapshot exists
    EG_ISSNAP      30813          Volume is a snap volume
    EG_GEOREPRUN   30814          Geo-Replication is running
    EG_NOTTHINP    30815          Bricks are not thinly provisioned
    
    Change-Id: I49a170cdfd77df11fe677e09f4e063d99b159275
    BUG: 1226117
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    (cherry picked from commit 2df57ab7dc7b9d7deb0eebad96036149760d607b)
    Reviewed-on: http://review.gluster.org/11042
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 8 Niels de Vos 2015-06-20 09:49:02 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.