Bug 121253 - hang when unloading usb-storage in the loader with .327 kernel
hang when unloading usb-storage in the loader with .327 kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
: 122397 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-19 15:31 EDT by Jeremy Katz
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 15:40:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2004-04-19 15:31:03 EDT
When the loader goes to unload usb-storage (so that they're not sda),
the system sits and hangs looping forever.  It looks like rmmod is in
D state with call trace of wait_for_zero_refcount. 

This worked previously, I'll try going back a few days rawhide-wise to
see when it broke, but it's in the past week or so.

Note that this blocks installation on any machine with a usb-storage
device.
Comment 1 Jeremy Katz 2004-04-19 15:41:40 EDT
Works with .322, broken with .326
Comment 2 Jeremy Katz 2004-05-06 18:19:48 EDT
*** Bug 122397 has been marked as a duplicate of this bug. ***
Comment 3 Arjan van de Ven 2004-05-07 16:51:13 EDT
ok tentative fix in cvs
Comment 4 Jeremy Katz 2004-05-11 15:40:41 EDT
Fixed with newer kernels (358 or so)

Note You need to log in before you can comment on or make changes to this bug.