Bug 121265 - no graphical installer on iMac DV
no graphical installer on iMac DV
Status: CLOSED DUPLICATE of bug 149188
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-04-19 16:24 EDT by Guy Streeter
Modified: 2016-02-09 20:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guy Streeter 2004-04-19 16:24:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040404 Firefox/0.8

Description of problem:
screen turns dark after probing for the mouse.
I tried adding video=aty128fb to the commandline. it didn't make any
difference.

Version-Release number of selected component (if applicable):
anaconda-9.92-5

How reproducible:
Always

Steps to Reproduce:
1. try to install on an iMac DV
2.
3.
    

Actual Results:  screen goes black

Expected Results:  screen doesn't go black

Additional info:
Comment 1 David Woodhouse 2004-04-19 16:37:35 EDT
We possibly need to use  
Option     "UseFBDev" "true"   

We certainly need that on the new PowerBook.
Comment 2 Colin Charles 2004-05-15 00:44:38 EDT
It doesn't start a graphical install even on an iBook G4 - Radeon 9200
video card here.
Comment 3 Bastien Nocera 2004-06-10 06:05:23 EDT
I have the same problem during the installation, and after boot on an
iBook G3 500 (dual-USB). I saw in the dmesg logs:
aty128fb: Invalid ROM signature e7c6 should be 0xaa55

My screen doesn't go black, but displays garbage (that's usually what
happens when the screen setup is buggered on my iBook).
Comment 4 Colin Charles 2004-08-22 19:33:37 EDT
As in Comment #2, this has been "fixed". Booting with mac, uses the
vesa drivers now, so you get nice X. Will test on iMac DV soon...
Comment 5 Paul Nasrat 2004-08-26 07:35:02 EDT
iMac DV still exhibiting black screen as of yesterdays rawhide.
Comment 6 Colin Charles 2004-08-31 05:40:12 EDT
ddcprobe during the startup detects it as the ATI Rage 128 with the
iMac as a monitor type. However, I can confirm that with yesterday's
rawhide too, the screen is all black, and there is no graphical
installer working

Passing video=aty128fb didn't help either
Comment 7 Yvan BARTHELEMY 2004-10-09 12:59:57 EDT
I have the same problem. Screen goes black after downloading the second part of 
installation and showing video, screen and mouse detection.

I run a PowerMac3,5 with a nVIDIA GeForce 4 MX 64MB
Comment 8 Ralf Ertzinger 2004-10-27 07:03:43 EDT
As for Comment #3, this seems to be a resolution thing. All should be
well if the installer tried 1024x768 instead of 640x480.
Maybe this helps with other macs, too.
Comment 9 Paul Nasrat 2004-10-27 07:13:21 EDT
Re comment #8 - can you test by booting the installer by passing
resolution as an argument eg:

yaboot ...
boot: linux resolution=1024x768

Comment 10 Colin Charles 2004-11-05 00:11:01 EST
Paul: done. linux resoluton=1024x768 just works on the iMac DV. I'm
doing a FC3 install now (rawhide 1104 tree), and for the first time am
I seeing goodness of anaconda with graphics on this box ;)
Comment 11 Soetji Anto 2005-01-21 22:18:33 EST
I am installing on iBook G3 (White) and have the same problem. Got jumbled up
graphics and have to run "linux text". I tried linux resolution=1024x768 and it
didn't help.

Before it got into the graphical mode it said:
probing for monitor type: unknown monitor
Comment 12 Paul Nasrat 2005-02-01 14:29:55 EST
Soetji - could you tell me what tree you are installing.
Comment 13 Soetji Anto 2005-02-01 15:33:11 EST
I downloaded the CD images from:
http://fedoraproject.org/fedorappc/FC-3/isos/

The gui worked only after I ran Xautoconfig, removed
/etc/X11/xorg.conf, and ran system-config-display.
Comment 14 David Woodhouse 2005-02-20 10:41:42 EST

*** This bug has been marked as a duplicate of 149188 ***
Comment 15 Colin Charles 2005-03-07 22:17:52 EST
I know this bug is closed, but rawhide as of March 7th doesn't do a graphical
install... I thought it got fixed, but it doesn't. Unsure if its selinux related

avc: denied {associate} for pid=560 exe=/mnt/runtime/usr/bin/python name=rpm
scontext=user_u:object_r:root_t tcontext=system_u:object_r:root_t tclass=filesystem

(from vt3, iirc)

linux text worksforme though
Comment 16 Red Hat Bugzilla 2006-02-21 14:02:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.