Bug 149188 - RHPL doesn't handle Mac X configuration well.
Summary: RHPL doesn't handle Mac X configuration well.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
: 121265 136044 136168 136173 151380 155483 (view as bug list)
Depends On:
Blocks: fedora-ppc
TreeView+ depends on / blocked
 
Reported: 2005-02-20 15:33 UTC by David Woodhouse
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 00:34:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2005-02-20 15:33:07 UTC
Graphical install and subsequent X configuration on some Mac hardware is broken.

Comment 1 David Woodhouse 2005-02-20 15:38:31 UTC
This helps with the G3 PowerBook I tested, but we still don't ever seem to parse
the server's output and get the panel size right. 

--- xserver.py.orig     2004-04-15 17:23:32.000000000 +0100
+++ xserver.py  2005-02-20 15:31:38.000000000 +0000
@@ -121,8 +121,8 @@
     attempt = 'PROBED'

     # use the framebuffer server by default on ppc
-    if rhpl.getArch() == "ppc":
-        attempt = "FB"
+#    if rhpl.getArch() == "ppc":
+#        attempt = "FB"

     orig_hsync = monitor.getMonitorHorizSync()
     orig_vsync = monitor.getMonitorVertSync()
@@ -199,6 +199,8 @@
                                                probeflags=XF86HW_PROBE_NONE)
                    hwstate.set_resolution(test_resolution)
                    hwstate.set_videocard_card(card)
+                    if rhpl.getArch() == "ppc":
+                        hwstate.videocard_options.append(("UseFBDev", "True"))

                    testx(hwstate, mouse, keyboard, logfile=logfile,
                          xStartedCB = xStartedCB, xQuitCB = xQuitCB)


Comment 2 David Woodhouse 2005-02-20 15:42:06 UTC
*** Bug 121265 has been marked as a duplicate of this bug. ***

Comment 3 David Woodhouse 2005-02-20 15:42:54 UTC
*** Bug 136173 has been marked as a duplicate of this bug. ***

Comment 4 David Woodhouse 2005-02-20 15:43:18 UTC
*** Bug 136168 has been marked as a duplicate of this bug. ***

Comment 5 David Woodhouse 2005-02-20 15:43:58 UTC
*** Bug 136044 has been marked as a duplicate of this bug. ***

Comment 8 David Woodhouse 2005-02-22 12:48:36 UTC
Users affected by this may want to use the Xautoconfig tool from
http://www.bytebot.net/geekdocs/ibook/Xautoconfig-0.22-1a.ppc.rpm
to automatically configure the X server. 

Comment 10 David Woodhouse 2005-02-24 08:56:34 UTC
Note that the ATI driver doesn't recognise the 'UseFBDev' option, and silently
ignores it. It _ought_ to recognise and honour it though -- as it doesn't cause
any harm at the moment I suspect we should continue to give it.

We should probably revamp the screen detection code when the DDC probe fails too
-- if there's a framebuffer we can use the ioctls on /dev/fb0 to get our screen
mode. Xautoconfig has an example of this.

Comment 11 Jeremy Katz 2005-04-27 23:05:07 UTC
*** Bug 151380 has been marked as a duplicate of this bug. ***

Comment 12 David Woodhouse 2005-04-29 07:44:04 UTC
*** Bug 155483 has been marked as a duplicate of this bug. ***

Comment 13 Jeremy Katz 2005-05-03 02:23:31 UTC
We try to do something along this line of thought now, but it's still not 100%.  :/


Note You need to log in before you can comment on or make changes to this bug.