Bug 121303 - Virtualhost directives being confused
Virtualhost directives being confused
Status: CLOSED DUPLICATE of bug 110861
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 05:07 EDT by David While
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David While 2004-04-20 05:07:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
If you place a directive in a Virtualhost and not in others, then on 
occasions the directive is applied to those Virtualhosts that don't 
contain it.

For example I have a configuration file with around 300 Virtualhosts 
in it. In two I have the directive php_flag engine off (to turn off 
PHP)

On occasions those sites using PHP (without the directive) will fail 
to work.

The workaraound is to make sure that the directive appears in every 
VirtualHost or none at all.

Version-Release number of selected component (if applicable):
2.0.48

How reproducible:
Always

Steps to Reproduce:
1. Create a config file with a directive in one Virtualhost but not 
others.
2.
3.
    

Actual Results:  The user is prompted to download the php file 
instead of it being displayed.

Expected Results:  The page should display correctly.

Additional info:

This is running on a 2 CPU system running the 2.4.22-1-2179.nptlsmp 
kernel
Comment 1 Joe Orton 2004-04-20 05:18:26 EDT
Please try the test packages at:

http://people.redhat.com/jorton/FedoraC1-php/

and post feedback to bug 110861.

*** This bug has been marked as a duplicate of 110861 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.