Bug 1213059 - git instaweb depends on lighttpd
Summary: git instaweb depends on lighttpd
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: git   
(Show other bugs)
Version: 7.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: Leos Pol
Marie Dolezelova
URL:
Whiteboard:
Keywords: FastFix, Patch
Depends On: 1598184
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-18 09:29 UTC by Matěj Cepl
Modified: 2018-10-30 11:38 UTC (History)
11 users (show)

Fixed In Version: git-1.8.3.1-19.el7
Doc Type: Bug Fix
Doc Text:
*git instaweb* now works without any additional configuration and it is available in a separate subpackage Previously, the *git instaweb* command required a web server and did not work in the default installation. With this update, *git instaweb* has been moved into the separate _git-instaweb_ subpackage, which depends on the *Apache* web server, and is configured to use the web server automatically. As a result, *git instaweb* now works without any further configuration when _git-instaweb_ is installed. To install the subpackage: # yum install git-instaweb
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 11:38:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (2.13 KB, patch)
2015-04-28 16:56 UTC, pstodulk
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3275 None None None 2018-10-30 11:38 UTC
Red Hat Bugzilla 1284081 None None None Never

Internal Trackers: 1284081

Description Matěj Cepl 2015-04-18 09:29:52 UTC
Description of problem:
When I run git instaweb on my current repository I get this error:

$ git instaweb
lighttpd not found. Install lighttpd or use --httpd to specify another httpd daemon.
$ 

Either git should depend on lighttpd (currently in EPEL) or git instaweb should be moved out to EPEL (or added to git-extras there).

Version-Release number of selected component (if applicable):
git-1.8.3.1-4.el7.x86_64

Comment 2 David Kutálek 2015-04-21 13:44:36 UTC
Is it actually possible to use other http as suggested - one which is included in RHEL? If so we could possibly patch to use different default?

Comment 3 Matěj Cepl 2015-04-21 16:09:53 UTC
(In reply to David Kutálek from comment #2)
> Is it actually possible to use other http as suggested - one which is
> included in RHEL? If so we could possibly patch to use different default?

Do we really want to have git pulling in Apache as a dependency (plus some configuration stuff)?

Anyway, I would really split git-instaweb into a separate package so that such disaster is at least a little bit mitigated.

Comment 4 David Kutálek 2015-04-22 15:25:21 UTC
(In reply to Matěj Cepl from comment #3)
> (In reply to David Kutálek from comment #2)
> > Is it actually possible to use other http as suggested - one which is
> > included in RHEL? If so we could possibly patch to use different default?
> 
> Do we really want to have git pulling in Apache as a dependency (plus some
> configuration stuff)?
> 
> Anyway, I would really split git-instaweb into a separate package so that
> such disaster is at least a little bit mitigated.

Sure, split makes a lot of sense to me here.

Comment 6 pstodulk 2015-04-28 16:56:48 UTC
Created attachment 1019804 [details]
patch

Comment 12 Matěj Cepl 2017-02-08 21:22:52 UTC
What's up with this bug?

Comment 13 pstodulk 2017-02-08 22:03:49 UTC
Thanks for remind. Git ia on ACL, but as I hear QA will have limited capacity.
I will talk with them about that. It would be great do this split at once with
the planned split of git-libgnome-keyring from the git package (bug #1284081).

It is on QA only. I am prepared to apply the fix when I will have permission
to do that.

Comment 19 Leos Pol 2018-07-25 11:42:42 UTC
# rpm -q git-instaweb
git-instaweb-1.8.3.1-18.el7.noarch
# rpm -qR git-instaweb-1.8.3.1-18.el7.noarch
/bin/sh
git = 1.8.3.1-18.el7
gitweb = 1.8.3.1-18.el7
httpd
mod_ssl
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

Comment 25 Pavel Cahyna 2018-08-30 11:22:45 UTC
Leos, can you add it to tests, please?

Comment 30 errata-xmlrpc 2018-10-30 11:38:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3275


Note You need to log in before you can comment on or make changes to this bug.