Bug 1213309 - [RFE][HC] - Support replace brick from UI
Summary: [RFE][HC] - Support replace brick from UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.0.0-beta
: 4.0.0
Assignee: Sahina Bose
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1390410 Generic_Hyper_Converged_Host 1217450 Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2015-04-20 10:13 UTC by Sahina Bose
Modified: 2016-11-01 01:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
You can now replace bricks for replicate type Gluster volumes and perform maintenance tasks from the Administration Portal.
Clone Of:
Environment:
Last Closed: 2016-08-17 14:36:38 UTC
oVirt Team: Gluster
ylavi: ovirt-4.0.0?
bmcclain: planning_ack+
sabose: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 43260 master MERGED engine: Support for replace brick 2016-05-05 12:30:37 UTC

Description Sahina Bose 2015-04-20 10:13:53 UTC
Description of problem:

In Hyperconverged mode, bricks need to be replaced before a host can be removed. To enable this, the engine needs to support replacing bricks. The UI should allow for replacing of one or all bricks on the host with equivalent from other hosts.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
NA

Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 10:54:27 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Mike McCune 2016-03-28 23:31:34 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 3 Sandro Bonazzola 2016-05-02 09:48:20 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 4 RamaKasturi 2016-08-17 11:25:45 UTC
Verified and works fine with build ovirt-engine-setup-4.0.2.6-0.1.el7ev.noarch

successfully replaced a brick when I/O is going on on the volume and self heal kicks in.

successfully replaced a brick which is down and self heal kicks in.

Replaced bricks from UI in engine, vmstore and data volumes. once self heal is completed, stopped and started all the vms and ran fio to make sure that none of the vms were broke.

A new event gets displayed when replace brick happens which is "Replaced brick '<old-brick>' with new brick '<new-brick>' of Gluster Volume <vol_name> on cluster <cluster_name>"


Note You need to log in before you can comment on or make changes to this bug.