Bug 121388 - Virtual PC 6.1.1 aborts with "An unrecoverable processor error has been encountered" early in boot process
Virtual PC 6.1.1 aborts with "An unrecoverable processor error has been encou...
Status: CLOSED DUPLICATE of bug 119838
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-20 21:22 EDT by Perry Wagle
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Wagle 2004-04-20 21:22:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/124 (KHTML, 
like Gecko) Safari/125.1

Description of problem:
VirtualPC for Mac is a x86 emulator that runs on G4 macintoshes and emulates an x86 
enough to run windows, linux, etc.

I installed fedora test2 from cdrom images just fine, but when I try to run it, immediately 
after the message "Uncompressing Linux... Ok, booting the kernel" has been printed on 
the console, VirtualPC halts the emulation and pops up the dialog "An unrecoverable 
processor error has been encountered" and gives you a button press to reboot.  Searching 
the web gives one other person with this same problem, but I see no response.

The cdrom images are: 

-rwxr--r--  1 wagle  staff  665059328 19 Apr 14:57 FC2-test2-i386-disc1.iso
-rwxr--r--  1 wagle  staff  665550848 19 Apr 14:59 FC2-test2-i386-disc2.iso
-rwxr--r--  1 wagle  staff  665747456 19 Apr 15:01 FC2-test2-i386-disc3.iso
-rwxr--r--  1 wagle  staff  180813824 19 Apr 15:01 FC2-test2-i386-disc4.iso

and the md5sums are:

fbf0c082c6096179bc4292086e39ecbc  FC2-test2-i386-disc1.iso
91cb7083c8a5d6bb003d09085d1f8753  FC2-test2-i386-disc2.iso
575e626c79503796ce11722861e2e885  FC2-test2-i386-disc3.iso
0e7be101b0e233e273f386983bfa28b4  FC2-test2-i386-disc4.iso


I can run "linux rescue" from the install cdrom image.

cat /proc/cpuinfo gives:

processor : 0
vendor_id : ConnectixCPU
cpu family : 6
model : 8
model name : ff/08
stepping : 4
cpu MHz: 486.364
...
cpuid level 2
wp : yes
flags : fpu vme pse tsc msr pae mce cx8 pge cmov mmx
bogomips : 2465.79

Earlier versions of virtualpc indicated that it ran a phoenix bios, but I haven't managed to 
interact with the bios with either VirtualPC 5.0 or Virtual 6.1.1.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  install fedora test2 from cdrom images on a macosx 10.3 G4 running virtual PC 6.1.1.  
this is painfully slow (10-12 hours), but it works fine.
2.  try to boot the installed os.  this doesnt work.

    

Actual Results:  the virtualpc emulator aborts with the message "An unrecoverable 
processor error has been encountered"  immediately after the linux boot process displays 
the message "Uncompressing Linux... Ok, booting the kernel".

Expected Results:  It should have continued the boot process.

Additional info:

The install and rescue kernels on the cdrom work fine.  The kernel installed on the (virtual) 
disk doesn't work.

This might be a problem that VirtualPC should fix.  But if we could tell them whats going 
wrong, then they would be more motivated to fix it.

If you don't have a Macintosh that runs virtualpc, I would be happy to perform any 
experiments and data collection you need.
Comment 1 Dave Jones 2004-04-21 09:52:48 EDT

*** This bug has been marked as a duplicate of 119838 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.