Bug 119838 - (VPC)Booting Fedora Core 2 causing Virtual PC processor error apparently due to self modifying code
(VPC)Booting Fedora Core 2 causing Virtual PC processor error apparently due ...
Status: CLOSED DUPLICATE of bug 136018
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 121388 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 10:34 EST by Stephan Somogyi
Modified: 2015-01-04 17:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 17:13:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot showing the boot state at the time of the processor error (28.09 KB, image/png)
2004-04-02 10:37 EST, Stephan Somogyi
no flags Details
config-2.6.7 and xorg.conf for working FC2 under Virtual PC (6.13 KB, application/octet-stream)
2004-07-01 23:30 EDT, David Sanders
no flags Details
Screen shot showing Fedora Core 2 running properly in Virtual PC 2004 (66.46 KB, image/jpeg)
2004-07-01 23:31 EDT, David Sanders
no flags Details
Screenshot of Fedora Core 3 Test 1 under Virtual PC 2004 (147.70 KB, image/jpeg)
2004-07-14 20:07 EDT, David Sanders
no flags Details
Fedora Core 3 Test 3 running under Virtual PC 2004 (104.37 KB, image/jpeg)
2004-10-16 15:59 EDT, David Sanders
no flags Details

  None (edit)
Description Stephan Somogyi 2004-04-02 10:34:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/124 (KHTML, like Gecko) Safari/125.1

Description of problem:
Under Core 2 Test 1, I was unable to even boot disc1.iso to install; I would hit enter at the first Fedora install screen and then immediately encounter the error.

With Core 2 Test 2, the installer no longer exhibits this problem, but after successfully installing C2T2, the first boot attempt causes the same issue.

The last text visible on screen is "Uncompressing Linux... Ok, booting the kernel."

At that point, Virtual PC (6.1.1 for Mac, running under 10.3.3, emulating i686) will generate an unrecoverable processor error.

I am fortunate to have been able to talk to the VPC folks about this problem and based on their investigation, this problem is caused by some self-modifying code.

Version-Release number of selected component (if applicable):
kernel 2.6.3-2.1.253.2.1

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora C2T2
2. After installation boot
3. Processor error occurs
    

Expected Results:  The system should've booted cleanly. Again, with C2T1, this problem happened while booting just the installer; C2T2 boots the installer just fine, but the first boot of an installed system causes the error.

Additional info:

I am happy to send a PNG of the screen at the time of the crash, but I can't quite find the UI to do that here.
Comment 1 Stephan Somogyi 2004-04-02 10:37:09 EST
Created attachment 99077 [details]
Screen shot showing the boot state at the time of the processor error
Comment 2 Dave Jones 2004-04-02 12:16:22 EST
The VPC folks need to be a lot more descriptive.
There's no information at all in this bug to work with.
If they can't provide a detailed analysis of the problem, afaics, its
virtualpc at fault.
Comment 3 Stephan Somogyi 2004-04-06 20:54:33 EDT
Just so that no-one thinks this is laying fallow, I am actively working on getting a detailed 
description of the problem with disassembly from the VPC folks. I hope to have these 
details within the next week.
Comment 4 Arjan van de Ven 2004-04-07 09:11:17 EDT
well the kernel does some self modifying code... but x86 allows that ...
Comment 5 Dave Jones 2004-04-21 09:52:51 EDT
*** Bug 121388 has been marked as a duplicate of this bug. ***
Comment 6 Alan Cox 2004-05-03 10:26:38 EDT
There are synchronization rules for self modifying code (synchronizing
instruction) but thats about it
Comment 7 Craig Feustel 2004-05-21 01:58:19 EDT
The same thing happens with MS Virtual PC 2004 (Build 582).

The following error displays in a popup:

An internal virtual machine error (13) has occurred.
The virtual machine will reset now.
Comment 8 Alex Le Bienvenu 2004-05-22 00:51:55 EDT
The same problem persists on the final release of Fedora Core 2 on 
virtual PC 2004.

Alex
Comment 9 Tomek Szczygiel 2004-05-23 21:12:36 EDT
I have the same problem during the install in GUI mode. Text mode
works fine but after the install during the reboot there are errors
coming during the X window load. 
Dave Jones. That can not be VCP problem since VMware is getting errors
at the same locations. However they can use vsdo=0 to bypass it. In
VPC that does not work. 
Comment 10 Tony 2004-05-24 12:48:46 EDT
I think the problem is related to x.org. I have virtual machines 
running Fedora Core 1 with kernel 2.6.5 and SUSE 9.1 Professional 
with kernel 2.6.4 and both run without any problem. However, when I 
tried to install Fedora Core 2 it failed like everyone else (crash 
when entering X). The only variable here is the X.org. 
Comment 11 Stephan Somogyi 2004-05-24 13:04:58 EDT
This thread has veered off into a different, separate bug. I don't know the protocol for 
splitting such threads.

The two bugs that I can identify are:

1) A processor error in the emulated VPC processor, which apparently has been repro'ed 
both with VPC Mac and VPC Win. This is the original bug I reported.

2) With the release of Core 2, it is no longer possible to install/run under VPC (and 
apparently VMWare as well). The hypothesis that there is an issue with x.org is plausible, 
but I'm not sure that it's proven yet.

I can confirm that I can't install FC2 on my configurations due to my screen going black -- 
and never to return -- shortly after anaconda launches during first install, and that this 
behavior is new to FC2 and was not present in FC2 Test 3. This apparent x.org issue has 
nothing at all to do with the processor error and really should be tracked as a separate 
bug. (And it's a really irritating one since it affects the ability to even begin an install and 
any fix would presumably require building a new first ISO.)
Comment 12 Perry Wagle 2004-05-24 14:36:42 EDT
On my MacOSX 10.3.3 powerbook running VirtualPC 6.1.1:

I was not able to install fedora core 2 with X windows.  I tried 3-4 times, and only the first 
time did I get a glimpse of the error message.  Something about not finding something, I 
think.  I'll try harder to retreive the error message if someone asks.

I WAS ABLE to install fedora core 2 with "linux text" at the install boot prompt.  It installs 
fine, but still can't boot.

I feel sure that X not being able to start for the install is a separate bug.
Comment 13 Marc Petitmermet 2004-05-25 15:21:52 EDT
I'm not really interested in the graphical staff because I want to use Fedora as server (I did 
not install x.org). I just wanted to add that booting with the rescue cd works without 
problems on MacOSX 10.3.3 and VirtualPC 5.0.4. So I guess it's more a kernel issue than 
an x.org issue. Now, if I only knew how to copy the kernel from the rescue cd to the VP 
drive...
Comment 14 Robert Citek 2004-06-14 02:30:09 EDT
The problem seems to be a combination of the kernel and the
initrd-2.6.5-1.358.img file.  See 

  http://cwelug.org/cgi-bin/wiki.cgi?FedoraCore2VPC

for the various combinations of kernel/initrds that I have tried so
far and for instructions on how to copy the Rescue CD's kernel and
initrd file to the /boot installation directory.

Regards,
- Robert 
( rwcitek at alum dot calberkeley dot org )

Comment 15 David Sanders 2004-07-01 21:47:18 EDT
I was able to install FC2 on Virtual PC 2004 by immediately 
replacing the stock kernel with a custom one and editing the
xorg.conf file.  Screen shot of FC2 running in virtual pc:
http://www.sandersweb.net/fedora.jpg
Comment 16 David Sanders 2004-07-01 23:30:44 EDT
Created attachment 101583 [details]
config-2.6.7 and xorg.conf for working FC2 under Virtual PC
Comment 17 David Sanders 2004-07-01 23:31:59 EDT
Created attachment 101584 [details]
Screen shot showing Fedora Core 2 running properly in Virtual PC 2004
Comment 18 David Sanders 2004-07-13 14:38:26 EDT
Fedora Core 2 Detailed Instructions (57 easy steps) for Virtual PC 2004
1. Download the 4 ISO images.
2. Download http://www.sandersweb.net/vpc.zip
This contains the kernel and some other config files.  It is rather
difficult to compile the kernel on a malfunctioning system so I'm
providing it to you.
3. Place vpc.zip in a shared folder (so we can get it later via samba)
4. Create a virtual machine
5. Boot from first ISO image
6. Type: "linux text" at the boot prompt
7. Select language (english)
8. Select keyboard (us)
9. Select Monitor (LCD Panel 800x600)
10. Select System Type (workstation)
11. Select Disk Partitioning (auto)
12. Select Remove all partitions
13. Select OK to confirm
14. Select bootloader (grub)
15. Select special options (none)
16. Select boot password (none)
17. Select OK to confirm boot loader
18. Select install boot loader into MBR
19. Network config - DHCP - or enter IP address etc.
20. Select hostname (whatever)
21. Select Firewall (enable)
22. Select additional languages (english)
23. Select Time Zone (whatever)
24. Select Root Password (whatever)
25. Select Package Defaults (customize)
26. Package Selection (whatever, except ensure you pick "Windows File
Server" since we will need samba later)
27. Install Media (continue)
28. (format hardisk)
29. (install packages)
30. Reboot
31. SEGMENTATION FAULT (ignore)
You will see a lot of error message, these can be safely ignored.
You may get segmentation faults on some of the below commands, just
try the command again until it works.
32. login as root
33. mount /proc
34. mount /boot
35. mount -o remount,rw /
36. modprobe tulip
37. ifup eth0 boot
38. cd /
39. Now we go get the vpc.zip file.
Type: smbclient //win2ksvr/Share -U david
But replace "win2ksvr" with the name of your computer and "Share" with
the name of your shared folder and "david" with your username on
XP/2000 host.
40. Enter your password for your host computer
41. Type: get vpc.zip
42. Type: quit
43. unzip -o vpc.zip
44. shutdown -r now  (or right-alt-del)
45. (Computer will hang when trying to shutdown)
46. From the VPC menu select Action->Reset
47. (reboots)
48. (Enters graphical setup menu)
49. Agree to the license agreement
50. Enable network time protocal (if you want)
51. Display setup (you can leave this as is for now)
52. Establish an user account
53. <additional CD's> - hit next
54. <finish setup> - hit next
55. Login
56. <All is well with the world>
57. Send me an e-mail to say it worked. 
Comment 19 David Sanders 2004-07-14 20:04:30 EDT
Fedora Core 3 Test1 experiences the same problem.  To install add step
43a.  cp /boot/grub/menu.lst /boot/grub/grub.conf
Comment 20 David Sanders 2004-07-14 20:07:30 EDT
Created attachment 101926 [details]
Screenshot of Fedora Core 3 Test 1 under Virtual PC 2004

Follow procedure give in bug report to install (with added step).
Comment 21 rainnyLin 2004-07-30 13:39:46 EDT
i got an error at step 39

error : can not determine network interfaces,you must use a 
interfaces config line .
Comment 22 David Sanders 2004-08-03 14:46:59 EDT
If step 39 did not work, your network didn't get setup right in step 37.
An alternative is to replace steps 36-42 with coping the file vpc.zip
from a CD-ROM (that you burned using your host operating system).
Comment 23 Rui Cardoso 2004-08-05 06:51:09 EDT
#18 works fine. Thanks David.
Comment 24 rainnyLin 2004-08-05 09:33:35 EDT
great! it's work.
thank you for help
Comment 25 gwilliam 2004-08-18 14:00:55 EDT
OK, but what mods did you make to the kernel?  I need to be able to 
build kernels.

Thanks.
Comment 26 David Sanders 2004-08-20 19:01:40 EDT
The kernel config is included in the zip.  It is just standard stuff,
nothing special.
Comment 27 Need Real Name 2004-09-07 06:05:28 EDT
Nothing works after I copied -R into the filesystem. Grup just hangs. 
I had /hda1 winXP on vfat /hda2 as boot and /hda3 as /
I tried changing 
kernel /vmlinuz-2.6.7 ro root=/dev/hda2
to
kernel /vmlinuz-2.6.7 ro root=/dev/hda3 
but same thing
What can I do?
thanks


Comment 28 Jaap 2004-09-11 17:48:08 EDT
Works excellent, got fedora running in no-time!
But...
To be able to rebuild the kernel it would be nice to know what the 
essential changes in the kernel config file need to be. 
David Sanders mentions about the mods; 'It is just standard stuff, 
nothing special'. Could you please be a little more explicit about 
the (probably) few changes that make the difference?

thanx a lot!
Comment 29 David Sanders 2004-09-13 20:31:23 EDT
The kernel config is in the zip.  Copy it to .config in your kernel
directory and do a make menuconfig.  This will allow you to see the
options selected and make any changes you want.

I don't know what one thing makes the difference.  The kernel is very
vanilla without any Redhat patches.  I just selected the options that
seemed appropriate to the emulated hardware.

For Need Name - You need to change the root XXX and kernel XXX to
match how you setup your filesystem.  I used /dev/hda1 as /boot and
/dev/hda2 and / and /dev/hda3 as swap. You will need to see the grub
documentation for how to change it.  
Comment 30 Chun Fong 2004-10-07 12:56:13 EDT
I'm still stuck after  Step 30 for the Comment  #18 From David Sanders  on 2004-07
-13 14:38. Did I miss something before rebooting ??
Comment 31 Chun Fong 2004-10-07 17:32:03 EDT
I followed the steps outlined in Comment #18 from David Sanders ,
but Linux did not reboot at Step 30. It still reports the processor problem.

I fail to see what is different in Comment #18 before step 30
than normal typical installation. Except the fact that vpc.zip is downloaded
into some shared folder somewhere... 

I'm a Linux NEWBIE, please explain in more detail how you got
past the step 30 reboot into segmentation faults INSTEAD of processor error.
Comment 32 SL 2004-10-11 16:42:15 EDT
All I'm getting when I attempt to unzip vpc.zip is a bunch 
of "checkdir error  cannot create..."
Comment 33 David Sanders 2004-10-16 15:49:50 EDT
Re Comment #31.  Chun, what processor are you using?  P4 Prescott? 
You should not be getting a processor error following in instruction
in step 30.  I need more info.

Re Comment #32.  SL, did you remount the root file system read-write
as in step 35?  If you got a segmentation fault, you have to re-try.
Comment 34 David Sanders 2004-10-16 15:52:50 EDT
Good news, you don't have to fight segmentation fault errors with
Fedora Core 3 Test 3.  Here is the new procedure.  The zip file is
posted to forum.

Fedora Core 3 Test 3 Install Instructions
1.  Download the 4 ISO images AND the rescue image.
2.  Download fedora3.zip
    This contains the kernel, initial ram disk, and config files.
3.  Place fedora3.zip in a shared folder (so we can get at it later
via SAMBA).
4.  Create a Virtual Machine
5.  Boot from the first ISO image.
6.  Press <ENTER> at the boot prompt for graphical install.
7.  Skip testing media (or test if you want).
8.  Select next to continue.
9.  Select "Install Anyway"
10. Select language (english)
11. Select keyboard (us)
12. Select installation type (workstation)
13. Select disk partitioning (auto)
14. Click <YES> at warning
15. Select "Remove all partitions on this system"
    and check "Review (and modify) partitions created"
16. Click <YES> at warning
17. Highlight "VolGroup00" and click delete
18. Highlight /dev/hda2 and click delete
19. click new, select mount point /, type ext3, size 15850 fixed, click OK
20. click new, select type swap, size 400 "fill to max allow size",
click OK
21. click NEXT
22. at boot loader screen click next
23. configure network device
    - configure using DHCP (or assign IP address)
    - activate on boot
    - set hostname (whatever)
24. configure firewall
    - enable
    - allow http,ftp,ssh (or whatever)
    - SELinux active
25. Set default language (english)
    Select any required additional languages
26. Select time zone (whatever)
27. Set root password
28. Select "Customize software packages to be installed"
29. Select packages (whatever, but ensure you select "Windows File Server"
    because we need samba)
30. Click next to start install then click continue
31. <formats file system>
32. <installs packages> (capture other CDs when prompted)
33. When install is complete, use the VPC menu to capture the rescue disk
    then click reboot
34. At the boot prompt press enter for rescue mode
35. choose language (english)
36. choose keyboard (us)
37. choose <YES> to "Do you want to start network...?"
38. Select configure using DHCP (or enter IP address)
39. Select continue to find install
40. Select <OK> to continue
41. You are now at a shell prompt
    Type: chroot /mnt/sysimage
42. Type: smbclient //win2ksvr/Share -U david
    but replace "win2ksvr" with the name of your host computer
    replace "Share" with the name of your shared folder
    and replace "david" with your username on the host.
43. enter password for host computer if prompted to do so
44. Type: get fedora3.zip
45. Type: quit
46. Type: unzip -o fedora3.zip
47. Release the rescue ISO from the VPC menu
48. Type: exit (twice)
49. <reboots>
50. Select 1st kernel from the grub menu
51. <startup and enter graphical setup program>
52. Click next
53. accept license agreement
54. set date and time and enable ntp (if you want)
55. Display Setup (you can leave this as is for now)
56. Establish user account
57. <additional CDs> - click next
    <finish setup> - click next
58. <Continues startup>
59. Login
60. <All is well with the world>

Comment 35 David Sanders 2004-10-16 15:58:23 EDT
Zip file was too large to post.  Download it from:
http://www.sandersweb.net/david/virtualpc/fedora3.zip
Comment 36 David Sanders 2004-10-16 15:59:55 EDT
Created attachment 105326 [details]
Fedora Core 3 Test 3 running under Virtual PC 2004
Comment 37 SL 2004-10-16 20:27:48 EDT
Re comment #33.  I was able to unzip the file using your tip, however 
I still don't go into X, but get multiple segmentation errors, and 
sometimes many other kinds of errors.  Each reboot give a different 
set of errors, although all include segmentation errors.

SL
Comment 38 Robert 2004-10-18 16:56:20 EDT
I am running Fedora Core 3 Test 3 running under Virtual PC 2004.  I 
finish graphical setup but i am stuck on step #42.  Is there a way to 
get the zip file into fedora by Cdrom?

Thx
Comment 39 SL 2004-10-20 22:21:05 EDT
I've discovered why I can't get into X after unzipping the file.  After:

32. login as root
33. mount /proc
34. mount /boot
35. mount -o remount,rw /
mount /dev/hdc
43. unzip -o /mnt/cdrom/vpc.zip

The file decompresses and appears to be decompressing into the proper
directories.  However, if I look in /boot I don't find anything about
the 2.6.7 kernel, and don't find the new grub.conf in /boot/grub.

S
Comment 40 David Sanders 2004-10-21 13:02:49 EDT
Re Comment #38 Robert, try downloading:
http://www.sandersweb.net/david/virtualpc/fedora3-updated.iso
Instead of using samba, capture the iso image and mount it.  Then copy
the zip to the root directory and unzip it per the instructions.

Re: Comment #39 SL, did you do a "cd /" before unzipping?
Comment 41 Robert 2004-10-21 18:02:44 EDT
David thanks for responding towards this issue. I did capture the iso 
image that was given by the link and I mount it in fedora text mode. 
I was unable to get it working because i am unsure how to copy the 
zip file to this operating system.  Sorry I am not too familiar with 
linux because I am just learning it!
Comment 42 David Sanders 2004-10-24 18:24:39 EDT
Re Comment #41 Robert, I think all you need to do is use the copy
command like:  "cp /media/dvdrom/fedora3-updated.zip ."  If it doesn't
work let me know.
Comment 43 Robert 2004-10-26 17:13:22 EDT
Thanks, David, this works GREAT!!
Comment 44 David Sanders 2004-11-03 15:23:58 EST
The problem has been determined to be the 4G/4G patch included in the
redhat supplied kernels.  Compiling a kernel without 4g4g mode fixes
the problem.
Comment 45 Need Real Name 2004-11-03 17:04:10 EST
That wasn't good enough on VPC 7, oddly, but once I turned off local apic and told it to 
build for a plain original pentium, i was ok, i should figure out which fixed it, but at this 
point i don't care. it does work now.
Comment 46 Dave Jones 2004-11-27 17:13:43 EST

*** This bug has been marked as a duplicate of 136018 ***
Comment 47 Erik Wright 2005-07-12 17:52:09 EDT
This website presents an alternative to smbclient and mount:

http://www.core.org.au/?p=133

I have tried, tried, and tried again to install FC4 on VPC7 for Mac to no avail.  The kernel RPM won't install 
due to a problem with the DSA key.  So I gave up and settled with FC3.  Oh, the website makes one 
mistake, use --force instead of -force in case you didn't know that.

Note You need to log in before you can comment on or make changes to this bug.