Bug 12139 - CD still mounted when asked to remove it
CD still mounted when asked to remove it
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 12163 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-12 14:26 EDT by Telsa Gwynne
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-22 15:16:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2000-06-12 14:26:32 EDT
At end of installation/upgrade process, presented with a screen of
"Remove the bootable medium and press Enter to continue". The CD is
apparently still mounted, and cannot be removed until -after- you've
hit the enter button to reboot -- at which stage you have approximately
ten seconds to reach the other side of the table, squat down, crawl 
under, and rescue the CD from the tray before the machine starts to 
boot back up.

umounting it would be good!
Comment 1 Brock Organ 2000-06-12 15:59:14 EDT
is this for an english language installation or another language ...?

All four english language screens (TUI install, GUI Install, TUI upgrade, TUI
install) say "Press return to reboot, and remove your medium as the system
reboots" ...
Comment 2 Dale Lovelace 2000-06-12 17:13:39 EDT
  I think what she is saying, and what a lot of people on testers-list are
saying, is that there is not enough time to remove the CD after installation,
before the machine reboots. If the CD was already unmounted before it started
the reboot process, you could manually eject it and take it out. This is
especially true if your machine happens to be a long way from your keyboard :-)
Comment 3 Dale Lovelace 2000-06-12 17:15:45 EDT
*** Bug 12163 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2000-06-12 21:24:56 EDT
And since the file with the actual installer is loopback mounted from the
installed system, it shouldn't be a problem to unmount the source image and give
a chance to eject and remove before hitting okay to reboot.
Comment 5 giulioo 2000-06-13 05:56:37 EDT
>All four english language screens (TUI install, GUI Install, TUI upgrade, TUI
>install) say "Press return to reboot, and remove your medium as the system
>reboots" ...

The Italian text message, re-translated in English, says:

"Press ENTER to reboot the system, and make sure to remove the CDROM or 
diskette."

There isn't any "as the system reboots".

Comment 6 Telsa Gwynne 2000-06-13 13:14:28 EDT
Yes, I had the precise wording wrong. The problem is as Dale says:
the first time I tried, I couldn't get the CD out in time, the second
time the CD drawer started to close as I removed the CD because the
machine was rebooting, (apparently machines close the drawer themselves)
and frightened the life out of me, and the third time I had to get my
husband to press enter whilst I squatted down by the box some distance
from the keyboard ready to capture the CD. Not optimal, no :)


Comment 7 David Balažic 2000-06-19 13:02:32 EDT
The wording in "Slovenian" also suggests to remove the CD first and then press 
NEXT.
Comment 8 Michael Fulbright 2000-06-22 15:16:03 EDT
Fixed in latest internal development version.

Note You need to log in before you can comment on or make changes to this bug.