Bug 1213912 - Directions for changing the Satellite Server FQDN (hostname) are incomplete and will cause pulp to fail.
Summary: Directions for changing the Satellite Server FQDN (hostname) are incomplete a...
Keywords:
Status: CLOSED DUPLICATE of bug 1152797
Alias: None
Deadline: 2015-04-23
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.8
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Eric Helms
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-21 14:23 UTC by Stuart R. Kirk
Modified: 2019-08-15 04:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-29 14:14:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 5020 None None None Never
Red Hat Bugzilla 1152797 None None None Never
Red Hat Bugzilla 1181283 None None None Never
Red Hat Knowledge Base (Solution) 1232133 None None None Never

Description Stuart R. Kirk 2015-04-21 14:23:43 UTC
Document URL: 
http://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/User_Guide/sect-Troubleshooting.html#idp27144192

Section Number and Name: 
16.3.1. Changing Your Red Hat Satellite's Fully Qualified Domain Name (FQDN)

Describe the issue: 
The documentation does not provide a complete mechanism for re-generating the required certificates with the $NEW_FQDN. Following the documentation as specified will not re-generate the required certificates for pulp or the qpidd broker service. 

Suggestions for improvement: 
Step 3 should be removed and replaced with:
-----------------------------------------------------
Back up the existing NSSDB:
mv /etc/pki/katello/nssdb /etc/pki/katello/nssdb-old
-----------------------------------------------------
Step 4 should be removed and replaced with:
-----------------------------------------------------
Re-run the katello installer (verbose debug)
katello-installer -v -d
-----------------------------------------------------

Additional information:

Comment 1 RHEL Program Management 2015-04-21 14:43:46 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 2 RHEL Program Management 2015-04-21 16:04:04 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Athene Chan 2015-04-21 22:48:16 UTC
Hi Stuart,

Thank you for your feedback! I have assigned this request to David O'Brien, one of our Satellite documentation writers. Our goal to have this changed will be for the 6.1 release.

Thank you again and let us know if you have other requests!

Cheers,
Athene

Comment 12 Andrew Dahms 2016-01-07 05:05:54 UTC
Moving to the default assignee.

Addition of this procedure into the documentation shall be considered during the Red Hat Satellite 6.2 documentation cycle should this functionality be available.

Comment 13 Bryan Kearney 2016-04-27 19:10:28 UTC
Upstream bug assigned to inecas@redhat.com

Comment 14 Bryan Kearney 2016-04-27 19:10:31 UTC
Upstream bug component is Installer

Comment 16 Bryan Kearney 2016-07-26 15:25:24 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 17 Bryan Kearney 2016-07-26 15:46:25 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 19 Bryan Kearney 2016-07-29 14:06:45 UTC
Upstream bug assigned to inecas@redhat.com

Comment 20 Stephen Benjamin 2016-07-29 14:14:20 UTC

*** This bug has been marked as a duplicate of bug 1152797 ***


Note You need to log in before you can comment on or make changes to this bug.