Bug 1152797 - [RFE] Provide Documentation to update Satellite FQDN and associated certificates (rename a Satellite)
Summary: [RFE] Provide Documentation to update Satellite FQDN and associated certifica...
Status: CLOSED DUPLICATE of bug 924383
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite-doc-list
QA Contact: satellite-doc-list
URL:
Whiteboard:
Keywords: FutureFeature
: 1181276 1181283 1213912 (view as bug list)
Depends On: 924383 1480346
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2014-10-15 01:22 UTC by Rich Jerrido
Modified: 2018-12-09 18:51 UTC (History)
16 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-08-04 15:47:52 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 924383 None CLOSED [RFE] Need a server side tool to assist with the process of changing the hostname of the Katello server 2019-05-23 19:24 UTC
Red Hat Bugzilla 1181283 None CLOSED error when changing fqdn and updating certs 2019-05-23 19:24 UTC
Red Hat Knowledge Base (Solution) 1232133 None None None Never

Internal Trackers: 924383 1181283 1213912

Description Rich Jerrido 2014-10-15 01:22:53 UTC
Document URL: https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html-single/Installation_Guide/index.html#Configuring_RednbspHat_Satellite_with_a_Custom_Server_Certificate

Section Number and Name: 2.3.2 - Configuring Red Hat Satellite with a Custom Server Certificate

Describe the issue: 

This RFE requests adding a section within the installation guide that covers how to change the fully qualifed domain name of a Satellite 6 instance, and update any/all SSL certificates to match the new hostname. 

This would ideally be placed as a chapter/section after section 2.3.2, as the other custom SSL certificate content is placed there. 


Suggestions for improvement: 

Additional information: 

This process is currently documented in the following KCS [https://access.redhat.com/solutions/1232133]

Comment 1 RHEL Product and Program Management 2014-10-15 01:42:54 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Athene Chan 2014-10-15 03:43:17 UTC
Thanks Rich! Adding to the requests queue!

Comment 13 RHEL Product and Program Management 2015-04-21 16:09:52 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 18 Hayley Hudgeons 2015-10-20 20:35:10 UTC
*** Bug 1181276 has been marked as a duplicate of this bug. ***

Comment 21 Mike McCune 2015-11-04 23:54:39 UTC
ALL:

There is no supported or tested routine for changing your Satellite 6.0 or 6.1 hostname. This will need to be added in Satellite 6.2 and should not be referenced in documentation or worked on until development of this feature is complete.

I also stated this very publicly here:

https://access.redhat.com/solutions/1315853

Comment 23 Mike McCune 2015-11-05 00:54:32 UTC
correction, the correct KCS is:

https://access.redhat.com/solutions/1232133

Comment 24 Stephen Wadeley 2016-02-17 08:26:02 UTC
Change flag to propose for 6.3, not 6.2, as the parent bug has just been changed:

 RHEL Product and Program Management 2016-02-16 15:07:19 EST
Flags: sat-6.3.0? → sat-6.3.0+

Comment 25 Kristof Van Damme 2016-04-14 15:03:10 UTC
A related question: is it possible to run Satellite 6 under a URL which is different from the hostname of the server it runs on ?

Comment 26 David O'Brien 2016-04-18 00:48:35 UTC
Reset docs contact <> daobrien

Comment 28 Stephen Benjamin 2016-07-29 14:12:35 UTC
*** Bug 1181283 has been marked as a duplicate of this bug. ***

Comment 29 Stephen Benjamin 2016-07-29 14:14:20 UTC
*** Bug 1213912 has been marked as a duplicate of this bug. ***

Comment 30 Mike McCune 2016-08-04 15:47:52 UTC

*** This bug has been marked as a duplicate of bug 924383 ***


Note You need to log in before you can comment on or make changes to this bug.